Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Richard Rees 26 posts 55 karma points
    Feb 11, 2018 @ 00:28
    Richard Rees

    Members missing in PublishedContent


    I have created a document type (course) with 2 properties.

    1. A Multinode Treepicker that picks from a node containing content of doctype "module"

    2. A Multinode Treepicker that picks from members.

    This was all working fine until the 7.7.10 upgrade (upgraded automatically by Umbraco Cloud), when suddenly the API is returning 0 rows for the members, even though there are members picked against the course node. It is still returning rows fine for modules I have picked against the course node.

    I have debugged and modules are coming through PublishedContent fine - members are not. I have tried removing the course doctype completely and saving and then re-adding it with new properties and then with some picked content but to no avail. Modules come though the API fine, Member do not.

    I have tried using the actual member picker instead and this brings back the member in the API no problem at all. But this is no good as it only allows one member to be picked.

    My issue is with the multinode treepicker set to look for members.

    Anyone else got this issue since 7.7.10? Anyone think what this issue could be and where I can look?

    The 7.7.11 upgrade hasn't fixed it.

    I am using ModelsBuilder API.



  • Richard Rees 26 posts 55 karma points
    Feb 12, 2018 @ 11:47
    Richard Rees

    Still no luck with this - is it a possible breaking change between 7.7.9 and 7.7.10?

  • Anders Bjerner 386 posts 2174 karma points MVP 2x admin c-trib
    Feb 12, 2018 @ 11:53
    Anders Bjerner

    An update may sometimes affect your Examine indexes. Have you tried rebuilding the internal members index (via the Developer section) to see whether that helps?


  • Richard Rees 26 posts 55 karma points
    Feb 12, 2018 @ 12:21
    Richard Rees

    Thanks for the reply Anders,

    It hasn't made a difference - As I mentioned in the original post, members added to the node via the member picker come through in PublishedContent fine.

    It is just members added via a Multinode Tree picker. I can see the added members in the back end. They just do not come through in PublishedContent.

    And they did come through in 7.7.9.

  • Richard Rees 26 posts 55 karma points
    Feb 12, 2018 @ 15:51
    Richard Rees

    Ok - more info

    I have created a brand new VS web app and installed 7.7.10 via nuget which gives me the sample site. I went onto the "people" doctype and added a new "Enrolledmembers" property and set it to Multinode treepicker set to members.

    I then created a member, and added that member to people via my new property.

    Opened the site, navigated to people, debugged. Model.Content.Enrolledmembers - Count = 0.

    I then created another VS Web app and installed 7.7.8 via nuget and repeated the exact same steps.

    When debugging, Model.Content.Enrolledmembers - Count = 1.

    This is a breaking change. This is worrying me because it got deployed automatically via Umbraco Cloud and has silently broken my site. Fortunately my live site isn't actually live yet.

    What is the process for raising a bug and getting it fixed?

  • Richard Rees 26 posts 55 karma points
    Feb 12, 2018 @ 17:03
    Richard Rees

    Looks like this is an issue and has already been logged

  • Alex Skrypnyk 4637 posts 16596 karma points MVP 2x admin
    Feb 13, 2018 @ 10:27
    Alex Skrypnyk

    Hi Richard

    Voted for the issue, hope that it will be fixed in next releases


Please Sign in or register to post replies

Write your reply to: