Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jin Botol 120 posts 271 karma points
    Aug 08, 2018 @ 03:08
    Jin Botol
    0

    Examine is not returning expected results

    Hi All,

    I badly need help, I am developing an existing site that uses Examine.

    It is working properly in Umbraco 7.5.6 but when I update it to Umbraco 7.11.1 is not properly working anymore, search is working but it's displaying 79 products instead of 88 products even if I add more products, it is still showing 79 products, but if I use @Model.Content.Children.Count() it shows the count of 88.

    Is the ExamineSearch affect after updating Umbraco to 7.11.1??

    Anyone can give ideas will be appreciate.

    Thanks

    Jin

  • Marc Goodson 673 posts 4234 karma points MVP 3x c-trib
    Aug 08, 2018 @ 07:10
    Marc Goodson
    0

    Hi Jin

    First of all have you tried to rebuild your Examine index from the Examine Management dashboard?

    enter image description here

    Rebuilding maybe all they need after the upgrade to begin functioning again.

    Next I'd have a look at the tracelogs that Umbraco produces /app_data/logs

    Have a look for any messages regarding Lucene and Lock Exceptions, eg are your examine indexes 'locked' and so aren't being updated?

    Recycling the application pool, will trigger the startup of Umbraco and then examine the logs for any further clues.

    Similarly check on disk where the examine index files are created, usually app_data/temp/ExamineIndexes/External/Index

    Check when the last date of one of these files was updated, gives you an indication as to whether Umbraco is updating the indexes successfully on disk or not.

    regards

    Marc

    (There was an update between your version hop to Examine: http://issues.umbraco.org/issue/U4-10735 which may be related to this)

  • Jin Botol 120 posts 271 karma points
    Aug 08, 2018 @ 08:01
    Jin Botol
    0

    Hi Marc,

    Yes I've already Rebuild Index but still no luck.

    There is not message for Lucene & Lock Exceptions.

    I think Examine is updated because it has 0.1.89 version it might be the latest version, but the Lucene.Net & Lucene.Net.Contrib it has a version of 2.9.4.1

    What should I look in the app_data/temp/ExamineIndexes/External/Index? Because I only have here.

    _8.cfs

    _9.cfs

    segments.gen

    segments_15

    write.lock

    Sorry for my bad English,

    Thanks

    Jin

  • Jin Botol 120 posts 271 karma points
    Aug 09, 2018 @ 05:08
    Jin Botol
    0

    Any ideas guys?

    Thanks

  • Marc Goodson 673 posts 4234 karma points MVP 3x c-trib
    Aug 09, 2018 @ 07:31
    Marc Goodson
    0

    Hi Jin

    So the examine index files on disk, when were they last updated? eg before or after the upgrade, when you publish a new page, is there a change in the index folder?

    Anything reported in the logs during the publish.

    In your Examine dashboards, does the Documents in index increase, when you add a new page?

    Can you find content via the Backoffice Examine Search, that isn't displayed on the front end of your site.

    Have you recycled application pool?

    Essentially trying to fathom, if your indexes are updating correctly, and your results are just not returnng the number you expect or whether the indexes are locked, and so aren't being updated / haven't been updated since your upgrade.

    regards

    Marc

  • Jin Botol 120 posts 271 karma points
    Aug 10, 2018 @ 03:11
    Jin Botol
    0

    Hi Marc,

    Thanks for your response.

    I never update or even edit this Examine Index Files.

    Yes, it has reports about ExamineStartup.

    I can't search the newly added product in Examine Search thru BackOffice.

    I am working first in my local before I transfer to Live Site.

    How would I know that my indexes are updating correctly or locked? Where can I locate this?

    Thanks,

    Jin

  • Jin Botol 120 posts 271 karma points
    Aug 11, 2018 @ 02:09
    Jin Botol
    0

    Hi all

    Ideas for this?? Am I missing something after upgrade?

    Thanks

  • Marc Goodson 673 posts 4234 karma points MVP 3x c-trib
    Aug 11, 2018 @ 12:40
    Marc Goodson
    0

    Hi Jin

    Did you establish whether the Examine files on disk are being updated?

    You are not meant to update or edit them yourself!

    But when a publish or new item is created in Umbraco, then Umbraco will update or add the details to the indexes, and these files will be updated, and their LastUpdated date will change on the file system!

    So what I'm hoping to be able to understand is, based on the dates of these files on disk, is when were they last updated? and are they being updated when new content is created or published in Umbraco.

    Eg is your problem related to the Examine indexes being locked or Umbraco not having the permissions to update them. after the upgrade or something else?

    Also realise the indexes are generated by Umbraco in the environment Umbraco runs, so you will need to rebuild your indexes locally and in the production environment after the upgrade.

    regards

    Marc

  • Jin Botol 120 posts 271 karma points
    Aug 14, 2018 @ 01:49
    Jin Botol
    0

    Hi Marc,

    I am really new in Umbraco.

    Can you point where Examine files on disk located?

    Thanks,

    Jin

  • Steve Temple 51 posts 263 karma points c-trib
    Aug 14, 2018 @ 08:46
    Steve Temple
    0

    What is your search, .Children will return all children but a search is usually filtering on some other field.

    Can you post the code that is doing the search?

  • Jin Botol 120 posts 271 karma points
    Aug 15, 2018 @ 06:06
    Jin Botol
    0

    Hi Steve,

    Thanks for your response.

    I am really new in Umbraco but I think it is not using .Children.

    I've already posted it here.

    Thanks,

    Jin

  • Jin Botol 120 posts 271 karma points
    Aug 16, 2018 @ 05:47
    Jin Botol
    0

    Hi guys

    Any solution?

    Thanks

    Jin

  • Jin Botol 120 posts 271 karma points
    Aug 21, 2018 @ 06:23
    Jin Botol
    0

    Hello, any helps?

    Thanks,

    Jin

Please Sign in or register to post replies

Write your reply to:

Draft