Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rickard Liljeberg 23 posts 113 karma points
    Oct 19, 2018 @ 13:44
    Rickard Liljeberg
    0

    Root node not found behind reverse proxy

    I am developing a site and have it behind an Application request routing proxy which forwards the request to the umbraco project and sets the "X-Forwarded-Host"

    To then make umbraco use that "X-Forwarded-Host" I have the following code. And as you can see from the watch at the bottom, everything seems correct.

    And this used to work until I upgraded to 7.12.3 today.

    Owin startup

    However if I now go to a controller (that overrides RenderMvcController) and there look at "Request.Url" it reports "http://ec-web.se:8788/"

    So it replaced the host but not the port. I have tried to replace LocalPort and setting port in Host (in the HeadersForwardOverrideMiddleware)

    However nothing seems to work.

    This also has the effect that it does not find my correct node (including root node - I have 3 root nodes). Instead it simply picks the first root node.

    How can I make it also respect the port I desire? I am also very open to another solution for configuring reverse proxy if there is a better way (rather than owin middlewhere)

  • Dale McCutcheon 22 posts 124 karma points
    Aug 27, 2019 @ 16:17
    Dale McCutcheon
    0

    Hey Rickard,

    Did you ever get this to work? we are currently having the same issue.

    Thanks Dale

  • Dale McCutcheon 22 posts 124 karma points
    Oct 18, 2019 @ 15:09
    Dale McCutcheon
    0

    We managed to get a fix implemented,

    Let me know if anyone thinks it would be useful to share and i will share the solution.

    Cheers Dale

  • Rickard Liljeberg 23 posts 113 karma points
    Oct 21, 2019 @ 15:05
    Rickard Liljeberg
    0

    Hey Dale!

    Sorry for never getting back to you, I did have a peek in the code but have had so much to do so I never got around to digging up what we did.

    I think it would be great if you posted your solution as I don't remember if I solved it or just did a workaround.

    And besides, I am sore more people will have this issue at some point too!

    //Rickard

Please Sign in or register to post replies

Write your reply to:

Draft