Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Harm-Jan Abbing 62 posts 102 karma points
    Jun 23, 2010 @ 16:52
    Harm-Jan Abbing
    0

    Keep getting no pages "Looks like there's still work to do" error

    Hi all,

    I'm having a lot of trouble getting pages to show. I just keep getting "Looks like there's still work to do". Things look alright in umbraco but no matter what i do, nothing shows front end. Also, there's no "link to document" in the document properties of the pages.

    The problem occurred after a much needed restart of the server (windows 2008 server) because of pending updates and sql server adjustments (for perfomance issues). Before that the website worked fine.

    Things i have tried include:
    - Republishing the enitire website
    - Restarting application pool, touch web.config
    - Making sure NETWORK SERVICE has full control for that folder
    - Duplicating the website with sql and folders copied

    All other websites running on the server are fine.

    Any help is much appreciated!

    (umbraco v 4.0.3)

    Kind regards,
    Harm

  • Stefan Kip 1613 posts 4125 karma points c-trib
    Jun 23, 2010 @ 17:35
    Stefan Kip
    0

    Try creating the "data\umbraco.config" again by deleting it (backup first) and then do some back-end actions (publish). I think that should solve it (we're having the same problem at the moment, at random moments it says 'Still some work to do'... Very very annoying)

  • Marco van Zomeren 5 posts 5 karma points
    Jun 24, 2010 @ 19:54
    Marco van Zomeren
    0

    thanks kipusoep, but this did not solve our problem. 

    Maybe someone can look into the following errors:

    Error adding stylesheet to tinymce (id: 1049). System.ArgumentException: No node exists with id '1049'     at umbraco.cms.businesslogic.CMSNode.setupNode() in d:\TeamCity\buildAgent\work\7380c184e9fcd3ea\umbraco\cms\businesslogic\CMSNode.cs:line 159     at umbraco.cms.businesslogic.CMSNode..ctor(Int32 Id) in d:\TeamCity\buildAgent\work\7380c184e9fcd3ea\umbraco\cms\businesslogic\CMSNode.cs:line 91     at umbraco.cms.businesslogic.web.StyleSheet..ctor(Int32 id) in d:\TeamCity\buildAgent\work\7380c184e9fcd3ea\umbraco\cms\businesslogic\web\StyleSheet.cs:line 78     at umbraco.editorControls.tinyMCE3.TinyMCE..ctor(IData Data, String Configuration) in d:\TeamCity\buildAgent\work\7380c184e9fcd3ea\components\editorControls\tinyMCE3\TinyMCE.cs:line 150

    -----------

    Error indexing node: (System.IO.IOException: read past EOF     at Lucene.Net.Store.BufferedIndexInput.Refill()     at Lucene.Net.Store.BufferedIndexInput.ReadByte()     at Lucene.Net.Store.BufferedIndexInput.ReadBytes(Byte[] b, Int32 offset, Int32 len)     at Lucene.Net.Index.SegmentReader.Norms(String field, Byte[] bytes, Int32 offset)     at Lucene.Net.Index.SegmentMerger.MergeNorms()     at Lucene.Net.Index.SegmentMerger.Merge()     at Lucene.Net.Index.IndexWriter.MergeSegments(Int32 minSegment, Int32 end)     at Lucene.Net.Index.IndexWriter.MergeSegments(Int32 minSegment)     at Lucene.Net.Index.IndexWriter.FlushRamSegments()     at Lucene.Net.Index.IndexWriter.Optimize()     at umbraco.cms.businesslogic.index.Indexer.IndexNode(Guid ObjectType, Int32 Id, String Text, String UserName, DateTime CreateDate, Hashtable Fields, Boolean Optimize) in d:\TeamCity\buildAgent\work\7380c184e9fcd3ea\umbraco\cms\businesslogic\index\Indexer.cs:line 199)
    -----------
    Error Republishing: System.ArgumentException: Item has already been added. Key in dictionary: '2402'  Key being added: '2402'     at System.Collections.Hashtable.Insert(Object key, Object nvalue, Boolean add)     at System.Collections.Hashtable.Add(Object key, Object value)     at umbraco.content.LoadContentFromDatabase(Boolean loadDocuments) in d:\TeamCity\buildAgent\work\7380c184e9fcd3ea\umbraco\presentation\content.cs:line 776

    Thanks, Marco

  • Harm-Jan Abbing 62 posts 102 karma points
    Jun 25, 2010 @ 09:48
    Harm-Jan Abbing
    0

    Turns out it was currupt content which resulted in umbraco.config not being generated correctly. Very nasty!

  • Matthias 87 posts 173 karma points
    Jun 25, 2010 @ 10:12
    Matthias
    0

    Hi,

    i had the same behaviour in a load balanced testing environment (with restricted access) until i allowed anonymous access to the website again in iis (Windows Server 2003).

    Matthias

  • gerald diva 11 posts 31 karma points
    Aug 19, 2010 @ 03:21
    gerald diva
    0

    Hey Harm-Jam,

    I am having the same issue. How did you fix the corrupt content?

    Gerald

  • Harm-Jan Abbing 62 posts 102 karma points
    Aug 19, 2010 @ 08:58
    Harm-Jan Abbing
    0

    Hi Gerald,

    Sadly i can't tell you how the content was fixed because i don't know. We had it done by another company.

    Have you tried recreating umbraco.config like kipusoep said? And are you sure all permissions are set correctly?

    Harm

  • gerald diva 11 posts 31 karma points
    Aug 19, 2010 @ 20:25
    gerald diva
    0

    Hi Harm,

     

    Yes I have tried what Kipusoep but it did not work. All permission are set correctly. Website is working properly, however, when critical updates were applied we are able to publish but the page does not look coorect and getting this in the error in Umbraco log:

    Error adding stylesheet to tinymce (id: 1179). System.ArgumentException: No node exists with id '1179' at umbraco.cms.businesslogic.CMSNode.setupNode() at umbraco.cms.businesslogic.web.StyleSheet..ctor(Int32 id) at umbraco.editorControls.tinyMCE3.TinyMCE..ctor(IData Data, String Configuration)

    Gerald

  • Dibar 92 posts 74 karma points
    Aug 19, 2010 @ 22:08
    Dibar
    0

    The no node existing errors relating to stylesheets stem, in my experience, from packages. In any case, you should be able to view your Richtext Editor datatypes in Developer section, and select which stylesheets you want associated, then save. I have found this will clear up the Error adding stylesheet reports. 

    "Corrupt content" refers in our case to non-printable characters. I did not find my non-printable characters in the content, though, but in my templates. The umbraco editor adds erroneous non-printing characters, which can get mixed in, but typically are the first and or last characters.

    To spot your npcs, open your templates in the umbraco gui, Ctrl+A to select all (this is important, vs mouse drag), then paste into an app that won't tolerate such shenanigans...I use Notepad++ and it changes the characters to ?s which I can delete. But you can't save this file using umbraco GUI, it will add the character back, so FTP it to overwrite your master pages sans <EOT> interspersed.

     

    This appears to have addressed unpublishing in my case, but not restarting.

    Anyway, check your TinyMCE Datatype.

  • Harm-Jan Abbing 62 posts 102 karma points
    Aug 20, 2010 @ 09:01
    Harm-Jan Abbing
    0

    If you're still stuck i could give you the information of the company that fixed it for us.

  • Peter 89 posts 160 karma points
    Aug 21, 2010 @ 12:22
    Peter
    0

    I am experiancing this problem with one of my sites. My assumption is that the problem was medium trust based or mysql based, as i've never experianced this issue with my MSSQL versions on full trust hosting. :(

    I have hunted npc (non printable characters) but no luck.

    I have also tried tinkering with the umbraco config and no luck there either.

     

  • Chris Gaskell 59 posts 142 karma points
    Dec 23, 2010 @ 11:30
    Chris Gaskell
    0

    Re: Error adding stylesheet to tinymce (id: .....

    I had this problem and fixed it by

    1. Go to developer section
    2. Open data types -> click 'Richtext editor'
    3. Add all stylesheets listed under 'Related stylesheets:'
    4. Save the Changes
    5. Deselect the stylesheets you dont wish to link to the RTE.

    This seemed to purge some bad data, I suspect a stylesheet has been linked to the RTE then deleted from disk.

    *Suspicion Only* - I havent done any research into it.

    HTH

    Chris.

  • Richard Han 19 posts 41 karma points
    Nov 16, 2016 @ 11:20
    Richard Han
    0

    Chris's solution works for me. thx.

Please Sign in or register to post replies

Write your reply to:

Draft