Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Chris White 23 posts 43 karma points
    Jun 25, 2010 @ 16:22
    Chris White
    0

    Issues installing Umbraco 4.5

    Hi all,

    Having a couple of issues with a blank Umbraco 4.5 installation. If I install and then choose to install the runway templates I get an exception stating "The given key was not present in the dictionary.".

    If I don't choose to install the runway templates it installs OK, but when I go into the editing UI all I can see is the top-level folder in each section (content, media, settings, developer, members) and if I right-click the menu appears as a thin grey line.

    Is anyone else seeing the same problems / got a solution ?

    Thanks,
    Chris

  • snitram 27 posts 48 karma points
    Jun 25, 2010 @ 20:04
    snitram
    0

    I've got the same problem.. tried lots of different approaches without any luck.

    Running a fresh local installation on Win7 Pro 64bit IIS7 with MySQL DB

    Any help would be largely appreciated :)

  • Dan Thayer 4 posts 24 karma points
    Jun 25, 2010 @ 20:53
    Dan Thayer
    0

    I ran into this problem starting with Umbraco 4.1 RC and have yet to find a solution.  I'm running Vista, SQLEXPRESS, .NET 4.0 for my development machine.  If anyone finds a solution, please post it here.

    Thanks!

    Dan

  • RolandWolters 42 posts 63 karma points
    Jun 25, 2010 @ 20:59
    RolandWolters
    0

    I am trying to get 4.5 running on my Win7 Pro 64bit IIS7 with MsSQLExpress but seem to be getting an error while trying to load the site. It is an error in the web.config. It says "config section web.extensions cannot be read because of a missing declaration for the section" (well actually the message is in dutch "Configuratiesectie system.web.extensions kan niet worden gelezen omdat een declaratie voor de sectie ontbreekt")

    Then it points to

    153:   <!-- ASPNETAJAX -->
      154:   <system.web.extensions>
      155:     <scripting>

    I did not edit the web.config (well i did at first fill in the database details but after seeing the errr I thougd i'd copy back the original web.config)

     

    Anyone ?

  • bitzi 6 posts 26 karma points
    Jun 25, 2010 @ 20:59
    bitzi
    0

    Oh, yes, I had the same problems on Win 7 64bit IIS 7.5 with MS SQL2008 server. I struggled for 2 days now to install Umbraco 4.5 but no luck so far. It would be nice to get some advice from those who actually succeeded to install version 4.5 (blank installation).

    thanks.

  • ben_a 65 posts 123 karma points
    Jun 25, 2010 @ 21:03
    ben_a
    1

    Regarding the <system.web.extensions> problem. Make sure you have .net 4.0 installed AND you've selected it as the .net version for your umbraco web instance. Then restart IIS.

  • RolandWolters 42 posts 63 karma points
    Jun 25, 2010 @ 21:06
    RolandWolters
    0

    yep, that was it. Thnx!

  • Morten Bock 1867 posts 2139 karma points MVP 2x admin c-trib
    Jun 25, 2010 @ 21:07
    Morten Bock
    0

    One thing that seems to have helped a lot of people is when you download the 4.5 zip file. Right click it and select "properties" and press the "unblock" button before unzipping the file to your website. 

    Also you might need to do a IIS Reset before the process updates the permission settings for the dll's.

    It's something that has not been a problem in previous versions, but I don't know the exact reason why it has started appearing now.

  • bitzi 6 posts 26 karma points
    Jun 25, 2010 @ 21:09
    bitzi
    0

    Doesn't work Ben. I tried many times, and I followed every time the steps as described here http://umbraco.org/documentation/books/install-umbraco-4-on-windows-vista?altTemplate=print   ; but it just doesn't take off. The application pool is set to .NET 4, using Classic mode. The binaries are in the wwwroot directory of IIS, no virtual directory used but no chance...

    thanks.

  • Morten Bock 1867 posts 2139 karma points MVP 2x admin c-trib
    Jun 25, 2010 @ 21:12
    Morten Bock
    0

    bitzi> Har you tried setting it to integrated mode? I think that is the default that the web.config expects in umb 4.5

  • snitram 27 posts 48 karma points
    Jun 25, 2010 @ 22:33
    snitram
    0

    I solved the problem by using winrar to unpack the binaries - 4.5 is now running smooth here :-)

  • bitzi 6 posts 26 karma points
    Jun 25, 2010 @ 23:03
    bitzi
    0

    Martin can you please tell me which application pool did you use? I see you have Win 7 64 bit like I do. I'm still struggling here.  With Integrated pipeline mode in application pool I get this error :

    HTTP Error 500.21 - Internal Server Error

    Handler "PageHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list

    Using Classic mode I kind of started  umbraco, but on the install page I'm not able to click next button, the page loaded with errors in both IE and firefox.

    Umbraco is the default web application, no virtual directory, full permission to all folders for NETWORK SERVICE  an IIS_IUSRS accounts.

    I pressed the Unblock button for the archive and I use winrar to unzip the files.

    I did not alter the default web.config file in any way. I also tried once to fill in the details required by the DB connection string but same result.

    I am logged in as administrator on my computer.

    What could be wrong ?

     

    thanks a lot.

  • Morten Bock 1867 posts 2139 karma points MVP 2x admin c-trib
    Jun 25, 2010 @ 23:54
    Morten Bock
    0

    I just tried at clean install on my Win7 64 bit machine, and I had no problem with the integrated pipeline error you mention above.

    The screendump you posted very much indicates that there is some sort of file permission error. I just recreated the error on my machine.

    If you look at the source of the install page, you will see a reference til css and javascript that link to the /Dependencyhandler.axd

    If you visit that link, you will probably see an exception like

    "Access to the path 'C:\inetpub\umb45.local\App_Data\ClientDependency\MORTENWKS01-map.xml' is denied."

    So try resetting you file permissions, copy the files from scratch, do an IIS Reset to clear permission caching, and see if you can get the client depency handler to not throw an exception.

  • Morten Bock 1867 posts 2139 karma points MVP 2x admin c-trib
    Jun 25, 2010 @ 23:58
    Morten Bock
    0

    Also, make sure that you chose .Net framework 4.0 as the runtime for your app pool.

    This thread suggests it could be caused be a faulty .Net 4.0 configuration, so you could try and run the aspnet_regiis.exe command that they suggest.

  • bitzi 6 posts 26 karma points
    Jun 26, 2010 @ 00:17
    bitzi
    0

    Hei Morten,

    i looked in the source file and I clicked the link but I didn't get any error. But the good news is that I made umbraco 4.5 run on my Win 7 x64 bit with IIS 7.5. YES, IT IS RUNNING! What I did was to add handler mappings on Default web site for *.aspx and *.axd files to use the .NET 4 framework aspnet_isapi.dll like this: C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll. I added handlers for both 32 and 64 bit version of .NET 4 framework. So, it wasn't the file permissions in my case but the handlers which were linking to the .NET 2.0 framework. Thanks a lot for your advices and patience. I really appreciate the work you've done with Umbraco.

    regards,

    another Umbraco 4.5 happy user.

  • Jens Ulrik 2 posts 22 karma points
    Jun 26, 2010 @ 01:12
    Jens Ulrik
    0

    Lucky you :-)

     

    I get the same error when app-pool is running 4.0 integrated mode as you did:

    HTTP Error 500.21 - Internal Server Error

    Handler "PageHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list

    in classic mode:

    HTTP Error 404.17 - Not Found

    The requested content appears to be script and will not be served by the static file handler.

     

    I am running:

    a clean win 7 pro 64bit.

    files from 4.5 unpacked zipfile copied unaltered to webroot in IIS7.5 

    Giving all permissions except full control to network service under rooot directory - did not help.

    givining iis_iusrs the same - did not help.

    creating new website in root bound to port 81, with a new appool 4.0 integrated mode - did not help.

     

    bitzi: can you explain what you did with the handler mappings? how come the others do not have the problem without altering the mapppings?

    Other ideas?

     

    Best Regards

    Jens Ulrik

  • Jens Ulrik 2 posts 22 karma points
    Jun 26, 2010 @ 01:44
    Jens Ulrik
    0

    OK - good news!

    I found that installing mssqlexpress 2008 after vs2010 can somehow corrupt the .NET 4, running the %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe –i command in an admin command prompt seemed to do the trick!

    - and by the way I have to use (local) as the servername in step 2/5. .\sqlexpress just didnt work...

     

    Now, I came to the umbraco install page and completed all steps.

     

    When chosing to have the runway templates installed I got a

     

    The given key was not present in the dictionary.

    but I think this is a well known problem, so unless somebody just knows the answer and post it here I will go and look for it in another posting.

     

  • Steen Tøttrup 191 posts 291 karma points c-trib
    Jun 26, 2010 @ 10:55
    Steen Tøttrup
    0

    I'm still getting the <system.web.extensions> error. I haven't installed Umbraco on an IIS, but is running it off the dev server from Visual Studio 2010 Web. The project has NET 4.0 set, but I still get the error.

    Any hints?

  • bitzi 6 posts 26 karma points
    Jun 26, 2010 @ 12:44
    bitzi
    0

    @Steen : it might help you to install AJAX first. Check this link: http://go.microsoft.com/fwlink/?LinkId=65212.

    @Jens: you don't have to add handler mappings manually if you run this %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe –i.

    I knwow you already did it but maybe a restart of IIS would help you.

    I would delete the umbraco DB, recreate it and try to install umbraco again.

    You can follow the steps from here: http://umbraco.org/documentation/books/install-umbraco-4-on-windows-vista?altTemplate=print

    I gave full permission to NETWORK SERVICE to my wwwroot folder and also the application pool is in Classic mode pipeline.

    See attached picture of my application pool (i created myself but you can modify existing one). See that identity is NetworkService.


  • Steen Tøttrup 191 posts 291 karma points c-trib
    Jun 26, 2010 @ 14:53
    Steen Tøttrup
    0

    @bitzi: Thanks for trying to help me, but it had nothing to do with the ajax tool kit (I already had that, I've been running v4.0.x for a while without issues).

    The problem was that I had selected the WebDev.WebServer20.exe instead of WebDev.WebServer40.exe. I never noticed that there was more than one exe in that folder until now, I'm sure that is something new (VS2010 ? or Windows 7 ?).

     

  • Chris White 23 posts 43 karma points
    Jun 28, 2010 @ 10:15
    Chris White
    0

    Thanks Martin - I used Winrar to unpack the binaries and things are fine for me now too - must be some sort of permissions issue on the files . . .

  • Carlos 338 posts 472 karma points
    Jun 30, 2010 @ 22:48
    Carlos
    0

    Can you guys put a link to installing the 4.5 version and make sure the requirements are added to the Codeplex page?  Maybe stating that .Net 4.0 is required. If we are trying to install this stuff. Most of us are assuming 3.5 is still in use because of your Umbraco 4.0 install guide and instructions. Or maybe on your site as well.

    Thanks,

  • Carlos 338 posts 472 karma points
    Jun 30, 2010 @ 22:51
    Carlos
    0

    Do we also need to use IIS 7.5 or is 7.0 sufficient?

  • Kim Andersen 1447 posts 2194 karma points MVP
    Jun 30, 2010 @ 22:54
    Kim Andersen
    0

    Hi carlos

    I have successfully set up an Umbraco 4.5 on a Windows Vista with IIS 7. So that shoud be sufficient :)

    /KIm A

  • Peter Dijksterhuis 1442 posts 1722 karma points
    Jun 30, 2010 @ 22:57
    Peter Dijksterhuis
    0

    For now, you can download a 3.5 version on the nightlies-page: http://nightly.umbraco.org/umbraco%204.1%20for%20asp.net%203.5/4.1/

    I think they will put that on codeplex as well

  • Jeff Grine 149 posts 189 karma points
    Jun 30, 2010 @ 23:14
    Jeff Grine
    0

    You can use .NET 3.5 with umbraco 4.5, but it's a bit of extra work. You really just the web.config, App_Browsers.dll, and App_global.asax.dll from the nightly link that Peter provided. See 3.5 for 4.5

  • Carlos 338 posts 472 karma points
    Jun 30, 2010 @ 23:16
    Carlos
    0

    Thanks Peter and Jeff. I think we may just upgrade to 4.0 anyways. We are going to be using Visual Studio 2010 and that already has 4.0 with it.

    Might as well move forward instead of falling back.

    Thanks

  • Carlos 338 posts 472 karma points
    Jun 30, 2010 @ 23:20
    Carlos
    0

    Awesome forums support here just to add.Thanks all

  • Carlos 338 posts 472 karma points
    Jun 30, 2010 @ 23:39
    Carlos
    0

    I got the latest nightly build for 4.1 for 3.5 or 4.5 for 3.5.  Is there a VistaDB. I done see it in the database types on the front end but I do see it in the data folder.  Where is it in the database dropdown?

  • Qube 74 posts 116 karma points
    Jul 01, 2010 @ 01:04
    Qube
    0

    In reply to the IIS requirements question, I have 4.5 running on II6. My dev environment is Windows 2003 32bit, and the live environment is Windows 2003 64bit. So far so good with fresh installs targetted to .NET 4.

  • Dan Thayer 4 posts 24 karma points
    Jul 01, 2010 @ 22:12
    Dan Thayer
    0

    Thanks Morten for the tip on "Unblocking" the zip file before extracting the files.  Whatever that does it allowed me to successfully install v4.5!

    Dan

  • Daniel Bardi 923 posts 2554 karma points
    Jul 01, 2010 @ 22:58
    Daniel Bardi
    0

    I gave NETWORK SERVICE full permissions to the path (c:\inetpub\UmbracoRoot\Umbraco4.5)

    Reinstalled .Net 4.0 via command line.

    These are my website and app pool settings:

    This is the result:

    What have I missed?

  • Carlos 338 posts 472 karma points
    Jul 01, 2010 @ 23:08
    Carlos
    0

    I had the same issue you had. I had to actually set my permissions on the website itself within IIS. Then refresh my browser.

  • Daniel Bardi 923 posts 2554 karma points
    Jul 01, 2010 @ 23:34
    Daniel Bardi
    0

    I tried setting permissions via IIS without success.

    I was able to fix the problem by going into the App Pool advanced settings and changing the Identity to NetworkService:

     

  • arviman 71 posts 92 karma points
    Jul 02, 2010 @ 00:31
    arviman
    0

    I tried upgrading my site running 4.0.1 version to 4.5. I'm using IIS 6 with Win XP on .Net 4( Classic pipeline I assume ).I updated my web.config file with the changes made from my old site and changed the appSettings.config file as per the documentation on codeplex. After finishing the installation, when I visit the site I get the following error:

     

    Server Error in '/' Application.

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.
    Parser Error Message: Only Content controls are allowed directly in a content page that contains Content controls.
    Source Error:
    Line 1:  
    Source File: /masterpages/Master.master    Line: 1
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

    The code that I'm running in the master page (which derives from another master page MainMaster) and which worked fine in 4.0.1. looks like the following. Apparently the Master tag on line 1 is the one that's causing the error <:bewildered:>

    <%@ Master Language="C#" MasterPageFile="/masterpages/MainMaster.master" AutoEventWireup="true" %>
    <asp:Content ContentPlaceHolderId="ContentPlaceHolderBreadcrumb" runat="server">
    .
    .
    </asp:Content>
    <asp:Content ContentPlaceHolderId="ContentPlaceHolderMain" runat="server">
    .
    .
    </asp:Content>

    I believe that the installation is supposed to change the templates according to the 4.5 specs, but I'm really confused as to why this error is occurring. There are no tags other than the 'content' and 'master' tags in this template. Has anyone been facing this problem, or have any hint of how I could go about resolving this?

  • Daniel Bardi 923 posts 2554 karma points
    Jul 02, 2010 @ 02:26
    Daniel Bardi
    0

    Try inserting a tilde'  (~) before the the path

    MasterPageFile="~/masterpages/MainMaster.master"

  • arviman 71 posts 92 karma points
    Jul 02, 2010 @ 03:03
    arviman
    0

    Oh wow can't believe it works now! Yay. Thanks so much Daniel.

  • Daniel Bardi 923 posts 2554 karma points
    Jul 02, 2010 @ 12:15
    Daniel Bardi
    0

    No problem.. glad it's working now! :-)

  • Tim 2 posts 22 karma points
    Jul 05, 2010 @ 11:12
    Tim
    0

    I'm stil having problems installing umbraco 4.5. I use win7 64 bit with MySQL Server 5.1.38.

    I've tried re-installing (ajax).net 4 (by removing from it form software as well as useing the command line), using winrar to extract the binaries, unblocking the zip file, restarting iis, rebooting my pc and a combination of all these.. The application pool is set to .net 4. And I still get the same result. The database connection is ok, the tables are installed nicely, but when I want to install Runway or other packages I get the "The given key was not present in the dictionary" error :(

    The weird thing is though, that Umbraco seems to think that Runway -or any other package I try to install- is installed even though I have the same empty UI as the topic starter.

    Also, when I try to build the binaries, I get an "Unrecognized configuration section system.web.extensions" error for the asp net ajax part in theweb.config. But the site still runs.. maybe something error happen with aspnet ajax?

     

    //edit: tried using MSSQL server and still get the same error

     

    //edit2: And it's solved. I had to remove the .net2 handlers for *.axd and *.aspx that were installed by default. 


  • Ove Andersen 435 posts 1536 karma points c-trib
    Jul 05, 2010 @ 14:09
    Ove Andersen
    0

    I managed to successfully upgrade my site to v4.5 by unblocking the zip as described in a previous post, and then doing a .NET v4 reinstall with aspnet_regiis -i.

    I also made sure that the application pool user had access to the proper folders as per the description here: http://our.umbraco.org/wiki/install-and-setup/set-umbraco-folder-permissions-from-command-line

  • JacoboPolavieja 62 posts 84 karma points
    Jul 06, 2010 @ 17:19
    JacoboPolavieja
    0

    Hello all..

     

    Is it possible to use Umbraco 4.5 with Cassini?

     

    Although I downloaded the latest Cassini version which supposedly goes up to asp.net 3.5, When I register a new slot I only have 1.0, 1.1 and 2.0 as the options for "Target ASP.NET Version".

    I have the lastest VS2010 with .Net 4 and 3.5 installed.

     

    So, do I have to go with IIS obligatory to try this out? i had no problem with cassini+vistadb with Umbraco 4.03, and that was very thandy to trying things out quickly.

     

    By the way, I almost forgot, I am receiving the line 154 error:

    Línea 152:
    Línea 153: <!-- ASPNETAJAX -->
    Línea 154: <system.web.extensions>
    Línea 155: <scripting>
    Línea 156: <scriptResourceHandler enableCompression="true" enableCaching="true" />

     

    Thanks a lot. Cheers!

  • Morten Bock 1867 posts 2139 karma points MVP 2x admin c-trib
    Jul 06, 2010 @ 22:34
    Morten Bock
    0

    .Net 3.5 is an extension to version 2.0, so you would just choose 2.0 to run 3.5 code.

    But as far as I recall, Umbraco 4.5 requires .net 4.0 for now. So if Cassini only supports up to 3.5, then you will probably need to use IIS.

  • JacoboPolavieja 62 posts 84 karma points
    Jul 07, 2010 @ 11:42
    JacoboPolavieja
    0

    Thanks Morten!

     

    I'm trying to install it with IIS and SQL Server then... and run into the same problem described here, no solution yet: http://our.umbraco.org/forum/getting-started/installing-umbraco/3986-SQL-2008-set-up

     

    Thank you all!

  • Bill 81 posts 83 karma points
    Jul 07, 2010 @ 13:14
    Bill
    0

    hello fellow umbracians. here is my problem:

    I try to install 4.5 and when i try to run my site and all I get is that:

    Server Application Unavailable

    The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

    Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.

    I use windows XP (IIS ver 5.1) and anp.net 4 is installed and selected in IIS. If I select 2.0. ... I get the error.

    Is there any solution to my problem or I need to upgrade to a higher IIS version (and of course a windows version) ?

    Thanks in advance!

     

    FIXED IT!

    For some reason when I changed the Application Protection to Low everything worked as expected.

  • jc 64 posts 100 karma points
    Jul 22, 2010 @ 22:05
    jc
    0

    For me, had to:

    cd %windir%\Microsoft.NET\Framework64\v4.0.30319
    aspnet_regiis.exe -u
    aspnet_regiis.exe -i
    iisreset


    Go to IIS admin and change app pool to use .NET 4 Integrated mode

  • Heather Floyd 522 posts 755 karma points MVP 2x c-trib
    Aug 17, 2010 @ 22:25
    Heather Floyd
    0

    Just some further notes that might help someone out (since I struggled with it)

    If you get a 404.17 error when browsing to your new 4.5 site, and are running on a 32bit OS (like myself), just reinstall .Net 4 from here:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en
    and restart IIS.

    If you then see a 404.2 error, switch your website's App Pool to use "Integrated" mode, rather than "Classic"

    ~Heather

Please Sign in or register to post replies

Write your reply to:

Draft