Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Matthew Tindall 2 posts 22 karma points
    Jul 17, 2010 @ 00:30
    Matthew Tindall

    Unrecognized configuration section system.web.extensions.

    HELP ME!!!

    (It wont help that im new at asp .net, but it seems to be able to amazing things and i really want to get to grips with it)

    I have an asp .net server package with 1&1 and im trying to put Umbraco on it. Since i place files on the server by ftp and allow "applications" by using there in browser file uploading tool. Also for using my mySQL databases i am not able to access them "off site".

    Now than the backgroud is layed out here is my issue. I downloaded the full 4.5 ZIP and placed all files within the "build" folder onto my server. I then try to access the site via the url and i recive this error:

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized configuration section system.web.extensions.

    Source Error:

    Line 153:
    Line 154:  <!-- ASPNETAJAX -->
    Line 155:  <system.web.extensions>
    Line 156:    <scripting>
    Line 157:      <scriptResourceHandler enableCompression="true" enableCaching="true" />

    Source File: E:\kunden\homepages\40\d329609254\um\web.config    Line: 155

  • Sascha Wolter 615 posts 1101 karma points
    Jul 17, 2010 @ 01:29
    Sascha Wolter

    Hi Matthew,

    I remember having a similar problem once, I think it was because the <system.web.extension> section was not at the right place (after <system.web>), might be worth a check however seems highly unlikely if it's a fresh download.

    Do you know which version of .Net your 1&1 environment is using? Do you have an idea if ASP.Net AJAX is installed?

    Oh wait, found it when I browsed to your page:

    Version Information: Microsoft .NET Framework Version:2.0.50727.3607; ASP.NET Version:2.0.50727.3614

    I'm afraid the current version 4.5 requires at least .Net framework 3.5 to work. In that case you should use the previous version which can be downloaded here:

    Best regards,



  • Brad Crandell 4 posts 26 karma points
    Jul 17, 2010 @ 11:57
    Brad Crandell

    Hi Matthew,

    Which download did you use from the Codeplex site?  I had the same problem when I tried using the one labeled "Umbraco 4.5 Binaires".  The first thing I tried was to add the section like @Saascha said, but then I ran into another issue and it said it didn't recognize the ASP.Net 4.0 assemblies. I only have .Net 3.5 on my server at this point. So then I downloaded the "Umbraco 4.5 WebDeploy for .NET 2.0/3.5" and just used the files in that the Umbraco folder within that .Zip to upgrade and that worked.

    Oh, the other thing you could do is switch to an AppPool that is using the .Net 4.0 Framework if you have it installed.  I forgot to mention that that should work, too.

    Hope that helps,

  • Matthew Tindall 2 posts 22 karma points
    Jul 17, 2010 @ 18:40
    Matthew Tindall

    Thankyou both for your replys!! Im now trying to upload version to see if i can get this to work.

Please Sign in or register to post replies

Write your reply to: