Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • choke 15 posts 35 karma points
    Jul 20, 2010 @ 09:31
    choke
    0

    How to upload web content from localhost to server

    can you suggest to me how to upload web content from localhost to server .

    i use FileZilla to upload all Umbraco floders from local to the server

    but i got some error about my web.config file.

    How i can solve this problem.

    Please suggest it to me.

    Choke

  • Darren Ferguson 1022 posts 3258 karma points MVP c-trib
    Jul 20, 2010 @ 09:44
    Darren Ferguson
    0

    I think you'll need to explain the error in a lot more detail to get a useful response here.

  • choke 15 posts 35 karma points
    Jul 20, 2010 @ 09:58
    choke
    0

    Dear Darren

    thank you for your suggestion, i got some errors as

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>

    and this is my web.config file

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <configSections >
        <section name="urlrewritingnet" restartOnExternalChanges="true" requirePermission="false" type="UrlRewritingNet.Configuration.UrlRewriteSection, UrlRewritingNet.UrlRewriter" />
        <section name="microsoft.scripting" type="Microsoft.Scripting.Hosting.Configuration.Section, Microsoft.Scripting, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" />

        <section name="clientDependency" type="ClientDependency.Core.Config.ClientDependencySection, ClientDependency.Core"/>
        <section name="Examine" type="Examine.Config.ExamineSettings, Examine"/>
        <section name="ExamineLuceneIndexSets" type="UmbracoExamine.Config.ExamineLuceneIndexes, UmbracoExamine"/>

      </configSections>

      <urlrewritingnet configSource="config\UrlRewriting.config" />
      <microsoft.scripting configSource="config\scripting.config" />
      <clientDependency configSource="config\ClientDependency.config" />
      <Examine configSource="config\ExamineSettings.config" />
      <ExamineLuceneIndexSets configSource="config\ExamineIndex.config" />

      <appSettings>
        <add key="umbracoDbDSN" value="server=.\SQLEXPRESS;database=DATABASE;user id=USER;password=PASS" />
        <add key="umbracoConfigurationStatus" value="" />
        <add key="umbracoReservedUrls" value="~/config/splashes/booting.aspx,~/install/default.aspx,~/config/splashes/noNodes.aspx" />
        <add key="umbracoReservedPaths" value="~/umbraco,~/install/" />
        <add key="umbracoContentXML" value="~/App_Data/umbraco.config" />
        <add key="umbracoStorageDirectory" value="~/App_Data" />
        <add key="umbracoPath" value="~/umbraco" />
        <add key="umbracoEnableStat" value="false" />
        <add key="umbracoHideTopLevelNodeFromPath" value="true" />
        <add key="umbracoEditXhtmlMode" value="true" />
        <add key="umbracoUseDirectoryUrls" value="false" />
        <add key="umbracoDebugMode" value="true" />
        <add key="umbracoTimeOutInMinutes" value="20" />
        <add key="umbracoVersionCheckPeriod" value="7" />
        <add key="umbracoDisableXsltExtensions" value="true" />
        <add key="umbracoDefaultUILanguage" value="en" />
        <add key="umbracoProfileUrl" value="profiler" />
        <add key="umbracoUseSSL" value="false" />
        <add key="umbracoUseMediumTrust" value="false" />

        <!--
            Set this to true to enable storing the xml cache locally to the IIS server even if the app files are stored centrally on a SAN/NAS
            Alex Norcliffe 2010 02 for 4.1-->
        <add key="umbracoContentXMLUseLocalTemp" value="false"/>
      </appSettings>
      <system.net>
        <mailSettings>
          <smtp>
            <network host="127.0.0.1" userName="username" password="password" />
          </smtp>
        </mailSettings>
      </system.net>

      <connectionStrings>
        <remove name="LocalSqlServer" />
        <!--<add name="LocalSqlServer" connectionString="server=.\sqlexpress;database=aspnetdb;user id=DBUSER;password=DBPASSWORD" providerName="System.Data.SqlClient"/>-->
      </connectionStrings>

      <system.web>
        <!-- <trust level="Medium" originUrl=".*" />-->

        <customErrors mode="RemoteOnly" />
        <trace enabled="true" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />
        <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="20" />
        <globalization requestEncoding="UTF-8" responseEncoding="UTF-8" />
        <xhtmlConformance mode="Strict" />

        <httpRuntime requestValidationMode="2.0" />

        <pages enableEventValidation="false">
          <!-- ASPNETAJAX -->
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add tagPrefix="umbraco" namespace="umbraco.presentation.templateControls" assembly="umbraco" />
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          </controls>
        </pages>

        <httpModules>
          <!-- URL REWRTIER -->
          <add name="UrlRewriteModule" type="UrlRewritingNet.Web.UrlRewriteModule, UrlRewritingNet.UrlRewriter" />
          <add name="umbracoRequestModule" type="umbraco.presentation.requestModule" />
          <!-- UMBRACO -->
          <add name="viewstateMoverModule" type="umbraco.presentation.viewstateMoverModule" />
          <add name="umbracoBaseRequestModule" type="umbraco.presentation.umbracobase.requestModule" />
          <!-- ASPNETAJAX -->
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <!-- CLIENT DEPENDENCY -->
          <add name="ClientDependencyModule" type="ClientDependency.Core.Module.ClientDependencyModule, ClientDependency.Core"/>
        </httpModules>


        <httpHandlers>
          <remove verb="*" path="*.asmx" />
          <!-- ASPNETAJAX -->
          <add verb="*" path="*.asmx" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
          <add verb="*" path="*_AppService.axd" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />

          <!-- UMBRACO CHANNELS -->
          <add verb="*" path="umbraco/channels.aspx" type="umbraco.presentation.channels.api, umbraco" />
          <add verb="*" path="umbraco/channels/word.aspx" type="umbraco.presentation.channels.wordApi, umbraco" />
          <add verb="*" path="DependencyHandler.axd" type="ClientDependency.Core.CompositeFiles.CompositeDependencyHandler, ClientDependency.Core "/>
          <add verb="GET,HEAD,POST" path="GoogleSpellChecker.ashx" type="umbraco.presentation.umbraco_client.tinymce3.plugins.spellchecker.GoogleSpellChecker,umbraco" />
        </httpHandlers>

        <compilation defaultLanguage="c#" debug="false" batch="false" targetFramework="4.0">
          <assemblies>
            <!-- ASP.NET 4.0 Assemblies -->
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Xml.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Data.DataSetExtensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Web.Abstractions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </assemblies>
        </compilation>

        <authentication mode="Forms">
          <forms name="yourAuthCookie" loginUrl="login.aspx" protection="All" path="/" />
        </authentication>

        <authorization>
          <allow users="?" />
        </authorization>

        <!-- Membership Provider -->
        <membership defaultProvider="UmbracoMembershipProvider" userIsOnlineTimeWindow="15">
          <providers>
            <clear />
            <add name="UmbracoMembershipProvider" type="umbraco.providers.members.UmbracoMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="Another Type" passwordFormat="Hashed" />
            <add name="UsersMembershipProvider" type="umbraco.providers.UsersMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" passwordFormat="Hashed" />
          </providers>
        </membership>

        <!-- added by NH to support membership providers in access layer -->
        <roleManager enabled="true" defaultProvider="UmbracoRoleProvider">
          <providers>
            <clear />
            <add name="UmbracoRoleProvider" type="umbraco.providers.members.UmbracoRoleProvider" />
          </providers>
        </roleManager>

        <!-- Sitemap provider-->
        <siteMap defaultProvider="UmbracoSiteMapProvider" enabled="true">
          <providers>
            <clear />
            <add name="UmbracoSiteMapProvider" type="umbraco.presentation.nodeFactory.UmbracoSiteMapProvider" defaultDescriptionAlias="description" securityTrimmingEnabled="true" />
          </providers>
        </siteMap>
      </system.web>

      <!-- ASPNETAJAX -->
      <system.web.extensions>
        <scripting>
          <scriptResourceHandler enableCompression="true" enableCaching="true" />
        </scripting>
      </system.web.extensions>

      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <modules runAllManagedModulesForAllRequests="true">
          <remove name="ScriptModule" />
          <remove name="UrlRewriteModule" />
          <remove name="umbracoRequestModule" />
          <remove name="viewstateMoverModule" />
          <remove name="umbracoBaseRequestModule" />
          <remove name="ClientDependencyModule" />

          <add name="UrlRewriteModule" type="UrlRewritingNet.Web.UrlRewriteModule, UrlRewritingNet.UrlRewriter" />
          <add name="umbracoRequestModule" type="umbraco.presentation.requestModule" />
          <add name="viewstateMoverModule" type="umbraco.presentation.viewstateMoverModule" />
          <add name="umbracoBaseRequestModule" type="umbraco.presentation.umbracobase.requestModule" />
          <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ClientDependencyModule" type="ClientDependency.Core.Module.ClientDependencyModule, ClientDependency.Core"/>
        </modules>

        <handlers accessPolicy="Read, Write, Script, Execute">
          <remove name="WebServiceHandlerFactory-Integrated" />
          <remove name="ScriptHandlerFactory" />
          <remove name="ScriptHandlerFactoryAppServices" />
          <remove name="ScriptResource" />
          <remove name="Channels" />
          <remove name="Channels_Word" />
          <remove name="ClientDependency" />
          <remove name="SpellChecker" />

          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="*" name="Channels" preCondition="integratedMode" path="umbraco/channels.aspx" type="umbraco.presentation.channels.api, umbraco" />
          <add verb="*" name="Channels_Word" preCondition="integratedMode" path="umbraco/channels/word.aspx" type="umbraco.presentation.channels.wordApi, umbraco" />
          <add verb="*" name="ClientDependency" preCondition="integratedMode" path="DependencyHandler.axd" type="ClientDependency.Core.CompositeFiles.CompositeDependencyHandler, ClientDependency.Core "/>
          <add verb="GET,HEAD,POST" preCondition="integratedMode" name="SpellChecker" path="GoogleSpellChecker.ashx" type="umbraco.presentation.umbraco_client.tinymce3.plugins.spellchecker.GoogleSpellChecker,umbraco"/>
        </handlers>
      </system.webServer>


      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
            <providerOption name="CompilerVersion" value="v4.0" />
            <providerOption name="WarnAsError" value="false" />
          </compiler>
        </compilers>
      </system.codedom>

      <runtime>
        <!-- Old asp.net ajax assembly bindings -->
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="4.0.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="4.0.0.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>

    </configuration>

    best regards.

    Choke

     

  • Darren Ferguson 1022 posts 3258 karma points MVP c-trib
    Jul 20, 2010 @ 10:03
    Darren Ferguson
    0

    Details: To enable the details of this specific error
     message to be viewable on remote machines, please create a
    <customErrors> tag within a "web.config" configuration file
    located in the root directory of the current web application. This
    <customErrors> tag should then have its "mode" attribute set to
    "Off".

  • choke 15 posts 35 karma points
    Aug 02, 2010 @ 12:08
    choke
    0

    dear darren ,

    After i edit as your suggestion, i got an error appear

    Server Error in '/' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized configuration section system.web.extensions.

    Source Error:

    Line 152:
    Line 153: <!-- ASPNETAJAX -->
    Line 154: <system.web.extensions>
    Line 155: <scripting>
    Line 156: <scriptResourceHandler enableCompression="true" enableCaching="true" />


    Source File: D:\Domains\sdsbiz.com\web.config    Line: 154


    Version Information: Microsoft .NET Framework Version:2.0.50727.3603; ASP.NET Version:2.0.50727.3082

  • Darren Ferguson 1022 posts 3258 karma points MVP c-trib
    Aug 02, 2010 @ 12:24
    Darren Ferguson
    0

    Your error message indicates that your are using .net 2 whereas your web.config suggests that you are trying to install a version of Umbraco that requires version 4 of the .net framework.

    Do you have .net 4 installed?

    It is hard to give you instructions on setting up IIS for .net 4 as you haven't provided an version numbers for Umbraco, IIS etc.

  • choke 15 posts 35 karma points
    Aug 02, 2010 @ 12:44
    choke
    0

    Dear darren

    How i can use the lower version such as .net 3.0 or 3.5 , where i can edit on my web.config ?

    or i need to download Umbraco lower version that can use on .net2.0 version?

    thank you.

    best regards

    Choke

  • Darren Ferguson 1022 posts 3258 karma points MVP c-trib
    Aug 02, 2010 @ 13:09
    Darren Ferguson
    0

    See this page (http://umbraco.codeplex.com/releases/view/48015) for .net 3.5 releases of the latest version of Umbraco.

     

     

  • choke 15 posts 35 karma points
    Aug 03, 2010 @ 08:58
    choke
    0

    Dear darren

    Thank you for your suggestion.

    For my sql database

    database name : umbraco

    uername >>> umbracouser

    password >>> umbracopassword

    and i change my web.config file to

    <add key="umbracoDbDSN" 
    value="datalayer=SqlServer;server=203.146.170.168;database=umbraco;user
    id=umbracouser
    ;password=umbracopassword" />
    i still found this page
    the way i can't see the configuration page i see only login page as

     

    how can i do next?

    FYI.

    Regards

    Choke

  • Darren Ferguson 1022 posts 3258 karma points MVP c-trib
    Aug 03, 2010 @ 09:44
    Darren Ferguson
    0

    You aren't being very clear about what you are trying to do. Initially you wanted to move Umbraco from localhost to a deployed server.

    Why are you now looking to visit the config page.

    BTW to access installation clear the value of umbracoConfigurationStatus in web.config and point your browser at /install

  • choke 15 posts 35 karma points
    Aug 03, 2010 @ 10:15
    choke
    0

    Dear darren

    Thank you very much for your help.

    I'm sorry for made you unclear at the first time , the problem is i got 2 sites , one i need to move it from local to host and another is new installation.

    by the way, i completed my site already.

    Thank a ton for your advise.

    Regards

    Choke

  • Shahzad Ahamad 46 posts 246 karma points
    Mar 01, 2018 @ 07:03
    Shahzad Ahamad
    0

    @Darren , I am using umbraco 7.4.1 on my localhost as well as server. I have made some changes on my local host added some pages ,doctypes etc. Do I need to take the backup of the database or should I just paste the dlls and views etc on the server and umbraco will take care of the db by its own?

Please Sign in or register to post replies

Write your reply to:

Draft