Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Geoff Baldwin 80 posts 100 karma points
    Oct 15, 2010 @ 15:56
    Geoff Baldwin

    Moving Umbraco site from dev laptop to server

    Hi, not sure if this is the correct forum; apologies if not. I did a search of the forum but have not found any threads with a solution.

    I have developed a couple of fairly simple Umbraco 4.5.2  sites on a Laptop running Windows 7 and IIS 7.

    I now want to make them available via my server which is an SBS203 machine running IIS 6.

    I moved the sites using the following procedure:

    1. Installed SQLExpress 2008 R2 on the server
    2. Created databases with the same names as used by my sites
    3. Backed up the databases on from the laptop
    4. Restored the databases on the server (with Options Overwrite the existing database [WITH REPLACE] and Preserve the replication settings [WITH KEEP REPLICATION] both checked
    5. SEt up a login for Umbracouser and tried to set the usermappings for the databases but got an error that the user already existed in the database -- so I assmued this was OK.
    6. copied my sites from C:\Umbracosites\site1 and  C:\Umbracosites\site2 on the laptop to C:\umbracosites\site1 (2) on the server
    7. Created the websites in IIS and pointed them at the locations above

    When I run the site from the server I get a Server Error in '/' Application error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized attribute 'restartOnExternalChanges'.

    Source Error:

    Line 2:  <configuration>
    Line 3:    <configSections>
    Line 4:      <section name="urlrewritingnet" restartOnExternalChanges="true" requirePermission="false" type="UrlRewritingNet.Configuration.UrlRewriteSection, UrlRewritingNet.UrlRewriter" />
    Line 5:      <section name="microsoft.scripting" type="Microsoft.Scripting.Hosting.Configuration.Section, Microsoft.Scripting, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" />
    Line 6:      <section name="clientDependency" type="ClientDependency.Core.Config.ClientDependencySection, ClientDependency.Core" />

    Source File: C:\UmbracoSites\JRBP1\web.config    Line: 4

    if I remove restartOnExternalChanges it complains about 'requirePermission' and I assume so on..

    I have not made any changes to the web.config file; I had expected I might need to change the connection string but it is commented out and seems to be replaced by the

    <add key="umbracoDbDSN" value="server=.\sqlexpress;database=jrbp1;user id=umbracouser;password=umbraco" />

    in <app settings>??

    I'd appreciate some indication as to what I am missing - thanks


  • Geoff Baldwin 80 posts 100 karma points
    Oct 15, 2010 @ 16:11
    Geoff Baldwin


    I installed MS Frontpage Server Extensions 2002 as a guess to resolve the problem on one of the sites. It didn't. And should I install this in any case?

    Tried to ad this a an edit to the original post but got an xlst error?

  • David 17 posts 40 karma points
    Oct 15, 2010 @ 17:09

    Just as a first step, you have an issue with the sql user. Although it claims the user already exists, it doesn't really! It's an annoying thing with MS SQL, that it migrates the user with the db but the SID of the user is different from the one on your new server. So,

    1. Expand security | users in your newly restored database on the server and delete the umbracouser from there.

    2. Expand Security | logins in the main server tree and map the umbraco user again to the new/restored database. That will work this time and you'll have a correct user mapping.

    As a hint from experience, I find that the Web platform installer is awesome to install umbraco reliably with all the security and dependencies sorted. Just make sure you create a website first in IIS with the correct version of ASP.NET that you want running in the app pool, or in the site in the case of IIS6.x. Then specify that existing website in the WPI install wizard. Otherwise it always goes for ASP.NET 2.x which in my case I don't want. I've had issues with manual installs before. Then create a package (content, document types, macros, templates and any binaries and extras) from your dev machine install of umbraco and load it into the new instance on the server. Saved me a lot of time in the past.Hope it helps.



  • KsuValk 32 posts 52 karma points
    Oct 15, 2010 @ 19:29

    Sometimes when restoring a db there can be a mismatch between the user id's in the restored db and the users/logins already set up.  Make sure they are in sync by running this in the restored db from a query window:

    exec sp_change_users_login 'Update_One', '<LoginNameHere>'

    You may have to check transact-sql help to make sure that's correct.

    Then go double-check the mappings to make sure the user is mapped to the db you want.

    Try connecting via sql enterprise or studio using that user to make sure it's working.


  • Geoff Baldwin 80 posts 100 karma points
    Oct 15, 2010 @ 20:44
    Geoff Baldwin


    thanks for the input.

    I 'reconfigured' the user as you suggested.

    Then I ran an install of Umbraco using WPI 2.0.

     All went well until the 'Launch Umbraco' part at which point attempting to browse to (not sure why the // before default; tried taking one out as well!) and got the exact same error.


    thanks for your input also. Dave's suggestion of deleting the users and then recreating the login / usermappings worked fine!


  • Geoff Baldwin 80 posts 100 karma points
    Oct 16, 2010 @ 22:06
    Geoff Baldwin

    Found the solution:

    I had to go to IIS manager>Websites>sitename>properties>ASP.NET and set the ASP>NET verson to 4.0.30319

    I think this is what you were trying to tell me David but I didn't understand what you were saying :(

Please Sign in or register to post replies

Write your reply to: