Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • RuneO 36 posts 116 karma points
    Nov 04, 2010 @ 10:01

    IE security question when logging into backoffice

    A user just reported a funny issue. When logging into backoffice IE present them with the following question:

    Do you want to view only the webpage content that was delivered securely?
    This webpage contains content that will not be delivered using a secure HTTPS connection, which could compromise the security of the entire webpage.

    The funny thing is that everything seems to work perfectly no matter if you answer Yes of No. Using both Fiddler and FireBug I cannot pinpoint the unsecure request either.

    Backoffice is located on a SSL site, the certificate is ok, and umbracoUseSSL is turned on in the web.config.

    I've also tested the thing in different browsers, and it only seems to be IE that shows this error - FF and Chrome doesn't.

    The site has just been upgraded from 4.0.3 to 4.5.2.

    Anyone else experiencing this behavoir?





  • Keith Petersen 67 posts 111 karma points
    Aug 12, 2011 @ 22:59
    Keith Petersen

    I've encountered this after upgrading to 4.7.0 from 4.5.2, but I never experienced it on 4.5.2. I filed an issue about it here: . I thought it was the links to the videos in the Content > Getting Started dashboard, but I removed those and I still get the warning in IE 8.

  • Martijn Maris 37 posts 235 karma points MVP
    Dec 06, 2012 @ 09:57
    Martijn Maris

    I ran into the same issue (with IE7 and IE8)  ith a 4.7.1 version of Umbraco. It was hell of a job to figure out what went wrong because it had nothing to do with HTTP links. After a lot of javascript debugging I found out that the warnings were caused by the tree.

    When there are PNG-background images used in the tree (for example the image of the recycle bin) the browser gives a warning because the path to the image is marked as insecured. The path does not contain http:// links but relative links like /umbraco/images/umbraco/bin_empty.png.

    I have fixed this by adding the protocol and hostname before the path like:

    I made the change in the jquery.tree.js file in /umbraco_client/trees/jquery.tree.js with the following code:


     if ( {
    str += "<ins " + ("/") == -1 ? " class='" + + "' " : " style='background-image:url(\"" + + "\");' ") + ">&nbsp;</ins>";

    Changed into:

     if ( {
    var url = location.protocol+'//'+location.hostname+(location.port ? ':'+location.port: ''); = url +;
    str += "<ins " + ("/") == -1 ? " class='" + + "' " : " style='background-image:url(\"" + + "\");' ") + ">&nbsp;</ins>";

    This worked for me!

Please Sign in or register to post replies

Write your reply to: