Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Wes 14 posts 35 karma points
    Jan 06, 2011 @ 21:48

    HTML entities in rich text editor (TinyMCE) getting stripped?

    I'm trying to figure out why certain HTML entities appear to be getting stripped from the output upon publish in the rich text editor. Certain entities (like ™) survive, but strangely (to me anyway) one I want to use, —, ends-up getting stripped from the output.

    I'm aware of the tinyMceConfig.config file, and I (think I) understand the configuration drill for it. But even tinkering with the entity_encoding config item, and adding a custom entities config item, doesn't seem to change the results. (And yes, I am cycling the app between config changes.)

    Anyone have any ideas? We can format content another way, but having these unavailable is a bit annoying.

  • Jan Skovgaard 11280 posts 23678 karma points MVP 10x admin c-trib
    Jan 06, 2011 @ 22:20
    Jan Skovgaard

    Hi Wes

    I think there are som options to try from this old post on the old forum:

    Not sure if you "just" need to change <TidyCharEncoding>UTF8</TidyCharEncoding> to <TidyCharEncoding>ASCII</TidyCharEncoding> or in the umbracoSettings.config file...seems like Heather disabled tidy (also in the umbracoSettings.config) to work around the problem.

    Try to check it out and try the stuff Peter and Heather are discussing.


  • Wes 14 posts 35 karma points
    Jan 06, 2011 @ 22:44

    Thanks, Jan. I'll check it out.

  • Wes 14 posts 35 karma points
    Jan 06, 2011 @ 22:57

    It rather looks like this was not actually resolved in that thread, either, unfortunately.

    For my situation, turning-off tidy is the easiest solution, and does work, and since I'm doing all the content work, it doesn't matter. When I implement Umbraco for someone else, which I will soon, I doubt they'll even know what an em-dash is, let alone need to use one, and most of the common entities do seem to work if you do switch the TinyMCE config for entity_encoding to "named" so problem perhaps not solved, but worked around.

    Thanks for pointing that thread out, Jan.


  • Adam Anthony 8 posts 79 karma points
    Feb 23, 2016 @ 17:49
    Adam Anthony

    I know this was a while ago, but I found setting the entity_encoding to "numeric" more useful than "named", as there are numeric versions of all the named entities, but not the other way around. I was getting question marks on a page refresh in the back office, but this sorted it for me.

    FYI, I ended up setting this in the config object that gets passed though to tinyMce in the umbraco.directives file. I added it to the object "baseLineConfigObj" that gets passed through in this line:


    Hope this helps someone!

Please Sign in or register to post replies

Write your reply to: