Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Mark 4 posts 24 karma points
    Jan 12, 2011 @ 23:30
    Mark
    0

    Unable to browse website - named pipes error

    I am setting up a local copy of Umbraco from a existing Umbraco install, am able to log into the backend and view all the "Content", "Media", "Users" it matches exactly what I see if I log into the existing install.

    But when I go to view any of the pages on the website I see nothing, this error appears in the umbracoLog table

    At /residential-property (Referred by: http://localhost/umbraco/editContent.aspx?id=1159): System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
       at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParser.Connect(ServerInfo serverInfo, SqlInternalConnectionTds connHandler, Boolean ignoreSniOpenTimeout, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, SqlConnection owningObject)
       at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)
       at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(String host, String newPassword, Boolean redirectedUserInstance, SqlConnection owningObject, SqlConnectionString connectionOptions, Int64 timerStart)
       at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
       at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.SqlClient.SqlConnection.Open()
       at System.Data.Linq.SqlClient.SqlConnectionManager.UseConnection(IConnectionUser user)
       at System.Data.Linq.SqlClient.SqlProvider.get_IsSqlCe()
       at System.Data.Linq.SqlClient.SqlProvider.InitializeProviderMode()
       at System.Data.Linq.SqlClient.SqlProvider.System.Data.Linq.Provider.IProvider.Execute(Expression query)
       at System.Data.Linq.DataQuery`1.System.Collections.Generic.IEnumerable<T>.GetEnumerator()
       at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
       at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
       at System.Data.Linq.Provider.BindingList.Create[T](DataContext context, IEnumerable`1 sequence)
       at System.Data.Linq.DataQuery`1.GetNewBindingList()
       at System.Data.Linq.DataQuery`1.System.ComponentModel.IListSource.GetList()
       at System.Web.UI.DataSourceHelper.GetResolvedDataSource(Object dataSource, String dataMember)
       at System.Web.UI.WebControls.ReadOnlyDataSource.System.Web.UI.IDataSource.GetView(String viewName)
       at System.Web.UI.WebControls.DataBoundControl.ConnectToDataSourceView()
       at System.Web.UI.WebControls.DataBoundControl.GetData()
       at System.Web.UI.WebControls.ListControl.OnDataBinding(EventArgs e)
       at System.Web.UI.WebControls.ListControl.PerformSelect()
       at System.Web.UI.WebControl...

     

    I am sure it is probably something that I have overlooked, I have editted the <add key="umbracoDbDSN" /> to use my local database settings.

  • Sascha Wolter 615 posts 1101 karma points
    Jan 13, 2011 @ 00:34
    Sascha Wolter
    1

    Hi Mark,

    it looks like your SQL server isn't configured correctly. When you start up SQL Server Management Studio, can you log into your server with the credentials from the connection string used and access the database that is used?

    To solve your problem you most likely have to configure your connections for SQL server. Do the following:

    1. All programs -> Microsoft SQL Server xxx -> Configuration Tools -> SQL Server Configuration Manager, launch that
    2. Select SQL Server Network Configuration and the Protocols for xxxx [with xxxx being your db instance]
    3. You should see 4 entries here: Shared Memory, Named Pipers, TCP/IP, VIA
    4. Make sure Named Pipes is Enabled
    5. Make sure TCP/IP is Enabled as well; right-click on TCP/IP and select Properties
    6. Select tab IP Addresses, select for all entries Active=Yes and Enabled=Yes, click OK
    7. You will most likely get the message 'You must restart the service for your changes to take effect' or similar; go to SQL Server Services in the Configuration Manager, right click on the entry 'SQL Server (xxx)' [with xxx being your db instance] and choose Restart

    That should do the trick! Please see also here for more info on setting up Umbraco.

    Hope that helps,

    Sascha

  • Mark 4 posts 24 karma points
    Jan 13, 2011 @ 07:22
    Mark
    0

    Hi Sascha,

    Thank you for the reply

    Yes the settings I have in web.config work when logging into SQL. All the protolcols are enabled and I checked that the IP addresses where active and enabled.

    This is the screen when I log into Umbraco


     

    When I try to browse the website I get this

     

    When I check the umbracoLog table it has the named pipes error in it.

     

    Thanks

  • Mark 4 posts 24 karma points
    Jan 13, 2011 @ 07:59
    Mark
    0

    Oops trust my first forum post to be an embrassing one.

    There is also a Connections.config file in the root bin directory that had connectionstring setting that needed to be changed

  • Jan Skovgaard 11264 posts 23592 karma points MVP 8x admin c-trib
    Jan 13, 2011 @ 08:02
    Jan Skovgaard
    1

    Hi Mark

    Welcome to the forums. I'm happy you got your problem solved. Don't be embarrased - we can all get confused about stuff and then asking for help is the only way forward. You got your problem solved by yourself and everything is good.

    If you have further questions etc. don't hesitate to ask. We're friendly bunch who just likes to help each other out. Sometimes we all get confused about the obvious. We're only human :-)

    /Jan

  • Mark 4 posts 24 karma points
    Jan 13, 2011 @ 21:55
    Mark
    0

    Thanks Jan, appreciate the comments!

  • Sascha Wolter 615 posts 1101 karma points
    Jan 14, 2011 @ 00:17
    Sascha Wolter
    0

    Hehe, glad you got it figured out (that's what counts in the end, right?). Don't worry, these 'stupid' mistakes happen all the time, the good thing is that we now got a nice forum entry about that so the next guy/girl looking for the same thing will hopefully get that resolved in no time at all. :)

Please Sign in or register to post replies

Write your reply to:

Draft