Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Josh Reid 182 posts 257 karma points
    Feb 09, 2011 @ 23:11
    Josh Reid
    0

    Entire Packages Node empty fresh 4.5.2 install

    Hi there

    I know there is alot around about the installed/created packages nodes being empty, but this is the entire Developer > Packages Node empty...

    Site is not showing: Package Repo / Created / Installed / Install Runway / Install Local Package

    I have had a dig around and it appears nothing is out of ordinary in DB / files, etc - compared to another perfectly functioning install.

    Has anyone experienced this- any pointers? Or just wipe it out and re-install?

    Thanks

    Josh

  • Josh Reid 182 posts 257 karma points
    Feb 10, 2011 @ 04:12
    Josh Reid
    0

    Oh and also this is the error through firebug on opening of the Developer > Packages node...

    [InvalidOperationException: Unable to generate a temporary class (result=1).
    error CS2001: Source file 'C:\WINDOWS\TEMP\gznr_lux.0.cs' could not be found
    error CS2008: No inputs specified
    ]
       System.Xml.Serialization.Compiler.Compile(Assembly parent, String ns, XmlSerializerCompilerParameters xmlParameters, Evidence evidence) +1010
       System.Xml.Serialization.TempAssembly.GenerateAssembly(XmlMapping[] xmlMappings, Type[] types, String defaultNamespace, Evidence evidence, XmlSerializerCompilerParameters parameters, Assembly assembly, Hashtable assemblies) +1902
       System.Xml.Serialization.TempAssembly..ctor(XmlMapping[] xmlMappings, Type[] types, String defaultNamespace, String location, Evidence evidence) +74
       System.Xml.Serialization.XmlSerializer.GenerateTempAssembly(XmlMapping xmlMapping, Type type, String defaultNamespace) +105
       System.Xml.Serialization.XmlSerializer..ctor(Type type, String defaultNamespace) +489
       System.Xml.Serialization.XmlSerializer..ctor(Type type) +6
       umbraco.BusinessLogic.Utils.SerializableData.Serialize(Object objDeserialized, Type objectType) +125
       umbraco.cms.presentation.Trees.XmlTree.ToString(SerializedTreeType type) +91
       umbraco.cms.presentation.Trees.LegacyTree.Render(XmlTree& tree) +119
       umbraco.presentation.webservices.TreeDataService.LoadTree(TreeRequestParams treeParams) +156
       umbraco.presentation.webservices.TreeDataService.GetXmlTree() +198
       umbraco.presentation.webservices.TreeDataService.ProcessRequest(HttpContext context) +85
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +181
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75

    Thanks
    Josh

  • Josh Reid 182 posts 257 karma points
    Feb 16, 2011 @ 23:24
    Josh Reid
    0

    Anyone interested this is SOLVED...

    The host hadn't setup the server with correct permissions for IIS on the C:\\WINDOWS\TEMP directory.

    What a waste of an afternoon trying to fix the install etc, and nothing I could do!

  • Dwayne A 97 posts 117 karma points
    Mar 08, 2011 @ 12:32
    Dwayne A
    0

    Hi Josh,

    Am experiencing similar with 4.6.1 and have also been digging without and epiphany in sight. My packages node is empty, and I've been thinking this might be caused by permissions. You say it is solved. Did changing permissions solve it in one fell swoop, or did you have to reinstall/update folder etc?

  • Dwayne A 97 posts 117 karma points
    Mar 09, 2011 @ 15:17
    Dwayne A
    0

    Okay, I get the same Firebug error. We're going to change permissions as well. That should solve it, it would appear.

  • Nick 11 posts 36 karma points
    Mar 31, 2011 @ 10:47
    Nick
    0

    I find it utterly ridiculous that Umbraco needs permissions in the Windows/Temp folder. That should be handled in the website itself.

  • Roy Georgia 1 post 21 karma points
    Oct 11, 2012 @ 02:39
    Roy Georgia
    0

    I want to add to this post. I'm hosting on Softsys and this was the issue.  I migrated a dev install to prod and everything (content-wise) came over fine.  When clicking the Packages node, nothing showed up.  I checked a lot of security settings, did resets, etc.  The issue was that the C:\Windows\Temp file needed "List folder" permissions for IIS_IUSRS account.  Applied that and everything showed back up.  It had nothing to do with the installedPackages.XML file which was intact. Hope this helps some innocent migrating soul.

Please Sign in or register to post replies

Write your reply to:

Draft