Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • AValor 32 posts 56 karma points
    Feb 28, 2011 @ 18:41

    DependencyHandler.axd error 500 when deploying website


    I'm currently developing an Umbraco site with the help of Microsoft WebMatrix. I wanted to show my progresses so I'm trying to deploy the site on my own IIS 7.5 (using Windows 7) service instead of IIS 7.5 Express used by WebMatrix. I copy the files and create the site, configure the application pool to use Framework 4.0. But when I go to the login page, it seems like missing images and borders and one I logged in, I see the Dashboard without style, images or even the content tree.

    I have been doing some research and thanks to Fiddler (great tool by the way!) I found weird http 500 errors trying to load DependencyHandler. I read in this post (,-after-moving-site-to-a-new-domain?p=0#comment41100) about not copying the App_Data\ClientDependency folder, so I tried again from the beggining without copying it, but it has no worked for me.

    Is there any permissions I've got to take into consideration? Anything else I can try?

    Thanks in advance!


  • E.J. Brennan 73 posts 114 karma points
    Feb 28, 2011 @ 19:02
    E.J. Brennan

    Definitely sounds like a permissions problem. See this post:

    which has the commands you can use to set the right permissions for the right directory.


  • AValor 32 posts 56 karma points
    Feb 28, 2011 @ 19:17

    That was great!!

    I had created a new Umbraco site using WebPI and noticed the permissions diferences in the security tab of the files, but I couldn't manage how to set permissions to the ApplicationPool itself. This script has done all the job and now it works great!


    Thank you!!

Please Sign in or register to post replies

Write your reply to: