Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rick 32 posts 135 karma points
    May 11, 2011 @ 20:07
    Rick
    0

    Step 3 - SQL CE 4 Database Connection Initialisation Failed

    Hi All,

    Trying to do an installation of v 4.7 on Windows Server 2008 R2 x64 w/ SP1 (IIS 7.5) and am unable to get the SQL CE 4 database configuration step to complete.

    Installation Steps:

    • Clean installation of 2008 R2 x64 w/ SP1 and all other available updates
    • Installation of MS Web Platform Installer (WPI) along with FF and Chrome browsers
    • Launched Umbraco 4.7 installation via WPI and it completed with no errors (dated 3/15/2011)
    • --- I seem to remember previous versions asking database questions during the WPI install but that did not happen with 4.7, has that been removed with the support of CE 4.0 being added?
    • Added application pool (we'll call it myAppPool) and set it to use .Net 4.0 (v4.0.30319)
    • Assigned Umbraco (Default Web Site) to use my application pool
    • Ran the script on this page using the IIS AppPool\myAppPool suggested modification: http://our.umbraco.org/wiki/install-and-setup/set-umbraco-folder-permissions-from-command-line
    • Ran the command on this page to fix the ManagedPipeHandler issue: http://www.gotknowhow.com/articles/fix-bad-module-managedpipelinehandler-in-iis7
    • Restarted IIS
    • Launched Umbraco (FF 4.x)
    • At Step 3, I select the option to use SQL CE 4 and click Install and receive "Database connection initialisation failed"

    At this point I checked permissions and IIS_IUSR has read access all the way down and myAppPool has modify access all the way down.  I tried changing both of these to have Full Control all the way down with no change to the behavior.

    Assume that I restarted IIS a pile of times.

    I've also tried doing the manual install as well as not using a custom application pool with the exact same results.

    Can anyone provide any suggestions?

    Thank you in advance,

    Rick

  • aghy 129 posts 308 karma points
    May 11, 2011 @ 22:00
    aghy
    1

    Hi Rick,

    Did you download and use the WebDeploy package? Only the WebDeploy one has the Microsoft SQL CE runtime files and installer.

    Have a look http://umbraco.codeplex.com/releases/view/62573 under Other Available Downloads for Umbraco 4.7.0 WebDeploy .net 4.0

    Ben

  • Jan Skovgaard 11257 posts 23497 karma points MVP 7x admin c-trib
    May 11, 2011 @ 22:11
    Jan Skovgaard
    0

    Just want to mention that once you have downloaded the WebDeploy package you should just overwrite the bin folder with the one from the package and you should be good to go :-)

    Hope this helps.

    /Jan

  • Carlos Mosqueda 177 posts 267 karma points
    Sep 20, 2011 @ 04:43
    Carlos Mosqueda
    0

    I am having the same issue.  I got the WebDeploy package. Did all the IIS permissions NETWORK SERVICE access to all, Set the appPool to 4.0.

    Restarted IIS, still can't get the SQL CE to be successful. Getting  "Database connection initialisation failed".  Insanely frustrating. I love using Umbraco, but local installation shouldn't be hard.

  • John 115 posts 150 karma points
    Dec 02, 2011 @ 03:41
    John
    0

    Hello,

     I agree Umbraco is the greatest thing since sliced bread. It can be a pain in the ass to get working though. Well I always seem to have some problem. I might be incompetant though. Actually that's probably the real cause :)

    Anyway, I just had this issue. For some reason or other the Web platform installer didn't install windows CE4. So if you go open that up click Products -> Database -> Make sure Microsoft Sql Server Compact 4 is installed. (I also have the tools installed)

    Hope that helps 

Please Sign in or register to post replies

Write your reply to:

Draft