Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Fengelz 106 posts 221 karma points
    May 12, 2011 @ 11:48
    Fengelz
    0

    Upgrading from 4.5.2 to 4.7 Cache issue

    I just upgraded an umbraco solution from 4.5.2 to 4.7.

    Everything has gone pretty smooth so far and the backend and different datatypes seems to work fine.

    For some reason I cant properly publish the site though, the umbraco.config in the App_Data folder doesn't get updated at all, but remains empty:

    <?xml version="1.0" encoding="utf-8"?>
    <!DOCTYPE root[ 
    ]>
    <root id="-1">
    </root>

    The App_data folder is not set to "read only" and the app pool runs on Network service.

    Does anyone have an idea what could cause this?

    best regards

    Sune

  • Jan Skovgaard 11257 posts 23497 karma points MVP 7x admin c-trib
    May 16, 2011 @ 22:40
    Jan Skovgaard
    0

    Hi Sune

    Have you tried deleting the umbraco.config and then republish the entire site?

    /Jan

  • Fengelz 106 posts 221 karma points
    May 17, 2011 @ 13:00
    Fengelz
    0

    Yeah I tried that

    I just got a server error: 

    [NullReferenceException: Object reference not set to an instance of an object.]
       umbraco.cms.businesslogic.web.Document.ToXml(XmlDocument xd, Boolean Deep) +205
       umbraco.content.PublishNodeDo(Document d, XmlDocument xmlContentCopy, Boolean updateSitemapProvider) +90
       umbraco.content.UpdateDocumentCache(Document d) +484
       umbraco.library.UpdateDocumentCache(Int32 DocumentId) +121
       umbraco.cms.presentation.editContent.Publish(Object sender, EventArgs e) +540
       System.EventHandler.Invoke(Object sender, EventArgs e) +0
       System.Web.UI.WebControls.ImageButton.OnClick(ImageClickEventArgs e) +133
       System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) +164
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3690

  • Fengelz 106 posts 221 karma points
    May 17, 2011 @ 13:13
    Fengelz
    0

    The weirdest thing is, that if I copy the umbraco.config from another 4.7 site (site 2) and delete all the xml content within the root node and then republish, the content from the other site (site 2), is republished in the solution I'm trying to fix (site 1).

    Further more, the site node from the site I'm trying to fix (site 1) is added to the bottom of the umbraco.config.

     

Please Sign in or register to post replies

Write your reply to:

Draft