Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sebastian Dammark 501 posts 1143 karma points
    May 19, 2011 @ 10:51
    Sebastian Dammark
    0

    Installing 4.7 hangs on step 3 at 0%

    Installing a new solution af Surftown but the installation hangs on step 3 at 0%

    Any ideas ?

  • dimi309 244 posts 578 karma points
    May 20, 2011 @ 11:33
    dimi309
    0

    This has happened to me once... It was funny because I could see that the umbraco user was connected to the database but no scripts were being executed. I just closed the browser and started again without changing anything else and it worked...

    I don't know if this helps. It was the only time I have ever seen this behaviour.

     

    Dimitri

  • Sebastian Dammark 501 posts 1143 karma points
    May 21, 2011 @ 12:41
    Sebastian Dammark
    0

    Well ... my solution does it consistently.  So I'm pretty stuck until the Surftown decides to answer my support case.

  • dimi309 244 posts 578 karma points
    May 21, 2011 @ 15:18
    dimi309
    0

    Sorry to hear that... I hope that they answer soon.

  • Maarten Boer 61 posts 82 karma points
    May 23, 2011 @ 07:55
    Maarten Boer
    0

    Hi Sebastian,

    In step 3 the connection is made with your database and the umbraco tables are being created.

    I assume you have created a database with a username and password or received one from the hosting provider...

    For this to work correctly you need a working connectionstring with username and password. These settings will be stored in file WEB.CONFIG.
    Make sure during the installation you have the proper rights to alter the WEB.CONFIG otherwise umbraco will not install.

    Some providers have controlepanels for the hosted domains (customer logins) in which you can alter setting like READ, WRITE, EXECUTE etc.
    If this is not the case, then you depend on them to alter the setting.

    But remember to change the rights on the WEB.CONFIG back to 'read only' after you finish your installation.

    Another way to work arround this problem is to alter the WEB.CONFIG localy, add the right settings and then upload the file to the root of u'r site again.

    The connection string depends on the type of database you are using.

    What kinda database are you running?

  • Sebastian Dammark 501 posts 1143 karma points
    May 23, 2011 @ 10:11
    Sebastian Dammark
    0

    Hi Maarten

    I believe the connection string is correct, since I can connect directly to the database with eg. SQL Management Studio with the same information as used in the connection string.

    I have no problems editing the web.config file.

    I'm using a MS SQL 2008 database.

  • Maarten Boer 61 posts 82 karma points
    May 23, 2011 @ 12:25
    Maarten Boer
    0

    OK Sebastian,

    Just in case, i would manually add the connection string in the web.config and try again just to be sure. I have done a lot of installations and this is a very common problem.

    Open the web.config and look for:

    <add key="umbracoDbDSN" ....

    Now enter you connectionstring

    <add key="umbracoDbDSN" value="server=[servername];database=[databasename;user id=[username];password=[password]" />

     

    If you approach your site again it will start with the installation from the beginning and you will see that the connection string has already been filled in. If you still can't pass step 3 after this then i'm as puzzeld as you are...

     

    Maarten

  • Maarten Boer 61 posts 82 karma points
    May 30, 2011 @ 23:38
    Maarten Boer
    0

    Hi sebastian,

    any luck yet?

  • James Telfer 65 posts 165 karma points
    May 31, 2011 @ 03:16
    James Telfer
    0

    I'm running into a similar problem I think.

    If there are no tables created in your database, then the problem will exist in either the database connection or the permissions available to the given database user.

    Verify:

    • the web.config has been altered by the installer to include the username/password (suggested above by Maarten)
    • that the connection string information is correct - you indicated that it worked for you from SMS, but is the syntax correct for the connection string? For example, if the port used is non-standard, you need to use host,port rather than host:port.
    • that the database user associated with this login is able to create tables in this database

    If the tables exist, then you may be able to skip the step: restart the installer and it should detect the existing objects and allow you to continue.

Please Sign in or register to post replies

Write your reply to:

Draft