Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • timo 6 posts 26 karma points
    Jun 23, 2011 @ 02:56

    Upgrading 4.5.2 to 4.7 - empty trees in backend

    I'm in the process of upgrading a customer site from 4.5.2 on .NET 3.5 to on .NET 4.  The OS is Windows server 2003 x64 running IIS 6.0.  The site also runs DataIllusion's Feedback Server ( out of the same bin folder.

    After running through the upgrade process, the sub-nodes in the backend are no longer visible.  If I set umbracoconfigurationstatus in the web.config to 4.5.2, they will reappear until the upgrade wizard is run again.

    The zip file containing the 4.7 build was not blocked, the user in the connection string has db_owner on the database, and Network Service has full control on the web site and all subdirectories (also set everyone to full control for good measure).

    App_global.asax.dll and AjaxControlToolkit.dll have been removed from the bin folder.  The site is running off the filesystem (not a share) and the system.web section in the web.config has the correct setting for full trust.

    I have also deleted and republished the app_data\umbraco.config xml - which is recreated with full content.

    Our internal development environment has been upgraded with Feedback Server and other dependencies without this issue.  Any suggestions on what else to try?



  • Rich Green 2246 posts 4008 karma points
    Jun 23, 2011 @ 09:00
    Rich Green

    Hey Timo,

    Sounds like what you've done should have worked.

    The only thing I can suggest is to recheck your permissions, as the empty trees you describe is often what displays when permissions are not correctly set.

    Best of luck


  • Siw Ørnhaug 130 posts 109 karma points
    Jun 27, 2012 @ 12:48
    Siw Ørnhaug

    Hi Timo, did you resolve this?

    I've just upgraded all the way from 3.0.6 via, 4.5.2 and now to 4.7.1.

    Getting from 3 to 4 on IIS7.5 was hell while the next step went smoothly. In 4.5.2 everything worked nicely after setting to legacy xml schema and republishing the whole site. But now! All content trees are empty and while I've upgradet 4-5 sites to 4.7.1 before I've never experienced this.

    Any comment will be appreciated!



Please Sign in or register to post replies

Write your reply to: