Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • fabrice 104 posts 227 karma points
    Oct 24, 2011 @ 08:49
    fabrice
    0

    Error loading javascript after installing Umbraco 4.7.1

    Hello,

    I'm working on an umbraco 4.7.0 project and I have upgrated it from 4.7.0 to 4.7.1

    It's worked like a charm on my localhost but I have a problem after installing it on the staging server :

    When I connect to the umbraco admin, I have the javascript error : "Jquery(xx).mask(...) : function does not exist" and any key press execute the umbraco Save function.

    The jquery mask plugin is used in umbraco 4.7.1 to add a date mask to the publish date in the property tab.

    The Jquery mask plugin is new in Umbraco 4.7.1 and is being included by "DateTimePicker.cs" with [ClientDependency(ClientDependencyType.Javascript, "MaskedInput/jquery.maskedinput-1.3.min.js", "UmbracoClient")]

    See : https://hg01.codeplex.com/umbraco/rev/d2304aa897d4

    However, even if I delete on the Staging server the bin,umbraco and umbraco-client folders and replace them with the ones from my local computer (where it works) the bug is still there.

    But if I change

    <compilation defaultLanguage="c#" debug="false" batch="false" targetFramework="4.0">

    to <compilation defaultLanguage="c#" debug="true" batch="false"targetFramework="4.0">

    in the web.config THEN it works...

    Does someone understand what happened ? How can I make it works with compilation debug=true ??

    Thank you very much

    Fabrice

  • Rodion Novoselov 694 posts 859 karma points
    Oct 24, 2011 @ 23:12
    Rodion Novoselov
    0

    Hi. Perhaps it's the outdated client dependency cache to blame (when you set debug="true" in your web.config this cache is turned off by design). Try simply to clean the contents of the client dependency cache folder (by default it's  App_Data/TEMP/ClientDependency).

  • fabrice 104 posts 227 karma points
    Oct 25, 2011 @ 08:41
    fabrice
    0

    Great thank you very much ! you're the best :)  it was that.

     

     

  • Marcelo 5 posts 25 karma points
    Apr 24, 2012 @ 00:38
    Marcelo
    0

    Hi,

    I got a similar error, I have Umbraco 4.7.1.  On my dev server everything works just fine, however on the production server when I enter on the CMS, when I enter a key I get the action to save a document.  This produces that I can't edit the content.  On firebug I see there is an error "jQuery("#ctl00_body_ctl48").mask is not a function"  I clean up the Temp folder from umbraco and set the debug configuration on the web config as false but I didnt got any results.  If you have any ideas it will be a great help thanks.

  • Dimitris Chrysomallis 21 posts 73 karma points
    Mar 12, 2013 @ 09:21
    Dimitris Chrysomallis
    0

    Hi, 

    I have the exact same problem with 4.7.2, on production. 

    Content in text boxes cannot be edited, as key presses trigger the save function.

    I have deleted App_Data/Temp/Client_Dependency, but it still doesn't work.

    Any hints?

  • Mark Oliver 2 posts 22 karma points
    Mar 13, 2013 @ 09:38
  • Pedro 2 posts 22 karma points
    Jul 14, 2014 @ 16:05
    Pedro
    0

    Hi All,

    I have the same problem. I've tried all suggestions, and it still doesn't work.

    Any idea ?

    These are the errors I have on the Browser:

     

    This seems to be file related but we can't find the cause of it.

    The Version of Umbraco is 4.7.1.1 .

    Any document type with a property of Form Picker doesn't work. It just "loads" as seen below:

    Can someone from Contour kindly take a serious look at this? :(

    This seems to be an issue that happens quite often.

    I've tried update the Contour package with the latest, for this Umbraco version and that didn't do the trick either.

     

    Cheers,

    Pedro

     *forgot to mention, If I change the Form Picker Data type property, to Text String, it just works. So it really seems to be Contour related.

     

     

     

     

Please Sign in or register to post replies

Write your reply to:

Draft