Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Thanos Panousis 14 posts 34 karma points
    Nov 03, 2011 @ 18:48
    Thanos Panousis
    0

    All requests including css/js redirect to login page

    I just took my local, functioning umbraco installation and copied it over to the testing environment.

    Suddenly ALL requests to my umbraco site, meaning css, javascript etc redirect to the login.aspx page. So the website is non-functional since no css/js is served properly, unless you login. If you manage to login using the no-css form, then everything is back to normal.

    Web.config is exactly the same as my local web.config.

    The setup is 2 IIS7 servers replicating configurations, looking at a single UNC path with the umbraco files.

    What could be going wrong?

  • Jan Skovgaard 11247 posts 23464 karma points MVP 7x admin c-trib
    Nov 03, 2011 @ 22:27
    Jan Skovgaard
    0

    Hi Thanos

    Have you tried to delete the ClientDependency folder? It's found in app_data/TEMP/ClientDependency - This can sometimes cause some weirdness :)

    /Jan

  • Thanos Panousis 14 posts 34 karma points
    Nov 04, 2011 @ 09:04
    Thanos Panousis
    0

    Hello and thanks for the reply.

    I deleted the folder you propose. Nothing changed.

     

    This is really driving me crazy and causing an embarassment to my client. Could an umbraco wizard give some help?

  • Asif Malik 200 posts 336 karma points
    Nov 08, 2011 @ 14:17
    Asif Malik
    1

    Hi Thanos, i have had a similar issue before which was caused by incorrect permissions for the IIS user account. Are you sure your permissions are all correct for the sharing

  • Thanos Panousis 14 posts 34 karma points
    Nov 08, 2011 @ 14:36
    Thanos Panousis
    0

    Hello and thanks for your answer.

    Yes in the end it was permissions. As soon as I entered a user that could write on the nfs share, everything worked. I have no idea why umbraco would behave like this due to permissions issue.

  • Johnny NGUYEN 1 post 71 karma points
    Dec 10, 2019 @ 05:09
    Johnny NGUYEN
    0

    Hi Thanos, I added IUSR user to the folder then issue was gone. I have no idea why but it worked like a charm.

Please Sign in or register to post replies

Write your reply to:

Draft