Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Siw Ørnhaug 130 posts 109 karma points
    Nov 28, 2011 @ 18:32
    Siw Ørnhaug

    Javascript error on all nodes after upgrade to 4.7.1 - what's wrong?

    I have upgraded from 4.0.3 via 4.5.2 to 4.7.1.
    Pages run smoothly but in Umbraco Content I get javascript error on all nodes.

    At first it said Type undefined line 241, character 1 in DependencyHandler.axd, pluss Object doesn't support property or method line 251, character 10.
    Then I set umbracodebug= true and it said: Type undefined, line 1, character 1 in <site>/umbraco/webservices/legacyAjaxCalls.asmx/js?cdv=1

    I'm not displaying the original messages since they are in Norwegian. I've upgraded the same intervals 3 times before but never ran into this one. I only noticed it when I tried to exchange the old "Media Picker with Preview" to the improved Media Picker.

    Please, anyone know what's the matter?

  • Tom Fulton 2030 posts 4997 karma points c-trib
    Nov 28, 2011 @ 18:38
    Tom Fulton


    Did you clear your ClientDependency cache after updating? If not, please do so:

    - Delete all files under /App_Data/TEMP/ClientDependency and/or /App_Data/ClientDependency
    - Increment the version # on the <clientDependency> element in /config/ClientDependency.config
    - Touch your web.config file


  • Siw Ørnhaug 130 posts 109 karma points
    Nov 28, 2011 @ 18:56
    Siw Ørnhaug

    Hi Tom, fantastic fast response :-)

    But alas, this didn't change anything for me. I deleted the temp files, incrementet from 1 to 2 in the ClientDependency.config file, and both touch the web.config and the app pool.

    Does the data folder mess things up? I seem to remember that all is done in the app_data folder from version 4.5.x ...


  • Tom Fulton 2030 posts 4997 karma points c-trib
    Nov 28, 2011 @ 19:19
    Tom Fulton

    The data folder shouldn't be messing anything up, unless you have ClientDependency files in there?  Then try the same.


    Do you only get the error after switching to the built in media picker?  (Note you should be using the "Media Picker" render control not Improved Media Picker -- this used to be a package but is now merged in the Umbraco core as the regular Media Picker)

    Does it happen on pages without the Umbraco media picker?


  • denisedelbando 141 posts 339 karma points
    Nov 28, 2011 @ 19:56

    I am not anwering the question. I just want to ask anyone how do I post a message here? I have a question about examine api in umbraco

  • Siw Ørnhaug 130 posts 109 karma points
    Nov 28, 2011 @ 22:56
    Siw Ørnhaug

    Tom, Sorry about the delay -

    I get the same error on all nodes in Content, but it now says:

    Type is undefined, line 241, character 1, Kode: 0, URI: <site>/umbraco/DependencyHandler.axd?s= <some fantastic long hash code>&t=Javascript&cdv=2
    The object doesn't support supplied property or method (roughly translated), line 247, char. 10, code: 0, URI: <site>/umbraco/editContent.aspx?id=<id>

    The same on all nodes.

    I'm sorry I don't really understand the quality of the problem, or I would try some different things. Including reverting to ver. 2.4.5 as I didn't try to do anything with the content in that version.

    As to the Media Picker, I'm using the built in version - never tried the Improved Media Picker on this site.
    I've checked both Preview and Advanced properties. If I deselect Advanced props the Choose Media Dialogue looks exactly like the non-functional old Media Picker with Preview.

  • Siw Ørnhaug 130 posts 109 karma points
    Nov 29, 2011 @ 00:02
    Siw Ørnhaug

    Hi again,

    I did revert to version 4.5.2, app pool .net 4.0 integrated, removed files and database for version 4.7.1 and reinstalled zipped and backed up files for 4.5.2.

    Same errors.

    Then I did as you suggested, Tom, on this version too. With exactly same lack of results.

    I also tried checking preview and advanced options on Media Picker to see what happened. It's the same behaviour: Dialogue opens, I can choose image, but when I've hit the Pick button it only refreshes the media treeview, removes the preview of the image I picked and refuse to respond anymore. I actually have to close the tab window in the browser to get away.

    For the sake of it: I'm using legacy xslt, there are 2 packages installed that don't work on legacy xslt: Log Manager and Config Tree - these dlls I've renamed so they are not playing. There's also a custom control compiled on .net 2.0, but it seems to work just fine. The site uses directory urls. I can't remember anything else that's special about it.

    I'm lost here. Anyone give it a go?


Please Sign in or register to post replies

Write your reply to: