Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Frank Kerrigan 5 posts 25 karma points
    Feb 03, 2012 @ 14:42
    Frank Kerrigan
    0

    Post Installation V5 : Right Frame 404 on Settings -> CSS, Site

    Hi I've just installed V5 on W2003 Server under its own site (port 8888) and SQL 2008 backend with the standard sample site. 

    If I click through to settings / Stylesheets  and look at any of the css files I get 404 page from IIS (below).

    I'm installed and uninstalled it and given permission to Network Service and IIS user (don't think this was required thou).

    Any Ideas anyone ?

    Thanks in advance

    Frank

     

    The page cannot be found

    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    Please try the following:

    • Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
    • If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
    • Click the Back button to try another link.

    HTTP Error 404 - File or directory not found.
    Internet Information Services (IIS)


    Technical Information (for support personnel)

    • Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
    • Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site SetupCommon Administrative Tasks, andAbout Custom Error Messages.
  • Frank Kerrigan 5 posts 25 karma points
    Feb 03, 2012 @ 14:53
    Frank Kerrigan
    0

    The header for the 404 page is as follows

    1. Request URL:
    2. Request Method:
      GET
    3. Status Code:
      404 Not Found
    4. Request Headersview source
      1. Accept:
        text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
      2. Accept-Charset:
        ISO-8859-1,utf-8;q=0.7,*;q=0.3
      3. Accept-Encoding:
        gzip,deflate,sdch
      4. Accept-Language:
        en-US,en;q=0.8
      5. Connection:
        keep-alive
      6. Cookie:
        ASP.NET_SessionId=xjd1rk2t0iw3gwvcqvstce1y; UMBAPP=settings; .UMBAUTH=D5718B54A5446DE47321D5968D9DF64D6B3BBC068570079C0A339C4773DEC3834EA099C2C54C00D651EF16F0ED7CC446C9D3128FE09CAFA359E07E35FE5EFBD1EAD86D9EECE02E6CEDE57066A5AEC8E958F59582CAD5E69B3C1E343F1666955BFD602CE8A52707A34B58AC3A379AE8D270714656AEA64F3377EA580A9144BA908B00FD278AD1F8D582892AD2D8B978493BD0BF4F47D7DEAC46E0F98933C5C29DDB1EFE609D9229AFE10AE15D3901578AF687B6ACAF818661BDB24BDA7ABA54119C886A4B122BDCADC0424598652FE6BC70EA0828CD877E4426F71C182E52A55056681D8EC07938598B969C5F80DDC74AB51F37D724602008A9BA325BD347143280BFA461F732EE61073DCEE2E63B1E2F5469B821317FA1BF7167BEAD4F751D32CA88F895A78FF506AB90A5EE8742CA9815FE38DB789659798F1385E8ADB2C5E8C0E47A7F040E218EFCEBE7C09DA693676F4FEC12CBA23252175079C17BF82822F458EA852F92ECED9FC7D2E290CCCDDFB9D43C62D45BE39E5FE6FD4365A39B368CB68EDDAB0DE3F038482A3F1C667CFAEA4EDB875A1DA6AA150A73C5597131DFC9724CC9A9B8DB5525B75D4875E06A53DC493196A9E4A9D63308A9426A49EBF0B2AD1B71D26305E21A81779EEA6523D0665B3EBCC8EE3F282CF0A7E93043408C3F0E1485FC8F029B4BE034A9D0EA7EBBE6B82E9B026FC2EAC5CEFD7FF6FCFEB34E070BD7FFEAE9860D0A15D63FB5B4C8A9AC8C4C58007464259100AFDAA9AFDF47E4C6E9DAB0D4CD2B926EAD912404285B83A83D364990BB676FD76047BC54F4D05CBF6113AE3FC3EAE6C3F2F68E62E2B17BB636E0F7F0323E703CFF1B15B310B2EF1C9186E66E37F2EB1A861A58D153C67FCCC1B86406754F4DB4FFF3616012A0401EEC32B2210D1605358EAC631116F1069F07E5AB75151B26D79889F36F9B2F4EEBF958B91F54B8DD6BDBF744267D079AEE9FF4897C0BE1E2C9A5F199B1137F0D5A2BA56204D3A65E9BA79FB8429D47584463BAA1952E4057D37A51F161C75BCC56D77C01A31AA97B293466316CB04D8B6581D5326BD3BB8285566253FE8677798ACCD83D55542439FD17A13D2C11D4C6BF4BF77FF8C2B523C80BF72B0FBF442E1F5DF9E52BCB74573FC267B5AF10B4A95B6462D1ACCFE762F32213E4B483B8189E8C97F512FB65EC4B7C46B64585D905B41C14237769ACD22F4754BD08D691445293A580BEA880648708C42B3065BE51B2CDEBB3B9034E752E5E4A3719F1EB5CDE129F86CC5DF45FBA5D5ED7D042F2049DA579302167ACB43E4AA381FCCEB4531F63D6F450EBF6D9C1721D28658CF1E1197907BF1D7CB2D899F543CA519C
      7. Host:
        glasvdev001:8888
      8. Referer:
      9. User-Agent:
        Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7
    5. Response Headersview source
      1. Content-Length:
        1635
      2. Content-Type:
        text/html
      3. Date:
        Fri, 03 Feb 2012 13:52:00 GMT
      4. Server:
        Microsoft-IIS/6.0
      5. X-Powered-By:
        ASP.NET
  • Hannes Rahm 28 posts 47 karma points
    Feb 06, 2012 @ 23:09
    Hannes Rahm
    0

    I have this too!

    Unusable :/

    /Hannes

  • Frank Kerrigan 5 posts 25 karma points
    Feb 07, 2012 @ 10:58
    Frank Kerrigan
    0

    Anyone help with this at all ?

     

  • Simon Hiort-Lorenzen 5 posts 25 karma points
    Feb 08, 2012 @ 10:17
    Simon Hiort-Lorenzen
    0

    I have the same problem on Windows Server 2003.

  • Simon Hiort-Lorenzen 5 posts 25 karma points
    Feb 08, 2012 @ 10:43
    Simon Hiort-Lorenzen
    0

    Ok, I found a solution. The problem is that .net doesn't handle the requests for the extensions .js .css and .c$html. It just tries to open the files, and they don't exist.

    You need to map these extensions to .net in IIS 6:

    Open your site properties, go to Home Directory tab, click the "Configuration..." button.

    Add each of the 3 extensions to the application extensions list, select the .NET 4 dll as executable, and unselect "Verify that file exists".

  • Frank Kerrigan 5 posts 25 karma points
    Feb 08, 2012 @ 14:38
    Frank Kerrigan
    0

    Thanks for the reply but this does not work me; these extensions don't work with the browser or are not served to the browser and you loss all css and js for the sample site. Also the css and js files are not available for edit in the /Umbraco admin tool

  • Frank Kerrigan 5 posts 25 karma points
    Feb 08, 2012 @ 14:40
    Frank Kerrigan
    0

    BTW Other posts suggest that Umbraco 5 is not fully compatiable with WS2003 and IIS6 and WS2008 and IIS7 is required.  Can anyone confirm this ?

  • Simon Hiort-Lorenzen 5 posts 25 karma points
    Feb 17, 2012 @ 16:37
    Simon Hiort-Lorenzen
    0

    My solution didn't work as i thought, I had the same problems you mention. We will probably upgrade to iis7.

  • Dennis Spijkerboer 53 posts 95 karma points
    Mar 12, 2012 @ 15:04
    Dennis Spijkerboer
    0

    I have this problem under IIS 7.5.

    I can acces the frontend, normal content pages. But i can't acces templates/macro's/css files/js files. The umbraco loading bar keeps 'loading'. Fiddler tells me that it return a 404.

    Tried to debug it with the umb5 source but because IIS is giving the 404 it never gets to umbraco. What IIS setting do I miss???

    Running IIS on integrated mode.

  • Dennis Spijkerboer 53 posts 95 karma points
    Mar 12, 2012 @ 17:31
    Dennis Spijkerboer
    0

    Fixed it!

    Installed:

    "IIS 7 Recommended Configuration" using Webplatform installer

  • Emma Garland 34 posts 109 karma points MVP 2x c-trib
    Apr 07, 2012 @ 18:13
    Emma Garland
    0

    Exactly the same issue, my hosting provider updated to .net 4.0 integrated mode, which fixed this too.

Please Sign in or register to post replies

Write your reply to:

Draft