Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • - 2 posts 22 karma points
    Feb 07, 2012 @ 00:01
    -
    0

    "No parameterless constructor defined for this object" with umbraco 5

    Hi,

    i try to install the latest Umbraco 5 version from codeplex on a 64bit Windows 2008R2 server. I installed the MVC2 and MVC3. But after calling the installation page "http://mydomain.tld/Install" i get the asp.net error message "No parameterless constructor defined for this object." 

    Exception Details: System.MissingMethodException: No parameterless constructor defined for this object.

    Stack Trace: 
    [MissingMethodException: No parameterless constructor defined for this object.]
       System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck) +0
       System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache) +98
       System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean skipCheckThis, Boolean fillCache) +241
       System.Activator.CreateInstance(Type type, Boolean nonPublic) +69
       System.Web.Mvc.DefaultControllerActivator.Create(RequestContext requestContext, Type controllerType) +67
    [InvalidOperationException: An error occurred when trying to create a controller of type 'Umbraco.Cms.Web.Mvc.Controllers.BackOffice.InstallController'. Make sure that the controller has a parameterless public constructor.]
       System.Web.Mvc.DefaultControllerActivator.Create(RequestContext requestContext, Type controllerType) +181
       System.Web.Mvc.DefaultControllerFactory.GetControllerInstance(RequestContext requestContext, Type controllerType) +77
       System.Web.Mvc.DefaultControllerFactory.CreateController(RequestContext requestContext, String controllerName) +66
       Umbraco.Cms.Web.Mvc.ControllerFactories.MasterControllerFactory.CreateController(RequestContext requestContext, String controllerName) +94
       System.Web.Mvc.MvcHandler.ProcessRequestInit(HttpContextBase httpContext, IController& controller, IControllerFactory& factory) +225
       System.Web.Mvc.<>c__DisplayClass6.<BeginProcessRequest>b__2() +50
       System.Web.Mvc.<>c__DisplayClassb`1.<ProcessInApplicationTrust>b__a() +13
       System.Web.Mvc.SecurityUtil.<GetCallInAppTrustThunk>b__0(Action f) +7
       System.Web.Mvc.SecurityUtil.ProcessInApplicationTrust(Action action) +23
       System.Web.Mvc.SecurityUtil.ProcessInApplicationTrust(Func`1 func) +124
       System.Web.Mvc.MvcHandler.BeginProcessRequest(HttpContextBase httpContext, AsyncCallback callback, Object state) +98
       System.Web.Mvc.MvcHandler.BeginProcessRequest(HttpContext httpContext, AsyncCallback callback, Object state) +48
       System.Web.Mvc.MvcHandler.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData) +16
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +8837208
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +184
    I guess i need a little hint In The Right Direction :( 
    thanks for your help!

  • - 2 posts 22 karma points
    Feb 07, 2012 @ 21:23
    -
    0

    None? hmm ... ok, than we┬┤ll take another cms.

  • Richard 4 posts 24 karma points
    Mar 10, 2012 @ 12:48
    Richard
    0

    Hi,

    I've got the same error.

    I've installed latest Umbraco 5 via Web PI. And when I go to http://localhost/Umbraco/Install the error occures. I try to reinstall Umbraco for a few times with the same result.

    Windows 7 x64.

    Reflector shows 'Umbraco.Cms.Web.Mvc.Controllers.BackOffice.InstallController' really doesn't have a parameterless constructor.

     Update: I resolve this issue by unintalling Umbraco and ASP.NET MVC 3. After that I install Umbraco via WEB PI and be able to create a simple site although with

    Error reading XSLT file: \xslt\umbTopNavigation.xslt

    error :)

  • Chris Randle 61 posts 149 karma points c-trib
    Mar 21, 2012 @ 23:42
    Chris Randle
    0

    Yep me too. Downloaded the file http://umbraco.codeplex.com/releases/view/81440#DownloadId=336006, unzipped into a folder, pointed IIS 7 at it, and browsed to it.  Got the same problem.  Checked folder permissions and set everyone to full permissions (just to be sure instead of IIS_IUSRS, IUSR and NETWORK SERVICE.

     

    This is disappointing. I was rather looking forward to using it.

Please Sign in or register to post replies

Write your reply to:

Draft