Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Paul Hulatt 47 posts 59 karma points
    Feb 21, 2012 @ 19:22
    Paul Hulatt
    0

    Problems running Umbraco on a UNC share

    We have a new server setup for our Umbraco sites which is 5 x VMWare ESXi virtual Windows 2008 R2/IIS 7.5 servers running across 2 large physical servers.  All data is stored on a single Dell PowerVault MD3200i SAN and currently the IIS servers access the SAN via UNC which is served by FreeNAS.

    I have setup a test site on one of the servers, with the AppPool running under the context of a windows user I created for the purpose as running using ApplicationPoolIdentity resulted in permissions errors.  This appears to work initially however after a short time I get the following errors in Event Viewer:

    Failed to start monitoring changes to '\\fileserver\WebShare\Umbraco_Test' because the network BIOS command limit has been reached. For more information on this error, please refer to Microsoft knowledge base article 810886. Hosting on a UNC share is not supported for the Windows XP Platform.

    I have tried making the registry changes referenced in the Microsoft KB article however this does not resolve the issue.

    I have also tried setting FCNMode=2 and whilst this stopped the error above, it also prevented the client-facing site from reflecting any changes made to MasterPages/XSLT in the admin section until the AppPool was recycled.

    If anyone has experienced any similar problems I would be grateful for some help with this issue as it is extremely frustrating at the moment.

    Thanks

     

    Paul

  • Stefan Kip 1579 posts 4024 karma points c-trib
    Feb 21, 2012 @ 19:28
    Stefan Kip
    0

    Having the exact same issue... Haven't found a fix though :-(

  • Lars Mortensen 90 posts 98 karma points
    Mar 15, 2012 @ 13:25
    Lars Mortensen
    0

    Hi

    I fixed this by using af symbolic link, som umbraco think it uses a local path.

    The link can be made form a command promt, and should be done on alle webservers, by running the command:

    mklink /D c:\IISData \\iis\iisdata\ (Please edit path as needed)

    Regards Lars.

  • Stefan Kip 1579 posts 4024 karma points c-trib
    Mar 15, 2012 @ 13:47
    Stefan Kip
    0

    @Lars

    But it's still on a share, so eventually you'll hit the network BIOS command limit right?

  • Lars Mortensen 90 posts 98 karma points
    Mar 15, 2012 @ 14:16
    Lars Mortensen
    0

    You are absolutly correct!

    I didn't read the question properly, because I thought this was another thread, sorry!

     

    /Lars

Please Sign in or register to post replies

Write your reply to:

Draft