Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Pagggy 27 posts 46 karma points
    Mar 19, 2012 @ 21:42
    Pagggy
    0

    System.Security.SecurityException: App_Web_insertmacro.aspx.43b758d9.ciot57it.0.cs

     

    i am getting following exception while i am trying to insert macro ( ascx control) on the page.

    i am using shared hosting on hostgator.

    Any idea what permission need to be added? as they have given full permission on all folder for the user account.

    I am using Umbraco 4.7.1 (SQL server)

    Server Error in '/' Application.


    Security Exception

    Description: The application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file. 

    Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

    Source Error: 

    Source File: App_Web_insertmacro.aspx.43b758d9.ciot57it.0.cs    Line: 


  • Mark Fitzpatrick 1 post 22 karma points
    Mar 20, 2012 @ 04:45
    Mark Fitzpatrick
    1

    This isn't a permissions error, but a trust error. Your host is most likely running your site in a Medium Trust environment. You can try to set the <trust level="Full" /> in the system.web section of your web.config. Your host may have it set though so you cannot over-ride this but it is worth a shot. If you cannot set it you will definitley have to ask your host if they will grant your application full trust. Remember, this is not permissions, this is the trust level of the site so setting permissions has not effect on this issue.Also, if your host doesn't know what an application trust level issue is and tries to address it with permissions I would look for a new host since this is one of the most common .Net hosting issues out there. Hostgator is great with Unix/Linux environments, but may not be so good with Windows hosted accounts.

  • Proxicode 122 posts 308 karma points
    Oct 29, 2014 @ 22:13
    Proxicode
    1

    Thanks Mark!! 2 1/2 year old answer and still totally relevant!

    <trust level="Full" /> does work on GoDaddy.

  • Alex Skrypnyk 6048 posts 23119 karma points MVP 5x admin c-trib
    Feb 24, 2015 @ 00:29
    Alex Skrypnyk
    0

    Thanks Roger, it really helps for goDaddy !!!

Please Sign in or register to post replies

Write your reply to:

Draft