Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Essy 74 posts 96 karma points
    Mar 20, 2012 @ 13:32
    Essy
    0

    How to stop Examine errors in Medium Trust

    Trying to use Umbraco in Medium Trust environment - have set web config as follows:

     <section name="clientDependency" type="ClientDependency.Core.Config.ClientDependencySection, ClientDependency.Core" requirePermission="false" />

     <section name="Examine" type="Examine.Config.ExamineSettings, Examine" requirePermission="false" />

     <section name="ExamineLuceneIndexSets" type="UmbracoExamine.Config.ExamineLuceneIndexes, UmbracoExamine" requirePermission="false" />

    also:

    <add key="umbracoUseMediumTrust" value="true" />

    But errors are continually reported which relate to the Examine indexing being done in the back-end, for example:

    '[UmbracoExamine] An error occurred recreating the index set,Lock obtain timed out: [email protected]\App_Data\TEMP\ExamineIndexes\Internal\Index\write.lock, IndexSet: InternalIndexSet'

    '[UmbracoExamine] An error occurred recreating the index set,Request failed., IndexSet: InternalMemberIndexSet'

    '[UmbracoExamine] An error occurred recreating the index set,Request failed., IndexSet: InternalIndexSet'

     

    Is there some way that I can configur Umbraco and/or Examine so that it will work in a medium trust environment?

    If not, how can I disable the indexing - I realise this will lose the ability to search the backend but this is a compromise I'm prepared to make providing it stops these errors being generated.

  • Shannon Deminick 1522 posts 5242 karma points
    Jun 11, 2012 @ 21:03
    Shannon Deminick
    0

    you need to add the requirePermissions="false" to the config headers like:

     

        <section name="Examine" type="Examine.Config.ExamineSettings, Examine" requirePermission="false"/>   

        <section name="ExamineLuceneIndexSets" type="Examine.LuceneEngine.Config.IndexSets, Examine" requirePermission="false" />

Please Sign in or register to post replies

Write your reply to:

Draft