Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simon Probert 21 posts 45 karma points
    Jul 27, 2009 @ 16:21
    Simon Probert
    0

    Nodes visible in backend but not in front end - even after publishing

    Hi I ran a "Replublish Entire Site" from the Content node, but subsequently while the nodes are all still visible and published they do not appear on the front end - I just get the "You're seeing this wonderful image..." page .

    I scanned the forum and tried deleting the umbraco/data/umbraco.config page then touching the web.config and republishing both entire and at directory level... still no bananas. One thing I did notice was that the "Link to document" field on the general properties is blank

    I then tried upgrading the site from 401 to 4021 to see if that would fix it by forcing the cache somehow but again no bananas

    You can preview a page from the RTE

    Anybody have any ideas - I would live to get rid of the historic piece of art and see my website again :)

     

    SP

     

     

  • Peter Dijksterhuis 1442 posts 1722 karma points
    Jul 27, 2009 @ 16:35
    Peter Dijksterhuis
    0

    Please check your permissions on the data-folder (note that that folder should be in the root of your site!).

    Depending on your server, NETWORK SERVICE and/or ASPNET accounts need full control over that folder.

    After you deleted the umbraco.config (from the data-folder in the ROOT of your site, NOT from the umraco/data-folder), do you see it re-created after you touched the web.config?

    HTH,

    Peter

  • Simon Probert 21 posts 45 karma points
    Jul 27, 2009 @ 17:10
    Simon Probert
    0

    I originally did look in the root\data folder - but there was no umbraco.config, but I did find one in the \root\umbraco\data folder hence why I deleted that one. All I see in my root\data folder is a bunch of packages and an access.xml

    Permissions are fine ( although I have granted Full Control to NETWORK SERVICE now - usually you just seem to need modify on NS and it works )

    I mean the site was working absolutely fine until I did the republish entire site from the content node - the only other thing I did was remove a property from one of my doctypes prior to the republish, this I then restored as i thought maybe that caused the problem... the only other anomaly is that when I publish from the Homepage folder it initially throws an object ref error, but works on second publish

    I guess it's simply not creating the umbraco.config file for some reason - even with the correct permissions - hmmm baffled

     

     

     

  • Simon Probert 21 posts 45 karma points
    Jul 27, 2009 @ 17:17
    Simon Probert
    0

    I've had a closer look at that error and I think it's just struggling with updating the document cache - possibly because of the rogue umbraco.config

     

     

    [NullReferenceException: Object reference not set to an instance of an object.]
    umbraco.presentation.nodeFactory.Node.initializeStructure() +26
    umbraco.presentation.nodeFactory.Node..ctor(Int32 NodeId) +282
    umbraco.presentation.nodeFactory.UmbracoSiteMapProvider.loadNodes(String parentId, SiteMapNode parentNode) +184
    umbraco.presentation.nodeFactory.UmbracoSiteMapProvider.BuildSiteMap() +231
    umbraco.presentation.nodeFactory.UmbracoSiteMapProvider.UpdateNode(Node node) +141
    umbraco.content.PublishNodeDo(Document d, XmlDocument xmlContentCopy) +652
    umbraco.content.UpdateDocumentCache(Document d) +254
    umbraco.library.UpdateDocumentCache(Int32 DocumentId) +124
    umbraco.dialogs.publish.Page_Load(Object sender, EventArgs e) +1190
    System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +24
    System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +41
    System.Web.UI.Control.OnLoad(EventArgs e) +131
    umbraco.BasePages.BasePage.OnLoad(EventArgs e) +20
    System.Web.UI.Control.LoadRecursive() +65
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2427

     

  • Peter Dijksterhuis 1442 posts 1722 karma points
    Jul 27, 2009 @ 18:13
    Peter Dijksterhuis
    1

    If there's no umbraco.config, the document-cache won't be filled either, umbraco.config gets loaded in memory, so that IS the cache ;)

    I think something must have gone wrong when you deleted the property. Creating a new one, won't get your old values back, because the new property gets a different ID than the old one. Do you have many documents that had that property? You could try to try and edit them if there are not many.

    Other than that, I don't have a solution....perhaphs someone else does?

  • Simon Probert 21 posts 45 karma points
    Jul 27, 2009 @ 18:35
    Simon Probert
    0

    Thanks for your help Peter,

    I fixed it in the end by copying the umbraco.config file from the original build - I then deleted all the stuff between the <root id="-1">...</root> and republished the site

    Once there was a file in place it all seems to work again.. go figure ...?

     

    SP

     

  • Peter Dijksterhuis 1442 posts 1722 karma points
    Jul 27, 2009 @ 19:22
    Peter Dijksterhuis
    0

    In that case, perhaphs the NS-account is lacking create-rights perhaphs? If there is a file, it may modify, but if it's missing, it may not create a new one....

    Only reason I can think of.

    Glad you got it back to work :)

  • Simon Probert 21 posts 45 karma points
    Jul 28, 2009 @ 01:34
    Simon Probert
    0

    I checked it again and noticed that the folder had become read-only at some point so it wasn't the NS permissions at all it was never going to let it create a file in the first place.Indeed all the folders in my root have become read-only... how mysterious

    Anyway I hope this thread helps someone :)

    SP

     

  • Biagio Paruolo 1593 posts 1824 karma points c-trib
    Aug 09, 2009 @ 22:32
    Biagio Paruolo
    0

    I've the same problem. I had deleted a node and there is not in content tree, but it appear into published site ( and in umbraco.config ). I've republished entire site, but nothing change. Why? There aren't permission problems

  • Andreas Ek 4 posts 24 karma points
    Sep 21, 2009 @ 13:02
    Andreas Ek
    0

    I hade the exact same problem but when I republished the root and everything turned up again.

    The backend worked as usual but the front end usercontrols didn't deliver any nodes with nodefactory, quite strange!

     

  • Sjors Pals 617 posts 270 karma points
    Oct 30, 2009 @ 11:40
    Sjors Pals
    0

    I am having the same problem, did try everything, republishing, deleting umbraco.config, setting permissions to everyone....

    :(

  • Anders Tillebeck 15 posts 36 karma points
    Feb 05, 2010 @ 14:23
    Anders Tillebeck
    0

    Hello

    We had the same issue after all files had there read/write permissions altered. After rolling the webfiles back to an earlier backup the issue was solved. We reused the database so all new pages, content etc. did not go missing.

    My suggestion to all of you is to look into the file permissions and see if there is an error somewhere. I do not know muvh about hosting or what the file permissions should be.

    BR. Anders

Please Sign in or register to post replies

Write your reply to:

Draft