Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Siw Ørnhaug 130 posts 109 karma points
    Jun 19, 2012 @ 14:46
    Siw Ørnhaug

    Upgrade step 2/5 redirected to install going from 3.0.6 to - why?

    Hi, I'm struggeling with an old site in version 3.0.6. I want to move it from a windows server 2003 to 2008, and from sql server 2005/express to 2008. IIS 7.5.

    I've managed to get a copy of the original site up and running in version 3.0.6 on the new server.

    But when I try to upgrade to it asks me to confirm the db connection string and then it wants to install instead of upgrade.

    Why is this happening?


  • Siw Ørnhaug 130 posts 109 karma points
    Jun 25, 2012 @ 08:44
    Siw Ørnhaug

    Ok, noone's interested in why. Can anybody tell me how to deal with it?

  • Siw Ørnhaug 130 posts 109 karma points
    Jun 25, 2012 @ 10:17
    Siw Ørnhaug

    I've tried to restart from complete scratch, including recreating root folder and IIS app pool. Still it doesn't work!

    Reading around in the forum I've tried as follows:

    - exchanging install step Detect with ValidatePermissions --> that tells me the data folder doesn't have correct permissions. I've both set IIS apppool permissions AND full permissions for users Networkd services and IIS_IUSRS

    - setting button Upgrade to visible in the Detect step ascx, since the connection string has been confirmed prior to the proposed install, but I then get the error message There is already an object named 'cmsTask' in the database

    - restoring old database (3.0.6) several times, it doesn't help - and of course the cmsTask table is in the database already.

    PLEASE, if anyone knows what's fowled up here - enlighten me!

  • Siw Ørnhaug 130 posts 109 karma points
    Jun 27, 2012 @ 13:38
    Siw Ørnhaug

    OK, I've collected very little interest here, but I've finally pulled the job through, all the way from 3.0.6 to 4.7.2 - so I've decided to share my experiences - It may be helpfull to some.

    First of all, it seems that my problems stemmed from operating on windows 2008 under IIS7.5. I'm no server wiz and no IIS wiz, so this was slow learning.

    Installed copy of original 3.0.6 site - went well.
    I set the app pool to .net 2.0 classic, but let it stay with apppoolidentity. Set permissions for this.
    I had to clean up the dbschemas in the old database as it had mixed ownership, and made sure all tables were owned by dbo.

    Upgraded to - quite a job.
    After deleting global.asax, updating config files and setting permissions I received the "Security Exception" error. After a fair amount of reading on the forum it was clear that this was permission related, but I spent hours getting to the solution that worked for me:
    I moved the site to the standard .net 2.0 classic app pool and was able to run the upgrade job. But then could not log on.
    After more browsing on the forum I found that in the previous version user passwords were in clear text while in version 4.x these were hashed.
    I even found a console app to produce the needed hashing of existing passwords. I could have just set it to clear text, but that was not really a solution.
    After this everything worked fine.

    Upgrade to 4.5.2 went smoothly.
    I had chosen the .net 4.0 version and set apppool and IIS permissions to standard values. 
    I new about the legacy schema handling and republishing of entire site, so all went well.

    Only yesterday I upgraded another site from 4.5.2 to 4.7.1 and it went just as smoothly, but when I hit this step today - it didn't.
    For some reason all content trees in Umbraco were empty. I've never experienced that before. Lot's of reading on the forum and I understood this had - again - something to do with permissions. This time I gave up.

    Instead I downloaded 4.7.2 from Codeplex and just went on with a new upgrade.
    And what do you know --- everything worked after another republishing!




Please Sign in or register to post replies

Write your reply to: