Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • John Churchley 27 posts 172 karma points
    Jan 25, 2013 @ 21:54
    John Churchley
    0

    Umbraco site won't load through IIS 8

    Getting a error in trying to launch umbraco 6 or 4 any ideas?

     

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Detailed Error Information:

    Module    IIS Web Core
    Notification    BeginRequest
    Handler    Not yet determined
    Error Code    0x80070021
    Config Error    This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
    Config File    \\?\C:\websites\pregnancymassagedevon\pregnancymassagedevon.web\web.config
    Requested URL    http://test.com:80/
    Physical Path    C:\websites\pregnancymassagedevon\pregnancymassagedevon.web
    Logon Method    Not yet determined
    Logon User    Not yet determined

    Config Source:

      180:     </modules>
      181:     <handlers accessPolicy="Read, Write, Script, Execute">
      182:       <remove name="WebServiceHandlerFactory-Integrated" />
    

    More Information:

    This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.

    View more information ยป

  • Mike Taylor 155 posts 353 karma points
    Jan 25, 2013 @ 22:16
    Mike Taylor
    0

    Have you checked which version of ASP.NET your site is configured for in IIS? I've seen this error when IIS has been set to ASP.NET v2.0 rather than v4.0...

    Mike

  • John Churchley 27 posts 172 karma points
    Jan 25, 2013 @ 22:23
    John Churchley
    0

    Check set as v4.0. Believe it's to do with permissions but I have changed the permissions for full control to all administrators.

  • Jan Skovgaard 11245 posts 23462 karma points MVP 6x admin c-trib
    Jan 25, 2013 @ 22:29
    Jan Skovgaard
    0

    Hi John

    Make sure that network service and iusr has full permissions and also check that the application pool is using integrated mode and that it's run by the network service. Also check if for some reason 32-bit mode has been enabled.

    If this does not work then try having a look at the various reasons Microsoft mentions for this error in here: http://support.microsoft.com/kb/942055

    Hope this helps.

    /Jan

  • Mike Taylor 155 posts 353 karma points
    Jan 25, 2013 @ 22:29
  • John Churchley 27 posts 172 karma points
    Jan 25, 2013 @ 22:51
    John Churchley
    0

    Solve: My IIS wasn't set up correctly had to switch further features on windows features! Thanks for all the suggestions!

  • Jan Skovgaard 11245 posts 23462 karma points MVP 6x admin c-trib
    Jan 25, 2013 @ 23:10
    Jan Skovgaard
    0

    Hi John

    What features did you specifically miss? Please share, it might help others in the future :)

    /Jan

  • Charles Afford 1163 posts 1709 karma points
    Jan 26, 2013 @ 19:12
    Charles Afford
    101

    I had this same problem, when i installed windows 8 under IIS 8 for me i had turn on ASP.NET 4,5 and Web management tools in the Windows Features :)

  • John Churchley 27 posts 172 karma points
    Jan 26, 2013 @ 19:26
    John Churchley
    0

    Exactly what Charles said!

  • Zakhar 171 posts 397 karma points
    Apr 29, 2013 @ 12:31
    Zakhar
    0

    I had the same error on Server 2012 and IIS8. Installing all features mentioned above didn't solve the problem, I had to actually unlock those sections manually, these commands did it:

    %windir%\system32\inetsrv\appcmd unlock config -section:system.webServer/handlers
    %windir%\system32\inetsrv\appcmd unlock config -section:system.webServer/modules

    more info here: http://blogs.iis.net/webtopics/archive/2010/03/08/troubleshooting-http-500-19-errors-in-iis-7.aspx

  • Raj Parmar 2 posts 23 karma points
    Jul 02, 2013 @ 12:43
    Raj Parmar
    0

    Hi, I had exactly the same problem with IIS 8 on Win8, I added Modify permissions to "IUSR" for the website and it all started working.
    I didn't add "NETWORK SERVICE" and left the Application Pool Identity to "ApplicationPoolIdentity"

  • Binyam 4 posts 24 karma points
    Oct 16, 2015 @ 07:38
    Binyam
    0

    Turning on Asp.net on Trun on/of feature setting will fix it enter image description here

  • giuseppe 9 posts 63 karma points
    Sep 30, 2016 @ 13:56
    giuseppe
    0

    I had the same problem on a fresh installation of windows10. I solved like Binyam said, checking the ASP.NET 4.6 feature under "world wide web services" -> "Application development fetatures"

  • Viral Shah 32 posts 61 karma points
    Aug 31, 2018 @ 11:08
    Viral Shah
    0

    I had the same issue on Windows 10 and got fixed by checking ASP.Net 4.7 feature under "World wide web services" -> "Application development fetatures"

Please Sign in or register to post replies

Write your reply to:

Draft