Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Debbie Lawrenson 55 posts 75 karma points
    Jun 11, 2013 @ 17:03
    Debbie Lawrenson
    0

    Runtime error on newly uploaded site

    Hello, I have moved a site from another company to our webservers which are shared servers. The DB is on a shared server and when I try to browse to the site I get this error: Any ideas how to fix this anyone?

    The hosting company have taken this code out of the web.config:

    <system.web.extensions>
    <scripting>
    <scriptResourceHandler enableCompression="true" enableCaching="true" />
    </scripting>

    to see how that works but now we are getting this - they have asked whether it's because it was on a private server previously.

     

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>
  • David Dimmer 76 posts 134 karma points
    Jun 11, 2013 @ 17:08
    David Dimmer
    0

    Can you turn off custom errors so we can get more details?

    -David Dimmer

    Fyin.com

  • Debbie Lawrenson 55 posts 75 karma points
    Jun 11, 2013 @ 17:14
    Debbie Lawrenson
    0

    Hi David,

    I think it is already off isn't it? From the the looks of the above. The hosting company is sugesting that there may be a lot of libraries and modules that are ref'd in the web config which we don't have on our server hence the errors.

    As a newbie I can't look at the web.config and detect this though.

  • David Dimmer 76 posts 134 karma points
    Jun 11, 2013 @ 17:40
    David Dimmer
    0

    Debbie, 

    Your error message is explaining how custom error work.  

    Add this and repost the error, which host are you using?  

     

     

    <system.web>
           
    <customErrorsmode="Off"/>

     

  • Debbie Lawrenson 55 posts 75 karma points
    Jun 11, 2013 @ 17:48
    Debbie Lawrenson
    0

    We are using Heart Internet in the UK. The host guys have suggested that there may be custom libraries on the old server which we no longer have access to and that there are a lot of ref'd functions and modules in the web.config. This is way over my head technically, I wouldn'd even know what to look for having judt done the training last week! Eek! Would it help if I posted the web.config here? I know that the DB name, username and password hve been changed in the DB but the relevant bits have been altered in the config fie.

    Thanks David :)

  • Debbie Lawrenson 55 posts 75 karma points
    Jun 11, 2013 @ 17:50
    Debbie Lawrenson
    0

    Just had this back from the hosting company:

    Thanks for getting back to me. I can imagine this is being quite testing. When we make a change to the script, it keeps on causing another one. So to begin with, we had this problem:

    Config Source

    156: <!-- ASPNETAJAX --> 157: <system.web.extensions> 158: <scripting>

    Links and More Information This error occurs when there is a problem
    reading the configuration file for the Web server or Web application.
    In some cases, the event logs may contain more information about what
    caused this error.

    [1]View more information ยป

    We then took this out of the document to see if we could move on. This is now causing this problem:

    Parser Error Message: Unrecognized attribute 'targetFramework'. Note
    that attribute names are case-sensitive.

    Source Error:


    Line 106: <add verb="GET,HEAD,POST" path="GoogleSpellChecker.ashx" type="umbraco.presentation.umbraco_client.tinymce3.plugins.spellchecker.GoogleSpellChecker,umbraco" />
    Line 107: </httpHandlers> Line 108: <compilation defaultLanguage="c#" batch="false" targetFramework="4.0"> Line 109: <assemblies>
    Line 110: <!-- ASP.NET 4.0 Assemblies -->


    These are all extracted directly from a server level.

  • Debbie Lawrenson 55 posts 75 karma points
    Jun 11, 2013 @ 17:59
    Debbie Lawrenson
    0

    I have now set the customerrors to off but it's not changing the error page.

  • David Dimmer 76 posts 134 karma points
    Jun 11, 2013 @ 19:04
    David Dimmer
    0

    Your host isn't configured to use ASP.net 4.0; our team could help you publish this and confirm your host is compatible.  Give a call to us 888.466.0101 x1.  

  • Debbie Lawrenson 55 posts 75 karma points
    Jun 11, 2013 @ 19:22
    Debbie Lawrenson
    0

    Oh okay. Where are you guys based? 

  • Debbie Lawrenson 55 posts 75 karma points
    Jun 11, 2013 @ 20:22
    Debbie Lawrenson
    0

    Hi, I reset the application pool to v4.0 and recylced the pool to clear the cache but still no joy. Still the same error, sigh.

    I may well call you tomorrow, is that the number I have to call from the UK?

    Thanks,

    Deb

  • David Dimmer 76 posts 134 karma points
    Jun 11, 2013 @ 20:52
    David Dimmer
    0

    Fyin.com is located just north of Chicago in Milwaukee, WI.  

  • Debbie Lawrenson 55 posts 75 karma points
    Jun 11, 2013 @ 23:44
    Debbie Lawrenson
    0

    Hi David, what's your time difference there so I know when to give you a call?

    Current error coming up:

    Line 66: </connectionStrings>
    Line 67: <system.web> Line 68: <customErrors mode="off" /> Line 69: <trace enabled="false" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />
    Line 70: <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="20" />

  • David Dimmer 76 posts 134 karma points
    Jun 11, 2013 @ 23:52
    David Dimmer
    0

    We are central standard time (CST) zone (UTC-6)

    -David

  • Nalysa 2 posts 72 karma points
    Oct 31, 2019 @ 05:53
    Nalysa
    0

    Hi Debbie and David!

    I have the same issue here, may I know the result?

    Thank you.

Please Sign in or register to post replies

Write your reply to:

Draft