Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • molham bakir 18 posts 38 karma points
    Aug 14, 2013 @ 00:36
    molham bakir
    0

    My website is not appearing on search results

    My website is not appearing on Google search results, why?!

    I have the sitemap correclty and Google web master is validating that. But there's no search queiry

    and that's been like this for 2 months.

    PLEASE HELP!

  • Jeroen Breuer 4860 posts 12127 karma points MVP 3x admin c-trib
    Aug 14, 2013 @ 09:31
    Jeroen Breuer
    0

    You could try the SEO Checker package. From the project page:

    Validate pages against Google recommendations
    Every page that has a template assigned can be validated. All validations are based on the "Search Engine Optimization Starter Guide" document from Google tinyurl.com/yjm24yq  check the documentation rules for a full list of all validations.

    So if you have any errors this package can tell.

    Jeroen

  • molham bakir 18 posts 38 karma points
    Aug 14, 2013 @ 09:34
    molham bakir
    0

    I believe this is not what i am facing, my problem is the way I have submitted the sitemap.xml 

    and i really don't know what to do?! 

  • Jeroen Breuer 4860 posts 12127 karma points MVP 3x admin c-trib
    Aug 14, 2013 @ 09:40
    Jeroen Breuer
    0

    The SEO Checker package can also validate a sitemap.xml file for you. Maybe you can try to submit that sitemap.

    Jeroen

  • molham bakir 18 posts 38 karma points
    Aug 14, 2013 @ 09:44
    molham bakir
    0

    I've already submitted the sitemap into Google webmaster, and its confirmed. But Google is not indexing it into search results.

  • Dave Woestenborghs 3216 posts 10808 karma points MVP 4x admin c-trib
    Aug 15, 2013 @ 10:00
    Dave Woestenborghs
    0

    Do you perhaps have robots.txt file that disallows search enginge to index your page?

  • molham bakir 18 posts 38 karma points
    Aug 15, 2013 @ 10:20
    molham bakir
    0

    Yes, that was my problem. It was set by mistake on the index nofollow.

    Problem is solved i think so far! will wait unitl Google start indexing my pages.

    THANKS!

  • Dave Woestenborghs 3216 posts 10808 karma points MVP 4x admin c-trib
    Aug 15, 2013 @ 10:22
    Dave Woestenborghs
    0

    Had made that mistake myself a couple of times...it's on my go-live checklist now.

    Dave

  • molham bakir 18 posts 38 karma points
    Sep 15, 2013 @ 13:22
    molham bakir
    0

    Unfortunity, promoto.ae only indexed my home page but not the others! 

    why is that happening? is it because the sitemap.xml showing the page un defined (e.g. promoto.ae/about-us) there's no html or something? 

     

  • molham bakir 18 posts 38 karma points
    Sep 15, 2013 @ 13:25
    molham bakir
    0

    This is the message from Google webmaster: Googlebot couldn't crawl this URL because it points to a non-existent page. Generally, 404s don't harm your site's performance in search, but you can use them to help improve the user experience. More info.

  • molham bakir 18 posts 38 karma points
    Sep 15, 2013 @ 13:48
    molham bakir
    0

    Another note: Usually when you copy a text from the home page and past it into Google, the links if that text should appear. but if i copy text from inside promoto.ae home page, google won't results! so basically non of the pages are indexing! 

Please Sign in or register to post replies

Write your reply to:

Draft