Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rich Lee 26 posts 116 karma points
    Sep 03, 2013 @ 16:41
    Rich Lee
    0

    6.1.5 Invalid object name 'umbracoUser'

    ASP.NET MVC4 solution with Umbraco 6.1.5. from NuGet.

    Seeing this when running in web.config with 

    <add key="umbracoConfigurationStatus" value="" />

    I'm using the same steps I used in 6.1.3 which worked consistently: new empty SQLExpress database, change config, run the project.

     

    An upgrade from the last version we used (6.1.3) isn't feasible in our multi-dev environment - we quite often need to spin up a site from scratch.

     

    Any ideas appreciated, or an ack that there's an issue.

     

    Rich

  • Sebastiaan Janssen 5018 posts 15341 karma points MVP admin hq
    Sep 05, 2013 @ 16:38
    Sebastiaan Janssen
    100

    You don't happen to have a connection string configured yet, do you? I think it might only try to install the schema into the database when you have an empty connection string AND an empty umbracoConfigurationStatus.

    So: for a fresh install with nothing in the database yet: have both an empty connection string and an empty umbracoConfigurationStatus.

    For an upgrade using an existing database with existing data leave the umbracoConfigurationStatus and the connection string intact and the installer will do any necessary upgrades (none between 6.1.3 and 6.1.5).

  • Rich Lee 26 posts 116 karma points
    Sep 06, 2013 @ 10:42
    Rich Lee
    0

    Thanks Sebastiaan for responding.

    I did have a connection string preconfigured.

    Hmm.. I can't repro the problem now: I just retried - first with no conn string and details enterd via the Umbraco setup pages, then with a conn string in web.config. Both worked OK.

    I've seen the error a number of times, so I'll keep an eye out for a consistent & reproducible instance.

    Rich 

Please Sign in or register to post replies

Write your reply to:

Draft