Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Terry Clancy 204 posts 943 karma points
    Nov 18, 2013 @ 09:59
    Terry Clancy
    0

    Installing Umbraco 6.1.6 on GoDaddy Hosting Service

    Dear Umbraco Folk,

    I have followed the instrunctions at http://www.storminternet.co.uk/support_kb_detail.asp?Key=umbraco to install Umbraco  6.1.6 on the GoDaddy Hosting Service but I am getting the following error:

     

    >>>>>>>>>>>>>>>>>

     

    Server Error in '/' Application.

    Access to the path 'G:\PleskVhosts\sketchmotion.com\httpdocs\Views\Partials' is denied.

     

     

     

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.UnauthorizedAccessException: Access to the path 'G:\PleskVhosts\sketchmotion.com\httpdocs\Views\Partials' is denied.

    ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6 and IIS 7, and the configured application pool identity on IIS 7.5) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

    To grant ASP.NET access to a file, right-click the file in File Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace:

    [UnauthorizedAccessException: Access to the path 'G:\PleskVhosts\sketchmotion.com\httpdocs\Views\Partials' is denied.]
       System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +10797222
       System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost) +10589262
       System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost) +136
       System.IO.Directory.CreateDirectory(String path) +33
       Umbraco.Web.Mvc.RenderViewEngine.EnsureFoldersAndFiles() +182
       Umbraco.Web.Mvc.RenderViewEngine..ctor() +433
       Umbraco.Web.WebBootManager.Initialize() +150
       Umbraco.Core.UmbracoApplicationBase.StartApplication(Object sender, EventArgs e) +89
       Umbraco.Core.UmbracoApplicationBase.Application_Start(Object sender, EventArgs e) +9
    
    [HttpException (0x80004005): Access to the path 'G:\PleskVhosts\sketchmotion.com\httpdocs\Views\Partials' is denied.]
       System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +9860497
       System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +118
       System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +172
       System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +336
       System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +296
    
    [HttpException (0x80004005): Access to the path 'G:\PleskVhosts\sketchmotion.com\httpdocs\Views\Partials' is denied.]
       System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +9874840
       System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +101
       System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +254
    



    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18056

     

    <<<<<<<<<<<<<<<<<<<<<

    At home on my WIndows Server 2012 machine I run the following batch file to set permissions to avoid similar problems:

    >>>>>>>>>>>>>>>>>>>>

    icacls App_Browsers /grant "IIS APPPOOL\ArtZen":(OI)(CI)RX
    icacls App_Code /grant "IIS APPPOOL\ArtZen":(OI)(CI)RX
    icacls App_Data /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls App_Plugins /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls bin /grant "IIS APPPOOL\ArtZen":(OI)(CI)WRX
    icacls Config /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls css /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls Install /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls macroScripts /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls masterpages /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls media /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls scripts /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls Umbraco /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls Umbraco_Client /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls usercontrols /grant "IIS APPPOOL\ArtZen":(OI)(CI)WRX
    icacls Views /grant "IIS APPPOOL\ArtZen":(OI)(CI)WRX
    icacls xslt /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls web.config /grant "IIS APPPOOL\ArtZen":(OI)(CI)M
    icacls web.config /grant "IIS APPPOOL\ArtZen":M

    <<<<<<<<<<<<<<<<<<<<

    Do I need to do a similar thing on the GoDaddy site ?

    And if so is there a way to run a script similar to the above on the GoDaddy hosting service ? 

    Altermatively is there a different way to approach this ?

    Thanks for your help

     

    Terry Clancy

  • John Palmer 75 posts 199 karma points
    Nov 25, 2013 @ 07:00
    John Palmer
    0

    It seems you cant install Umbraco on Godaddy as Umbraco requires Full Trust permission. As far as I know Godaddy doesnt support Full Trust permission. If you require full trust permission, you need to find other hosting provider. My client use asphostportal.com and they do provide full trust.

  • Amir Khan 1263 posts 2674 karma points
    Nov 25, 2013 @ 18:44
    Amir Khan
    0

    Hi Terry, hope you've figured this out. There isn't really a great way to set file permissions through a Plesk panel, you'll just have to do it manually.

  • Terry Clancy 204 posts 943 karma points
    Nov 25, 2013 @ 20:49
    Terry Clancy
    0

    Thanks Amir,

    Yes you are correct, I have confirmed with GoDaddy that there is no way to script the setting of file permissions using the Plesk Panel and there is no way to execute Bach files on the server.

    I wonder if this could be done using an FTP Script.  I installed ncftp because it supports chmod for setting permissions - but when I tried to use it agains my GoDaddy site it failed with a server failure.  I am not sure if there is another approach.

    Thanks

    Terry

  • Amir Khan 1263 posts 2674 karma points
    Nov 25, 2013 @ 23:38
    Amir Khan
    0

    Hi Terry,

    I don't think using an FTP script isn't going to help because you need to set permissions for the user of the Application Pool or Network Service, not the FTP user.

    Were you able to get things working by changing the permissions for all of the folders in this link via the Plesk panel? http://our.umbraco.org/wiki/reference/files-and-folders/permissions

    -Amir

  • John Palmer 75 posts 199 karma points
    Nov 26, 2013 @ 04:49
    John Palmer
    0

    As far as I know Godaddy doesnt support full trust permission. To install umbraco you need full permission to your folder. If not, you will receive above error message.

  • Terry Clancy 204 posts 943 karma points
    Nov 26, 2013 @ 20:33
    Terry Clancy
    0

    Hi - yes I now have the site running by setting permissions manually using the Plesk Pannel.  So far everything is working well  running Umbraco 6.1.6.

    Howeverstill working on getting  Umbraco 7.0.0installed on Go Daddy :-(

    Terry

  • Amir Khan 1263 posts 2674 karma points
    Nov 26, 2013 @ 20:37
    Amir Khan
    0

    If you want inexpensive and reliable Umbraco hosting in the US, probably want to roll with SoftSys: http://www.softsyshosting.com/windows.aspx

  • Terry Clancy 204 posts 943 karma points
    Nov 26, 2013 @ 21:59
    Terry Clancy
    0

    I just talked to GoDaddy support and they do now support Full Trust.

    However they do not support .Net 4.5 on the servers managed by the "Plesk" control plannel.  Fortunately they do support .Net 4.5 on the servers managed by thier proprietry GoDaddy "Web Host" control planel.  So I am migrating from  "Plesk" to the "Web Host" control planel and will test Umbraco 7.0.0 there and will let you know how it goes..

    Yes I have heard good reports of Softsyshosting but since I am already using GoDaddy with persist with that for now to see if it will work and I will then report back on this thread.

     

    Terry Clancy

  • Jon Cuthbert 84 posts 173 karma points
    Mar 08, 2014 @ 21:29
    Jon Cuthbert
    0

    Hi Terry, I'm also installing Umbraco 6.1.6 on GoDaddy and have the same issue. Was all you did to fix this to change the permissions on the each folder using the "Files" page?

    Thanks,

    Jon

  • Zain 3 posts 23 karma points
    May 18, 2014 @ 13:49
    Zain
    0

    @Terry,

    Any luck with GoDaddy "Web Host" control planel? 

  • Chandan Kumar 3 posts 73 karma points
    Mar 12, 2017 @ 12:45
    Chandan Kumar
    0

    Virtual Directory / Directory Access Permissions --Application pool group give full control >Got the same problem Now it's fixed.

Please Sign in or register to post replies

Write your reply to:

Draft