Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Adam Maidment 2 posts 22 karma points
    Oct 16, 2009 @ 17:31
    Adam Maidment
    0

    Configuration Error on login

    Hi,

    I have developed  and run a site with Umbraco 4 with no problem at all. I have run this locally on Win 7 64 using the VistaDB.

    I have deployed the site to our live server - a shared host plan with FastHosts. The front end runs great and I can get to the login panel via www.xxx.com/umbraco/umbraco.aspx as normal. However when I login I am receiving a "Configuration Error" highlighting the line:

    <add name="UmbracoMembershipProvider" type="umbraco.providers.members.UmbracoMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="TestType" />

    Any help shedding light on this matter would be much appreciated. The full config file is as follows:

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
    <configSections>
    <section name="urlrewritingnet" restartOnExternalChanges="true" requirePermission="false" type="UrlRewritingNet.Configuration.UrlRewriteSection, UrlRewritingNet.UrlRewriter" />

    <!-- ASPNETAJAX -->
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
    <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
    <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
    <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
    <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
    <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
    <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
    </sectionGroup>
    </sectionGroup>
    </sectionGroup>

    <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
    <section name="umbraco.presentation.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
    </sectionGroup>
    </configSections>

    <urlrewritingnet configSource="config\UrlRewriting.config" />


    <appSettings>
    <add key="umbracoDbDSN" value="datalayer=&quot;VistaDB,VistaDB For Umbraco&quot;" />
    <add key="umbracoConfigurationStatus" value="4.0.2.1" />
    <add key="umbracoReservedUrls" value="/config/splashes/booting.aspx,/install/default.aspx,/config/splashes/noNodes.aspx" />
    <add key="umbracoReservedPaths" value="/umbraco/" />
    <add key="umbracoContentXML" value="/data/umbraco.config" />
    <add key="umbracoStorageDirectory" value="/data" />
    <add key="umbracoPath" value="/umbraco" />
    <add key="umbracoEnableStat" value="false" />
    <add key="umbracoHideTopLevelNodeFromPath" value="true" />
    <add key="umbracoEditXhtmlMode" value="true" />
    <add key="umbracoUseDirectoryUrls" value="false" />
    <add key="umbracoDebugMode" value="true" />
    <add key="umbracoTimeOutInMinutes" value="20" />
    <add key="umbracoDisableVersionCheck" value="true" />
    <add key="umbracoDisableXsltExtensions" value="true" />
    <add key="umbracoDefaultUILanguage" value="en" />
    <add key="umbracoProfileUrl" value="profiler" />
    <add key="umbracoUseSSL" value="false" />
    <add key="umbracoUseMediumTrust" value="false" />
    </appSettings>

    <system.net>
    <mailSettings>
    <smtp>
    <network host="127.0.0.1" userName="username" password="password" />
    </smtp>
    </mailSettings>
    </system.net>

    <!-- REMOVE FOR BETA -->
    <!-- added by NH to test foreign membership providers-->
    <connectionStrings>
    <remove name="LocalSqlServer" />
    <add name="LocalSqlServer" connectionString="Data Source=.\SQLEXPRESS;Initial Catalog=C:\USERS\HARTVIG\DOCUMENTS\VISUAL STUDIO 2005\WEBSITES\AJAXENABLEDWEBSITE2\APP_DATA\ASPNETDB.MDF;Integrated Security=True" providerName="System.Data.SqlClient" />
    </connectionStrings>

    <system.web>
    <!--
    <trust level="Medium" originUrl=".*" />-->
    <customErrors mode="Off" />
    <trace enabled="true" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />
    <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="20" />
    <globalization requestEncoding="UTF-8" responseEncoding="UTF-8" />
    <xhtmlConformance mode="Strict" />

    <pages enableEventValidation="false">
    <!-- ASPNETAJAX -->
    <controls>
    <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add tagPrefix="umbraco" namespace="umbraco.presentation.templateControls" assembly="umbraco" />
    </controls>
    </pages>

    <httpModules>
    <!-- URL REWRTIER -->
    <add name="UrlRewriteModule" type="UrlRewritingNet.Web.UrlRewriteModule, UrlRewritingNet.UrlRewriter" />
    <add name="umbracoRequestModule" type="umbraco.presentation.requestModule" />
    <!-- UMBRACO -->
    <add name="viewstateMoverModule" type="umbraco.presentation.viewstateMoverModule" />
    <add name="umbracoBaseRequestModule" type="umbraco.presentation.umbracobase.requestModule" />
    <!-- ASPNETAJAX -->
    <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    </httpModules>

    <httpHandlers>
    <remove verb="*" path="*.asmx" />
    <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />

    <!-- UMBRACO CHANNELS -->
    <add verb="*" path="umbraco/channels.aspx" type="umbraco.presentation.channels.api, umbraco" />
    <add verb="*" path="umbraco/channels/word.aspx" type="umbraco.presentation.channels.wordApi, umbraco" />
    </httpHandlers>

    <compilation defaultLanguage="c#" debug="true" batch="false">
    <assemblies>
    <!-- ASPNETAJAX -->
    <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    </assemblies>
    </compilation>

    <authentication mode="Forms">
    <forms name="yourAuthCookie" loginUrl="login.aspx" protection="All" path="/" />
    </authentication>

    <authorization>
    <allow users="?" />
    </authorization>

    <!-- Membership Provider -->
    <membership defaultProvider="UmbracoMembershipProvider" userIsOnlineTimeWindow="15">
    <providers>
    <clear />
    <add name="UmbracoMembershipProvider" type="umbraco.providers.members.UmbracoMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="TestType" />
    <add name="AspNetSqlMemberShipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="LocalSqlServer" />
    <add name="UsersMembershipProvider" type="umbraco.providers.UsersMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" />
    </providers>
    </membership>

    <!-- added by NH to support membership providers in access layer -->
    <roleManager enabled="true" defaultProvider="UmbracoRoleProvider">
    <providers>
    <clear />
    <add name="UmbracoRoleProvider" type="umbraco.providers.members.UmbracoRoleProvider" applicationName="umbraco" />
    </providers>
    </roleManager>

    <!-- Sitemap provider-->
    <siteMap defaultProvider="UmbracoSiteMapProvider" enabled="true">
    <providers>
    <clear />
    <add name="UmbracoSiteMapProvider" type="umbraco.presentation.nodeFactory.UmbracoSiteMapProvider" defaultDescriptionAlias="description" securityTrimmingEnabled="true" />
    </providers>
    </siteMap>
    </system.web>

    <!-- ASPNET3.5 CODEDOM-->
    <system.codedom>
    <compilers>
    <compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
    <providerOption name="CompilerVersion" value="v3.5" />
    <providerOption name="WarnAsError" value="false" />
    </compiler>
    </compilers>
    </system.codedom>


    <!-- ASPNETAJAX -->
    <system.web.extensions>
    <scripting>
    <scriptResourceHandler enableCompression="true" enableCaching="true" />
    </scripting>
    </system.web.extensions>



    <!--
    The system.webServer section is required for running ASP.NET AJAX under Internet
    Information Services 7.0. It is not necessary for previous version of IIS.
    -->
    <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    <modules>
    <!-- Asp.net 3.5 Modules-->
    <remove name="ScriptModule" />
    <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

    <!-- UMBRACO modules-->
    <add name="UrlRewriteModule" type="UrlRewritingNet.Web.UrlRewriteModule, UrlRewritingNet.UrlRewriter" />
    <add name="umbracoRequestModule" type="umbraco.presentation.requestModule" />
    <add name="viewstateMoverModule" type="umbraco.presentation.viewstateMoverModule" />
    <add name="umbracoBaseRequestModule" type="umbraco.presentation.umbracobase.requestModule" />
    </modules>
    <handlers>
    <!-- Asp.net 3.5 handlers-->
    <remove name="WebServiceHandlerFactory-Integrated" />
    <remove name="ScriptHandlerFactory" />
    <remove name="ScriptHandlerFactoryAppServices" />
    <remove name="ScriptResource" />
    <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

    <!-- UMBRACO Handlers -->
    <add verb="*" name="Channels" path="umbraco/channels.aspx" type="umbraco.presentation.channels.api, umbraco" />
    <add verb="*" name="Channels_Word" path="umbraco/channels/word.aspx" type="umbraco.presentation.channels.wordApi, umbraco" />
    </handlers>
    </system.webServer>

    <!-- Ajax 1.0 Compatibility -->
    <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <dependentAssembly>
    <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" />
    <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
    </dependentAssembly>
    <dependentAssembly>
    <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35" />
    <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
    </dependentAssembly>
    </assemblyBinding>
    </runtime>
    </configuration>

    Thanks

    Adam

  • Sebastiaan Janssen 4876 posts 14545 karma points MVP admin hq
    Oct 18, 2009 @ 13:34
    Sebastiaan Janssen
    0

    Sounds like a permissions problem. I'm not too familiar with the permissions needed on hosting machines, but it seems like the umbracoMembershipProvider can't be loaded.

    Other than that, the only difference in my web.config seems to be that I added the hashed passwords, that might help?

    <add name="UmbracoMembershipProvider" type="umbraco.providers.members.UmbracoMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="TestType" passwordFormat="Hashed" />

    <add name="UsersMembershipProvider" type="umbraco.providers.UsersMembershipProvider" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" passwordFormat="Hashed" />

    Oh, I also see a difference in the modules section, mine says:

    <modules runAllManagedModulesForAllRequests="True">
  • Adam Maidment 2 posts 22 karma points
    Oct 19, 2009 @ 16:33
    Adam Maidment
    0

    Thanks for the reply S_J. I've done some digging and found out the shared hosting package in place is only a Medium Trust environment, so I expect that's the reason for the issue.

    Time to change hosts it seems.

  • Daniel Ferreira 4 posts 22 karma points
    Nov 09, 2009 @ 18:23
    Daniel Ferreira
    0

    I got the same error. I have deployed the site in this Host: http://www.plugin.com.br/

    Any help?

  • Salar Golestanian 2 posts 22 karma points
    Apr 08, 2010 @ 16:55
    Salar Golestanian
    0

    Sorry if this has been answered before, But I dont seem to be able to find any reference other than this post.

    This is my first time trying to evaluate Umbraco 4.0.3

    I wanted to install it on the windows 2003 server with sql server 2005. I created a blank db, and have given necessary permission to the folders. And created a website in IIS the usual way. created its own Application Pool.

    I have given the site a domain name and get the same error.

    I wonder if you have any ideas or if there are any documentations in setting up the site on IIS. I have only spent about 10 minutes to reach this step and I may need to do more readings on documentations.

    Many thanks in advance

    Salar


     

     

     

  • Salar Golestanian 2 posts 22 karma points
    Apr 08, 2010 @ 17:00
    Salar Golestanian
    0

    Sorry my post is missing the screen-shot here:- 

  • Stefan van Leusden 21 posts 73 karma points
    Aug 28, 2012 @ 10:48
    Stefan van Leusden
    0

    If anyone else came across this error like i did for an UMB 4.0 project:

    Try to add <trust level="Full"/> in the <system.web> section in your web.config.

    Source: http://msdn.microsoft.com/en-us/library/ff648344.aspx

     

  • Damian Green 452 posts 1433 karma points
    Oct 09, 2015 @ 16:56
    Damian Green
    2

    Old post but i got this after 7.3 upgrade and it was because my Global.asax had been deleted.

    Completely unrelated error - had me stumped for a while!

  • mmaty 75 posts 178 karma points
    Oct 29, 2015 @ 09:24
    mmaty
    0

    @Damian

    Thanks a lot! You saved me a lot of time. There are some more files deleted (like config files). I don't know, why they are deleted, but I was able to identify these files with my SVN. This might help somebody others.

    -Mirko

Please Sign in or register to post replies

Write your reply to:

Draft