Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Gaurav Gupta 17 posts 39 karma points
    Apr 24, 2014 @ 13:04
    Gaurav Gupta
    0

    Installing Umbraco

    Hi,

    During the installation of umbraco I always got this message.

    Managed Debugging Assistant 'LoaderLock' has detected a problem in 'C:\Program Files (x86)\IIS Express\iisexpress.exe'.

     

    What is this?and why it comes?

    Please help me.

    Thanks in advance.

  • Jan Skovgaard 11264 posts 23592 karma points MVP 8x admin c-trib
    Apr 24, 2014 @ 13:10
    Jan Skovgaard
    0

    Hi Gaurav

    Make sure you follow the documentation on installing Umbraco very carefully.

    I think the above error is either due to permissions or the fact that some other process is for some reason trying to access the site somehow.

    I suppose you're using IISexpress in combination with CE SQL?

    /Jan

  • Nicholas Westby 2043 posts 7020 karma points c-trib
    Aug 21, 2014 @ 18:16
    Nicholas Westby
    0

    FYI, I just got this problem with a fresh install of Umbraco 7.1.5 (just released today). I was running it from Visual Studio 2013 Update 3 as a Website (rather than a Web Application).

    Happened during the customize stage of the Umbraco install. I clicked the first thumbnail for a starter kit (annoyingly, I was just trying to see more info about the starter kit, but that kicked off the installation immediately), then during the install it displayed the error (see screenshot below). I was indeed using SQL Server CE and the website was configured to use IISExpress. The installation appeared to finish without any other issues (I was able to view the starter kit homepage).

    LoaderLock Error

  • Nicholas Westby 2043 posts 7020 karma points c-trib
    Aug 21, 2014 @ 18:27
    Nicholas Westby
    0

    Interestingly, this appears to be reproducible. I discarded my changes (I'm using Git) because I wanted to start over without installing a starter kit, and I got the exact same error dialog during the install process.

    Also, the dialog actually appeared twice during the install. I think it did that during the last install too, but I wasn't sure because I wasn't sure if I just forgot to click "Continue".

  • Nicholas Westby 2043 posts 7020 karma points c-trib
    Aug 21, 2014 @ 18:33
    Nicholas Westby
    0

    Note that an issue has already been created for this error: http://issues.umbraco.org/issue/U4-2779 ("Errors when I try to install 6.1.5 - anyone else seeing this?")

  • Nicholas Westby 2043 posts 7020 karma points c-trib
    Aug 21, 2014 @ 18:40
    Nicholas Westby
    0

    To add some further details. Turns out installing Umbraco without clicking "Customize" still installs a starter kit, so I ended up installing Umbraco a third time. During this third install, I customized the install to avoid installing a starter kit, and I only got the error dialog once (at the end of the install).

    Windows 8.1 Enterprise. Visual Studio 2013 Update 3. Web Essentials 2013 (the one released August 7th, 2014 for Visual Studio 2013 Update 3).

  • Keith Emery 1 post 21 karma points
    Jan 30, 2015 @ 22:45
    Keith Emery
    0

    I had this problem on a fresh install of 7.2.1 with Visual Studio 2013. The solution here worked perfectly: http://rtslink.blogspot.com/2009/03/attempting-managed-execution-inside-os.html

  • palaksha 1 post 21 karma points
    Feb 25, 2015 @ 15:10
    palaksha
    0

    I had this problem when Running the application for first time. After closing the VLC media player it is working fine

Please Sign in or register to post replies

Write your reply to:

Draft