Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • nigel 6 posts 26 karma points
    Nov 02, 2009 @ 18:08

    Cannot log in as admin after simple install (cassini, vistadb)

    I have installed Umbraco, using the embedded VistaDB, following the guide at:-

    I changed the admin password when prompted during the install, making absolutely sure I had an accurate note of the password (which was a weak one).

    I cannot login as admin and see anything of the admin goodies although the runway website itself works.

    When I try to login in

    a) If I enter the correct password both the username and password field are cleared

    b) If I enter an incorrect password, only the password field is cleared

    This makes me think that the login was successful when a correct password is enter but something is going wrong beyond that.

    I have uninstalled, re-installed 3 times, double checking and no joy at all.

    Maybe should note that I already had Cassini and VistaDb (3.4.1) installed as I use these regularly.

    Really appreciate any help in getting access to this - sounds brilliant - be good to see it in operation!


  • Immo Wache 69 posts 224 karma points
    Nov 03, 2009 @ 20:16
    Immo Wache

    Hi Nigel,

    basicly it should work with current versions V4.0.2.1 and V4.0.3beta. V4.1beta currently don't support VistaDB.

    May be it has to do with your VistaDb (3.4.1)  Installation on your PC. I could imagine Umbraco is using the VistaDb assemblies from your global assembly cache, instead of using the ones it should use in your application path /bin folder.

    May be you can test this by rename (deactivate) the VistaDB.NET20.dll in the umbraco /bin folder. If your application still works the same it's using the wrong VistaDB assembly. For this case I think you can refer the correct /bin vistadb assembly in your web.config file.


  • nigel 6 posts 26 karma points
    Nov 06, 2009 @ 17:26

    Thanks Immo for your suggestion - tried renaming as you suggest but no luck (umbraco throws a wobbler due to the missing dll).

    Really struggling as to where to look.

    I have now tried run it up under VS2005 and see this error:-

    Error 1 The virtual path '/masterpages/RunwayMaster.master' maps to another application, which is not allowed. C:\Umbraco\masterpages\RunwayHomepage.master 1 

    Not sure if this is a feature of trying to run under VS2005?

    Will have a another look thru the forum


  • nigel 6 posts 26 karma points
    Nov 06, 2009 @ 19:02

    Further to my previous post, I have re-installed cleanly again (8th time and counting ... must be keen)

    This time I elected to use mySQL - the install appeared to work just fine and the relevant table were created in mySQL.

    Exactly the same issue ... being not able to login as admin ... the password box simply clears and I get nothing in the way of a message.

    Running on Windows XP professional.

    Using a pre-installed Cassini (for VS2005, 2.0)

    Really stuck ... but persistant!



  • Petr Snobelt 923 posts 1535 karma points
    Nov 06, 2009 @ 23:18
    Petr Snobelt

    Isn't it related to password format in web.config? You can try passwordFormat="Clear"

    BTW:Why you don't try embeded msSQL

    <add name="UsersMembershipProvider" 
    ="false" enablePasswordReset="true"
    ="false" passwordFormat="Clear" />

  • Immo Wache 69 posts 224 karma points
    Nov 07, 2009 @ 09:28
    Immo Wache

    Hi Nigel,

    first: (only to make sure for the case) I assume you are using umbraco version

    second: you should make sure for correct path access rights for your C:\Umbraco folder + subfolders. This is described for XP in in section "Set file permissions".

    But be aware that Cassini runs with your own user account. So you must replace or add access rights of [your machine]\ASPNET with your local account [your machine]\[your login name].

    third: You should try to use IIS from your Windows XP. You can follow for that the XP book. Make sure you have installed all the required software for umbraco 4 (like described in the book you followed in your first post). Then you just need only the step from XP configure-iis, see my link.

    4th a tip: after umbraco setup (with vistadb, admin pass, runway and so on) you can enter the default backend url http://localhost/umbraco/umbraco.aspx in the last step installation window into your browser and you should come direct to the backend without need to login.

    HTH more, Immo

Please Sign in or register to post replies

Write your reply to: