Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • George 58 posts 165 karma points
    Oct 13, 2014 @ 11:10
    George
    0

    Manual install of Umbraco 7.1.8 Error

    We are currently running Umbraco 7.0.1.

    I wanted to update our website to Umbraco 7.1.8

    I downloaded it here http://our.umbraco.org/contribute/releases/718

    Then I started copying the files folder by folder, I only had to take care while merging web.config.

    When I try to open the site itself or umbraco, I get "Welcome to the Umbraco installer. " page with only 1 button - continue.

    The next page shows "Error during installation" and references the log file in App_Data.

    The log file contains the following:

    2014-10-13 11:02:46,471 [60] INFO  Umbraco.Core.ApplicationContext - [Thread 63] CurrentVersion different from configStatus: '7.1.8',''
    2014-10-13 11:02:46,471 [60] WARN  Umbraco.Web.UmbracoModule - [Thread 63] Umbraco is not configured
    2014-10-13 11:02:46,513 [60] INFO  Umbraco.Core.ApplicationContext - [Thread 52] CurrentVersion different from configStatus: '7.1.8',''
    2014-10-13 11:02:47,282 [60] INFO  Umbraco.Core.ApplicationContext - [Thread 62] CurrentVersion different from configStatus: '7.1.8',''

    -I looked at this thread http://our.umbraco.org/forum/getting-started/installing-umbraco/53416-manual-install-of-714-not-working and I tried giving permissions for the root folder of umbraco to IUSR, NetWork Service , IIS Users, and "Authorsied Users", and all subfolders.

    -I restarted IIS service and the computer

    The error still persists, and I can't find any other solution. Anyone got any ideas on how to solve this?

     

  • Dave Woestenborghs 3431 posts 11702 karma points MVP 7x admin c-trib
    Oct 13, 2014 @ 11:27
    Dave Woestenborghs
    0

    What do you have in the appsetting "umbracoConfigurationStatus". Does it state 7.0.1 or 7.1.8.

    If it says 7.1.8 it assumes you have ran the upgrade already and finished it succesfully. And maybe this is the problem.

    Dave

  • George 58 posts 165 karma points
    Oct 13, 2014 @ 11:34
    George
    0

    Thanks for the reply, Dave

    I tried running the update with '7.0.1' and with an empty value '' for umbracoConfigurationStatus

    Both of them show the same error, the only difference being the second parameter in the error text:

    2014-10-13 11:30:37,701 [6] INFO  Umbraco.Core.ApplicationContext - [Thread 1] CurrentVersion different from configStatus: '7.1.8','7.0.1'

     

  • Dave Woestenborghs 3431 posts 11702 karma points MVP 7x admin c-trib
    Oct 13, 2014 @ 11:44
    Dave Woestenborghs
    0

    Maybe a stupid question. Do you have a install folder in your solution ?

    Dave

  • George 58 posts 165 karma points
    Oct 13, 2014 @ 12:18
    George
    0

    No install folder in the root folder. A quick seach shows the following folders:
    root\umbraco\install\
    root\umbraco\views\install\
    root\app_data\temp\install\

    I have purged app_data multiple times (deleted everything inside) - same error.
    Removing \umbraco\views\install\ shows the same error.
    Removing \umbraco\install\ crashes the setup at the very first page, saying something like "umbraco\install\* missing".

    I removed the root\install folder during our last update from umbraco 4.9 to umbraco 7.0.1

     

  • Sebastiaan Janssen 5017 posts 15339 karma points MVP admin hq
    Oct 15, 2014 @ 13:17
    Sebastiaan Janssen
    0

    Umbraco 7 doesn't have an install folder in the root, so that's good that you don't have one. Could you set debug=true in the compilation section of your web.config and see if there's better information in the logs then? Also make sure to check that umbracoVersion is set to 7.0.1 and that your connection string is still correct/valid.

  • George 58 posts 165 karma points
    Jan 26, 2015 @ 11:53
    George
    0

    Hello Again,

    I have started trying the update process again , but this time I am attempting to update to version 7.2.1. 
    Umbraco is still sitting at 7.0.1 since my last attempt failed miserably.

     I have replicated all the steps as I did with my last attempt, but I keep getting the same problem :

     2015-01-26 11:29:18,819 [81] WARN  Umbraco.Web.UmbracoModule - [Thread 104] Umbraco is not configured
     2015-01-26 11:29:19,135 [81] INFO  Umbraco.Core.ApplicationContext - [Thread 98] CurrentVersion different from configStatus: '7.2.1','7.0.1'

    I have given IUSR, IIS_IUSRS, IIS_WPG full access to the drive itself and all subfolders of the drive where Umbraco is installed.
    I have set debug=true in the compilation section of my web.config, but that didn't make the log more informative.
    My connection string (for DB I assume) is working fine with version 7.0.1. It is being used daily. I haven't touched it in web.config.


    Is there any way I can get more info about this error?
    When the Log file is spamming only the 2 lines I quoted, it is not very helpful for solving the problem... 

  • George 58 posts 165 karma points
    Jan 26, 2015 @ 12:52
    George
    0

    UPDATE: Problem solved.

     Check your browser console and refer to these links you encounter the same problem:

    http://stackoverflow.com/questions/16967134/odd-exception-scenario-system-net-http-mediatypeheadervalue-cannot-be-cast-to-me
    http://our.umbraco.org/forum/getting-started/installing-umbraco/52843-Issue-upgrading-from-704-to-712

    tl;dr: I edited <dependentAssembly> for System.Net.Http and added the no-redirect rule for /install*

    I finally managed to install version 7.2.1!

Please Sign in or register to post replies

Write your reply to:

Draft