Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Kevin Slowey 2 posts 22 karma points
    Dec 17, 2014 @ 19:47
    Kevin Slowey

    The ConnectionString property has not been initialized

    Trying to install 7.2.1 on

    Mac Mini with VMWare Fusion 7, WIndows 8.1 IIS 8, VS 2013, ASP.NET 4.5,

    Installing as admin in a blank project from NuGet console.

    Build Project

    Started without debugging.

    Put in username, email etc.

    Setup database Using either SQL server or CE.

    On the screen for adding a website, Whether I choose on install a website or not:

    getting a "The connectionstring property has not been initialized" error.

    The database seems to be populated "no way of telling if complete as I am new to this".

    Connection string is in the config as expected, with correct creds.

    Rerun as "start without debbuging" returns to setup screen.

    Log as follows.

    2014-12-17 18:14:43,067 [10] ERROR Umbraco.Web.Install.Controllers.InstallApiController - [Thread 8] An error occurred during installation step User
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException: The ConnectionString property has not been initialized.
       at System.Data.SqlClient.SqlConnection.PermissionDemand()
       at System.Data.SqlClient.SqlConnectionFactory.PermissionDemand(DbConnection outerConnection)
       at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
       at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
       at System.Data.SqlClient.SqlConnection.TryOpenInner(TaskCompletionSource`1 retry)
       at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource`1 retry)
       at System.Data.SqlClient.SqlConnection.Open()
       at Umbraco.Core.Persistence.FaultHandling.RetryPolicy.<>c__DisplayClass1.<ExecuteAction>b__0()
       at Umbraco.Core.Persistence.FaultHandling.RetryPolicy.ExecuteAction[TResult](Func`1 func)
       at Umbraco.Core.Persistence.FaultHandling.RetryPolicy.ExecuteAction(Action action)
       at Umbraco.Core.Persistence.PetaPocoConnectionExtensions.OpenWithRetry(IDbConnection connection, RetryPolicy retryPolicy)
       at Umbraco.Core.Persistence.PetaPocoConnectionExtensions.OpenWithRetry(IDbConnection connection)
       at Umbraco.Core.Persistence.Database.OpenSharedConnection()
       at Umbraco.Core.Persistence.Database.<Query>d__1c`1.MoveNext()
       at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
       at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
       at Umbraco.Core.Persistence.Database.Fetch[T1,T2,TRet](Func`3 cb, Sql sql)
       at Umbraco.Core.Persistence.Repositories.UserRepository.PerformGet(Int32 id)
       at Umbraco.Core.Persistence.Repositories.RepositoryBase`2.Get(TId id)
       at Umbraco.Core.Services.UserService.GetUserById(Int32 id)
       at Umbraco.Web.Install.InstallSteps.NewInstallStep.Execute(UserModel user)
       --- End of inner exception stack trace ---
       at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
       at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
       at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
       at Umbraco.Web.Install.Controllers.InstallApiController.ExecuteStep(InstallSetupStep step, JToken instruction)
       at Umbraco.Web.Install.Controllers.InstallApiController.PostPerformInstall(InstallInstructions installModel)

    Really getting quite frustrated, esp since everyone else seems to get a clean install.

    Any help appreciated.

  • Tobbe 3 posts 23 karma points
    Jan 10, 2015 @ 20:13

    Did you find any solution to this? getting the same error.. :(

  • Jan Skovgaard 11280 posts 23678 karma points MVP 11x admin c-trib
    Jan 10, 2015 @ 23:20
    Jan Skovgaard

    Hi guys

    Do you have resharper enabled? If so try disabling it during the installation of Umbraco. Does that help any?


  • Tobbe 3 posts 23 karma points
    Jan 10, 2015 @ 23:49


    Nope, I havent resharper. In fact I haven't even opened VS. I've just copied the files to the server, started it and filled out all umbraco install stuff (the custom choice with mssql server database)

  • Kevin Slowey 2 posts 22 karma points
    Jan 12, 2015 @ 12:13
    Kevin Slowey

    No I dont have resharper installed.

    Thanks for the reply,

    any help greatly appreciated.

  • Justin Spradlin 139 posts 347 karma points
    Feb 21, 2015 @ 19:19
    Justin Spradlin

    Was there ever any resolution to this? I am also running into this same error message. I just tried to instal 7.2.2 via Nuget in Visual Studio 2013 on Windows 8 (VM hosted by Parallels). 

Please Sign in or register to post replies

Write your reply to: