Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Mike Poole 8 posts 97 karma points
    Jan 07, 2015 @ 12:51
    Mike Poole
    1

    Umbraco 7.2.1 - Build fails after deploy to Azure WebSite

    Hi,

    I'm new to Umbraco and I am just trying to install on Azure web site.

    I'm using VS2013 Community Edition on Win7.

    I locally installed UmbracoCms 7.2.1 via NuGet and my source control is to TFS which is linked from the Azure web site. So the build happens automatically after I check-in.

    Everything works great locally.

    I get the following build error when I check-in to TFS.

    C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\Web\Microsoft.Web.Publishing.targets (2292): Could not open Source file: Could not find a part of the path 'C:\a\src\mycompany.umbraco\mycompany.Umbraco\umbraco\Install\Views\Web.config;\umbraco\Install\Views\Web.config'.

    I've reviewed this bug fix here http://issues.umbraco.org/issue/U4-4510

    Not sure if this means the problem is not yet solved in 7.2.1.

    Please let me know if more info needed and I will reply asap.

    Cheers Mike

  • Mike Poole 8 posts 97 karma points
    Jan 08, 2015 @ 11:48
    Mike Poole
    0

    So I've tried a number of things incrementally to resolve the problem based on forum comments and kind advice from others.

    1. change the build action on the offending web.config file from Content to None and redeploy (this didn't change the original error message)

    2. exclude the Install folder from the local build and redeploy (this changed the build error message to the one below)

    C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\Web\Microsoft.Web.Publishing.targets (2292): Could not open Source file: Could not find a part of the path 'C:\a\src\mycompany.umbraco\mycompany.Umbraco\umbraco\Xslt\Web.config;\umbraco\Xslt\Web.config'.

    1. change the Build Action of this web.config file from Content to None and redeploy (this didn't change this error).

    There must be a minimum buildset for Umbraco so that I can exclude everything I don't need for deployment. I will start looking but please reply if you know where it is.

    Please let me know if more info needed and I will reply asap.

    Cheers Mike

  • Maff 136 posts 459 karma points
    Jan 08, 2015 @ 12:13
    Maff
    1

    Hi Mike,

    I would suggest deleting the web.config from your XSLT folder (take a backup first though) and try the build/redeploy again. You no longer need to create any XSLT files as everything can now be done using Razor scripts, so removing this file shouldn't cause a problem...

    Cheers,

    Maff

  • Mike Poole 8 posts 97 karma points
    Jan 08, 2015 @ 13:13
    Mike Poole
    0

    Hi Maff,

    Thanks for your reply.

    At the moment I'm just trying to prove the process of deployment and then I will re-visit all steps again once I have a route through.

    Prior to your post I excluded the XSLT directory from the solution, did local build and checked local Umbraco was working. Then did check-in which triggered the build. The same build error was occurring for the XSLT directory.

    Deleting the excluded folder didn't create a pending change locally so I checked the code files on TFS online.

    The directory was still present within the checked-in code, so I deleted the folder on TFS itself which triggered a new build.

    However, following that build, it reports the same error message even though the XSLT folder no longer exists within the checked-in code.

    Can the deployed NuGet "packages" directory that contains the UmbracoCms and UmbracoCms.Core pull through the deleted XSLT folder somehow?

    At the moment I'm leaning towards a manual install Umbraco and potentially the earlier version. e.g. http://our.umbraco.org/contribute/releases/624

    Any further thoughts amigos?

    Cheers Mike

  • Mike Poole 8 posts 97 karma points
    Jan 08, 2015 @ 23:24
    Mike Poole
    108

    I found the problem.

    I had set the Build Action from Content to None for the web.config file in the XSLT directory instead of the Umbraco\XSLT directory.

    Once I changed these then the build worked ok.

    Maff - I don't have enough Karma to High-5 you but thanks for all of your help on this one!

    cheers Mike

  • Burki 7 posts 77 karma points
    Mar 14, 2017 @ 19:05
    Burki
    0

    Thanx a lot Mike! Saved my day :)

  • Maff 136 posts 459 karma points
    Jan 09, 2015 @ 12:42
    Maff
    0

    Hi Mike,

    Great - glad you managed to get it sorted! :)

    Cheers,

    Maff

  • Simon 692 posts 1067 karma points
    Feb 05, 2015 @ 14:39
    Simon
    0

    Hi Mike and Maff,

    I have the same problem, but I changed the umbrac/xslt/web.config build proeprty from Content to None but the same still show up before publish through we deploy:

    Could not open Source file: Could not find a part of the path 'C:\.................umbraco\Xslt\Web.config;\umbraco\Xslt\Web.config'.

    Any Ideas pls?

    Thank you. 

  • Maff 136 posts 459 karma points
    Feb 05, 2015 @ 15:16
    Maff
    1

    Hi Simon,

    Have you checked that the web.config file itself has been checked in to your repository? If your solution is referencing it but the file is missing, you would get this sort of error.

    Cheers,

    Maff

  • Simon 692 posts 1067 karma points
    Mar 05, 2015 @ 21:56
    Simon
    0

    Hi Maff,

    What do you mean by "has been checked in to your repository?"

    Thank you.

    Kind Regards

  • Maff 136 posts 459 karma points
    Mar 05, 2015 @ 22:08
    Maff
    1

    Hi Simon,

    Apologies - just re-read your earlier comment and saw you are using web deploy, so source control isn't the issue.

    I had this exact problem last night whilst deploying an Azure website using web deploy, and setting the build action to 'none' for the umbraco/xslt/web.config fixed the problem.

    Can you check you've changed the right file a there are 2 xslt/web.config files in the Umbraco solution. It needs to be the one in the umbraco folder.

    Thanks,

    Maff

  • Simon 692 posts 1067 karma points
    Mar 06, 2015 @ 10:05
    Simon
    0

    Hi Maff, 

    No positive results.

    The same error. Also, when I try to delete them from VS, both the Install folder and the Umbraco/Xslt/Web.config, there will  regenerated after rebuild.

    Any Idea Matt, please?

    thank you.

  • Simon 692 posts 1067 karma points
    Mar 17, 2015 @ 09:58
    Simon
    0

    Hi,

    I have been trying to delete the Install Folder but no success. Because after each rebuild, it will be regenerated :/

    also, I changed the web.config Build action to None, and always the same error: Could not open Source file: Could not find a part of the path 'C:\Repository\Work\Clients\Current\git.demajo.com\www\deploy\Demajo\umbraco\Install\Views\Web.config;\umbraco\Install\Views\Web.config'.

    Any Ideas pls?

    thank you.

    Kind Regards

  • Maff 136 posts 459 karma points
    Mar 17, 2015 @ 10:04
    Maff
    0

    Hi,

    I don't know why the install folder would be recreated when you build the solution - I haven't seen this before.

    You could try excluding the Install folder from your Visual Studio solution - that should prevent it from being included in the build and publish to Azure.

    Thanks,

    Maff

  • Simon 692 posts 1067 karma points
    Mar 17, 2015 @ 11:15
    Simon
    0

    Hi Maff,

    Currently, I am set to include all files in folder. But, I want it to delete the Install Folder.

    I think that it is noting from the VS side, but more that Umbraco is recreating the Install folder once rebuild if it not found.

    Are there a setting or someting which may triggering this recreation?

    Thank you

    Kind Regards

  • Maff 136 posts 459 karma points
    Mar 17, 2015 @ 11:18
    Maff
    0

    Hi,

    Sorry but I have no idea why the install folder would be recreated - it's not something I've seen happen personally...

    Maff

  • Lee 1123 posts 3059 karma points
    May 18, 2015 @ 20:43
    Lee
    0

    I'm can't get this to work either :(

    I had the web.config errors, and for both the web.configs (In Umbraco/Install and Umbraco/Xslt) I changed the build action to none and managed to get past the error you were all having.

    However... I know have the following error

    Error 39 Copying file AppData\TEMP\ExamineIndexes\External\Index\segments6k to obj\Release\Package\PackageTmp\AppData\TEMP\ExamineIndexes\External\Index\segments6k failed. Could not find file 'AppData\TEMP\ExamineIndexes\External\Index\segments6k'. 0 0 Umbraco.Site

    Starting to think that it might not be possible..??

  • Lee 1123 posts 3059 karma points
    May 18, 2015 @ 20:46
    Lee
    0

    Oh. And I'm using v7.2.5 for this project, not that I think it would make a difference.

  • Lee 1123 posts 3059 karma points
    May 18, 2015 @ 20:50
    Lee
    0

    What's also weird... Examine folders are not in my solution and that file doesn't exist in my file system... :/

  • Carsten Fallesen 35 posts 154 karma points
    May 18, 2015 @ 20:52
    Carsten Fallesen
    0

    Hi Lee,

    I have seen issues like this when the files have been included in the VS project but not comitted to TFS or Git. 

    I do not normally include App_Data in neither version control nor the project.

  • Maff 136 posts 459 karma points
    May 18, 2015 @ 23:36
    Maff
    0

    Hi Lee,

    Very odd! The error message would indicate that you do have the Examine folders included in your solution somehow, or else they wouldn't be copied into that folder when the project is built/published.

    It could be that the solution file references that file - have you tried opening the csproj file in Notepad and searching for that filename?

    Thanks,

    Maff

  • Lee 1123 posts 3059 karma points
    May 19, 2015 @ 19:43
    Lee
    1

    Non existent Examine files where in my .csproj!! No idea how they got there.

    I got it working by removing those from the project file, and marking the xslt web.config file from Content to None and I think there was another one I did the same too. Then it worked fine (Well I say fine, a couple of missing external dll's which I needed to fix) :)

  • Maff 136 posts 459 karma points
    May 19, 2015 @ 23:40
    Maff
    0

    Bizarre! Pleased you got it working eventually :)

  • Tessa 20 posts 72 karma points
    Sep 08, 2015 @ 16:22
    Tessa
    0

    I had set both of those web.config files' build actions to "None" and that fixed the error and allowed me to create a deployment package.

    I'm just wondering, because I have no idea why it was broken or how doing that got it fixed, but will that have any unwanted repercussions when publishing as a file system?

    Both files being:

    • /umbraco/Install/Views/web.config
    • /umbraco/Xslt/web.config
  • Lee Conlin 1 post 20 karma points
    Jul 30, 2016 @ 02:00
    Lee Conlin
    0

    I'm having this exact same error ... completely fresh install of umbraco. Published fine earlier.

    I just tried to re-publish (as I'd changed main web.config to use transforms for production connection strings) and now get this error.

    Restored back to previous setup that worked and still get the error.

  • Zonkzen 6 posts 62 karma points
    Nov 01, 2016 @ 19:50
    Zonkzen
    6

    If you don't have a file in the root of the project called ProjectName.wpp.targets , create it. Edit the file and add:

    <Project ToolsVersion="4.0" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
     <PropertyGroup>  
     <AutoParameterizationWebConfigConnectionStrings>False</AutoParameterizationWebConfigConnectionStrings>  
     </PropertyGroup>
    </Project>
    

    The file doesn't even have to be included in the project. That's it.

  • Ashkan Sirous 38 posts 226 karma points
    Jun 11, 2018 @ 14:59
    Ashkan Sirous
    0

    Thanks!!!!!

  • Ian 23 posts 113 karma points
    Mar 22, 2017 @ 10:51
    Ian
    1

    For anyone finding this issue with web.config files other than the umbraco/Xslt one (\App_Plugins\Articulate\Views\Web.config in my case), then follow Zonkzen's answer above.

    It's based on Daniel's answer here: http://issues.umbraco.org/issue/U4-4510

    ...which references this post: https://blogs.msdn.microsoft.com/webdev/2010/11/10/asp-net-web-application-publishpackage-tokenizing-parameters/

    -see the "Prevent tokenizing connection strings" section

    Hope it helps

Please Sign in or register to post replies

Write your reply to:

Draft