Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • David Wilson 2 posts 22 karma points
    Jan 09, 2015 @ 17:58
    David Wilson
    0

    Primary Key Constraint error on new Umbraco 7 install

    I've completely new to Umbraco but have developed a few basic websites in the past.

    When running through the initial setup of Umbraco i get the following error: The database failed to install. ERROR: The database configuration failed with the following message: Violation of PRIMARY KEY constraint 'PK_structure'. Cannot insert duplicate key in object 'dbo.umbracoNode'. The duplicate key value is (-1). The statement has been terminated.

    I'm installing on IIS8 on Server 2012 in a SQL server Express 2012 database. The database is a brand new completely blank database and the SQL login im using in the Umbraco setup has owner rights on the database.

    Doing a search i see lots of errors with primary keys on upgrades to newer versions but i dont see anything about errors on a new install. How can their be a primary key violation when nothing yet exists in the database?

  • jivan thapa 194 posts 681 karma points
    Jan 11, 2015 @ 09:55
    jivan thapa
    0

    Hi, David, Have try on SQL CE? Do you get same error if you use SQL CE?

  • David Wilson 2 posts 22 karma points
    Jan 12, 2015 @ 15:20
    David Wilson
    0

    Hi, yes i tried the setup selecting SQL CE and got the same error message. I'm currently trying a deploy to my web hosted site to rule out a config error on my local IIS server.

  • Chris H 1 post 21 karma points
    Jan 13, 2015 @ 13:27
    Chris H
    0

    Hello David,

    I got the same error as you during install - this was due to downloading a dev version of umbraco from github by accident. Perhaps you did the same?

    Downloading the 7.2.1 version installed without a hitch.

    http://our.umbraco.org/contribute/releases/721

  • Christian Palm 277 posts 272 karma points
    Feb 03, 2015 @ 17:19
    Christian Palm
    0

    I got the same problem as David with Umbraco v7.2.1, clean installation and blank database.
    Windows server 2008, ms sql 2012 server

    I could resolve it with

    1. Install clean Umbraco v7.2.0
    2. Upgrade afterwards with Umbraco v7.2.1
    /C

     

     

  • Joss 10 posts 73 karma points
    Apr 10, 2015 @ 08:37
    Joss
    1

    I am having the same issue with 7.2.4. Clean install.

    Installed with 7.2.0 and upgraded to 7.2.4 with no issues.

    Did another try. I set modify rights to the ASP.NET user on the main Umbraco (project) folder, and everything went smooth with 7.2.4 too. Seems like this is happening if there is an issue with security while installing.

  • MrFlo 150 posts 393 karma points
    Apr 11, 2015 @ 20:54
    MrFlo
    0

    Yes that's the solution just give write access to the IIS User. 

    Thanks Joss!

  • Roger Withnell 127 posts 612 karma points
    Jul 01, 2015 @ 21:48
    Roger Withnell
    0

    I'm getting exactly this error. I'm trying to install Umbraco 7.2.6 using Nuget in Visual Studio 2013.

    I'm using the IIS server in Visual Studio and MSSQL 2012 on a remote server.

    Could you please let me know step by step how and where I "set the modify rights to the ASP.NET user on the main Umbraco (project) folder"?

    Your help would be much appreciated.

    Thanking you in anticipation.

    Roger

  • Jason Prothero 421 posts 1242 karma points c-trib
    Jul 01, 2015 @ 22:24
    Jason Prothero
    1

    Find the directory containing your umbraco site. This should be the directory with the web.config and folders like AppData and AppCode in it.

    Right click and select Properties. Select the 'Security' tab and click 'Edit'. Add permissions for IIS AppPool\APPPOOLNAME and give it Full or Modify permissions.

  • Roger Withnell 127 posts 612 karma points
    Jul 02, 2015 @ 18:38
    Roger Withnell
    0

    This worked, Jason, thanks.

  • Jason Prothero 421 posts 1242 karma points c-trib
    Jul 02, 2015 @ 18:56
    Jason Prothero
    0

    Great!

Please Sign in or register to post replies

Write your reply to:

Draft