Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Dakota Lightning 11 posts 42 karma points
    Feb 24, 2015 @ 00:57
    Dakota Lightning
    0

    Unable to Update Umbraco 7.8.1 from Nuget to 7.2.2 - Unable to uninstall 'Newtonsoft.Json 6.0.5'...

    Update-Package : Unable to uninstall 'Newtonsoft.Json 6.0.5' because 'Microsoft.AspNet.WebApi.Client 4.0.30506.0' depends on it.

    enter image description here

    I have tried multiple versions, 7.2, 7.2.1 and nothing works. They end in the same error, does anyone have a NUGET Solution for this? I can just drop the files in sure, but I'm looking for a NUGET fix for this update problem.

    Thanks

    I'm Using VS 2013 Update 4 with recent .NET updates.

  • Jan Skovgaard 11257 posts 23497 karma points MVP 7x admin c-trib
    Feb 24, 2015 @ 05:38
    Jan Skovgaard
    0

    Hi Dakota

    Could you try what is suggested in the answer to this and see if that helps? http://stackoverflow.com/questions/28547579/how-to-fix-newtonsoft-json-assembly-loading-error/28548392#28548392

    /Jan

  • Dakota Lightning 11 posts 42 karma points
    Feb 24, 2015 @ 19:32
    Dakota Lightning
    0

    I'm still getting the same error when trying to update.

  • Russell Fox 4 posts 24 karma points
    Aug 05, 2015 @ 08:09
    Russell Fox
    0

    I'm also new to Umbraco, installing from Package Manager Console I get

    Install-Package : Unable to uninstall 'Microsoft.AspNet.WebApi.Client 4.0.30506.0' because 'Microsoft.AspNet.WebApi.Core 4.0.30506.0' depends on it. At line:1 char:1 + Install-Package UmbracoCms -Version 7.2.8 + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand"

    If I install using GUI it works. I got stuck on this with version 7.2.7 a month back too.

    Here is a video example of it happening:

    https://youtu.be/gpnjwopHjRY

  • Graham Roberts 13 posts 42 karma points
    Jan 08, 2016 @ 14:39
    Graham Roberts
    0

    I was having this same error when using updating via nuget in VS2012. The only way to get around this problem was to install VS2013. It worked fine then

Please Sign in or register to post replies

Write your reply to:

Draft