Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • mike 90 posts 258 karma points
    Feb 27, 2015 @ 01:43

    Umbraco Exception (DataLayer): SQL helper exception in ExecuteNonQuery

    I have copied Umbraco from my local dev box to server, copied database across and set folder permissions.

    Everything seems ok And I can view site and login but when I try to create anything in control panel I get:

    Umbraco Exception (DataLayer): SQL helper exception in ExecuteNonQuery

    I looked in logs and this is the error:

    2015-02-27 00:27:09,918 [38] ERROR umbraco.DataLayer.SqlHelper`1[[System.Data.SqlClient.SqlParameter, System.Data, Version=, Culture=neutral, PublicKeyToken=]] - [Thread 22] Error executing query INSERT INTO umbracoNode(trashed, parentID, nodeObjectType, nodeUser, level, path, sortOrder, uniqueID, text, createDate) VALUES(@trashed, @parentID, @nodeObjectType, @nodeUser, @level, @path, @sortOrder, @uniqueID, @text, @createDate)

    System.Data.SqlClient.SqlException (0x80131904): Cannot insert the value NULL into column 'id', table 'xxx.dbo.umbracoNode'; column does not allow nulls. INSERT fails.

    The statement has been terminated.

       at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)

       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)

       at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)

       at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)

       at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds)

       at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite)

       at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite)

       at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()

       at Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteNonQuery(String connectionString, CommandType commandType, String commandText, SqlParameter[] commandParameters)

       at umbraco.DataLayer.SqlHelper`1.ExecuteNonQuery(String commandText, IParameter[] parameters)


    Why is it trying to insert a null value whenever I try and create something? It works fine on my local machine and to my knowledge I replicated everything across.

  • mike 90 posts 258 karma points
    Feb 27, 2015 @ 02:17

    I found out this is because I used the export feature to copy database.  I deleted database and this time used script to create and now it works.

  • Samuel Watts 4 posts 74 karma points
    Mar 30, 2016 @ 11:39
    Samuel Watts

    Had the same issue, restored from a backup of my local and it worked fine

Please Sign in or register to post replies

Write your reply to: