Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Alex Skrypnyk 6054 posts 23213 karma points MVP 5x admin c-trib
    Mar 11, 2015 @ 00:10
    Alex Skrypnyk
    0

    System.Security.Permissions.SecurityPermission at Godaddy hosting

    We have a strange error at Godaddy hosting provider 

    System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

    Permissions for files and folders are set right. What can be wrong ? 

    Thanks

  • Dan Lister 416 posts 1973 karma points c-trib
    Mar 11, 2015 @ 09:38
    Dan Lister
    100

    Hi Alex,

    I'm not sure if this will fix you issue but according to this forum post, if you set the following trust level in your web.config file, it should fix your issue:

    <system.web>
        <securityPolicy>
            <trustLevel name="Full" policyFile="internal"/>
        </securityPolicy>
    </system.web>
    

    I hope that helps.

    Thanks, Dan.

  • Alex Skrypnyk 6054 posts 23213 karma points MVP 5x admin c-trib
    Mar 11, 2015 @ 12:26
    Alex Skrypnyk
    2

    Thanks Dan, it helps:

    Changes to config -

    In appSettings:

    <add key="umbracoUseMediumTrust" value="false" />
    

    In system.web:

    <trust level="Full" originUrl="" />
    

    Thanks

  • John Palmer 75 posts 199 karma points
    Apr 01, 2015 @ 06:02
    John Palmer
    0

    If you receive above error message, you just need to give full permission to your folder. It will fix your issue. Umbraco requires full trust permission to run

  • Sam Pearson 36 posts 89 karma points
    Apr 03, 2015 @ 16:15
    Sam Pearson
    0

    Hi all,

    I'm also getting this error with GoDaddy (plesk)...

    All folder permissions are set correctly, trust is set to full, also added the key that Alex mentioned above, recycled the app pool after every change - but the error remains.

    Phoned up Godaddy, they put me on hold for 20 mins before telling me that everything was fine their end and it was an issue with the application....not really sure what to do now...

    Does anyone have any suggestions?

    -Sam

    EDIT: I'm running a fresh install of Umbraco 7.2.2 btw

     

  • Sam Pearson 36 posts 89 karma points
    Apr 03, 2015 @ 17:05
    Sam Pearson
    1

    Ok we have progress,- it seems that you have to be careful where you update your site config settings on GoDaddy.

    If you change web.config settings through the GD 'ASP.NET Settings' control panel (specifically the trust level drop down at the bottom of the page) it seems to mess up your web.config in some way, giving you security exceptions.

    Make sure you edit your web.config settings in the file directly.

    -Sam

     

  • John Palmer 75 posts 199 karma points
    Apr 06, 2015 @ 07:19
    John Palmer
    0

    Hi Sam,

    Does Godaddy support for full trust hosting? This is useless if you have setup full permission on your plesk panel but godaddy doesnt allow full trust hosting. You may check it with them. That above error clearly shows that this problem with permission only. I also had same experience with you at asphostportal.com. They give full permission and all works perfectly.

  • Sam Pearson 36 posts 89 karma points
    Apr 07, 2015 @ 09:36
    Sam Pearson
    0

    Hi John,

    Yes GoDaddy does support full trust if you have the Plesk panel version of their shared hosting. By all accounts they used to support medium trust only until recently, but definitely support full now.

    I have got the site (now running Umbraco 7.2.4) in question working now so all appears to be well. The last point I made about the config settings was crucial though - their .net control panel will screw up your web.config if you change the trust level at their end, their support guys don't seem to know about this either.

    -Sam

  • dave 36 posts 149 karma points
    May 23, 2015 @ 16:10
    dave
    2

    With 7.2.x on GoDaddy Plesk I had security issues.

    The resolution for me was to add the trust level below the customErrors manually to my web.config (if you use the godaddy dashboard to add this, it puts it specific to a umbraco directory not the upper root of the site).

    <customErrors mode="RemoteOnly" />
    <trust level="Full" originUrl="" />
    

    I also set permissions on the directories following this.. https://our.umbraco.org/documentation/Installation/permissions

  • Pramil Gawande 2 posts 72 karma points
    Oct 17, 2015 @ 19:46
    Pramil Gawande
    0

    Thanks @dave your solution was ultimate and worked for me in the first instance.

    Thanks a lot man! :)

  • Pramil Gawande 2 posts 72 karma points
    Oct 18, 2015 @ 12:48
    Pramil Gawande
    0

    If I'm using the customize option and proceeding the installation I'm getting an error.

    Error Screenshot

    The normal installation was successful.

Please Sign in or register to post replies

Write your reply to:

Draft