Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Carlos Mosqueda 239 posts 428 karma points
    Mar 11, 2015 @ 21:04
    Carlos Mosqueda
    0

    Visual Studio, running on IISExpress vs Local IIS issue

    I have a dev version of Umbraco running on my machine through Visual Studio.  When I go into the project properties and change the 'Web' tab to point and launch to my Local IIS, I am able to see my sites' home page but when I try to go the '/umbraco/' on my URL, I get a blank page.  I don't get a login screen. Just a blank page

    HOWEVER, when I launch the project with IISExpress, I am able to get the login screen and the back office.

    I look at the source for the browser page that runs when configured to use my Local IIS and it says it can't find the following files

    <script class="html-attribute-name"><!--
    type</span>="<span class="html-attribute-value">text/javascript</span>" <span class="html-attribute-name">src</span>="<a class="html-attribute-value html-resource-link" href="http://dev.mylocalsite.com/umbraco/lib/rgrove-lazyload/lazyload.js" mce_href="http://dev.mylocalsite.com/umbraco/lib/rgrove-lazyload/lazyload.js" target="_blank">lib/rgrove-lazyload/lazyload.js</a>"></span><span class="html-tag" style="font-family: monospace; font-size: medium; line-height: normal; white-space: pre-wrap;" mce_style="font-family: monospace; font-size: medium; line-height: normal; white-space: pre-wrap;">
    // --></script>
    href="/umbraco/assets/css/umbraco.css?cdv=460158730" type="text/css" rel="stylesheet"/>href="/umbraco_client/tree/treeicons.css?cdv=460158730" type="text/css" rel="stylesheet"/>

    When I click on the link from "View Source" in Chrome it directs me to a link like:
    http://dev.mylocalsite.com/login.aspx?ReturnUrl=%2fumbraco%2flib%2frgrove-lazyload%2flazyload.js ;

    But when I run it on IISExpress through VS it actually takes me to the correct URL of 
    http://localhost:56458/umbraco/lib/rgrove-lazyload/lazyload.js ;

    What would my Local IIS be doing that IISExpress is not doing or vice versa.

     

  • Yakov Lebski 473 posts 1878 karma points
    Mar 11, 2015 @ 21:48
    Yakov Lebski
    0

    Did you install umbraco from nuget?

  • Carlos Mosqueda 239 posts 428 karma points
    Mar 11, 2015 @ 22:13
    Carlos Mosqueda
    0

    I did install Umbraco from Nuget originally, got the 7.1.8 version and did the manual upgrade to 7.2.2.  

  • Yakov Lebski 473 posts 1878 karma points
    Mar 11, 2015 @ 22:17
    Yakov Lebski
    0

    May be it's done automatically by installation, to be sure change version in ClientDependency.config and try again

  • Carlos Mosqueda 239 posts 428 karma points
    Mar 11, 2015 @ 22:27
    Carlos Mosqueda
    0

    yeh, not that.  

    I am going to try an fresh install from NuGet, copy over my UI files from my current, non working version and see if I can't get it to run to make sure it is nothing with the NuGet install.  

  • Yakov Lebski 473 posts 1878 karma points
    Mar 11, 2015 @ 22:29
    Yakov Lebski
    0

    Sometime update task not copy all files, you can try copy it manually from packages\UmbracoCms.7.2.2\UmbracoFiles folder

  • Carlos Mosqueda 239 posts 428 karma points
    Mar 11, 2015 @ 22:38
    Carlos Mosqueda
    0

    I have confirmed!!!!

    I had a brand new version of Umbraco 7.2.2 installed from NuGet into Visual Studio (2013).

    Went and changed my project properties on the Web tab. Made the URL a completely new URL. Went into my local host file and made the pointer, and in IIS made the site with the pointer.  

    When I went to launch it from Visual Studio to point to my new install, I get nothing when I try to go to the Umbraco backoffice. Just a blank page.

    When I changed VS to run from IISExpress, I was able to access the Backoffice. Or I got the login page to render.  Seems like a mapping issue someplace in the project with Local IIS vs IISExpress.

    I am wondering if anyone else can replicate this.  I will put it out as a bug on Issues.umbraco.org unless I am wrong.

  • Jeffrey Schwartz 3 posts 23 karma points
    Mar 13, 2015 @ 20:42
    Jeffrey Schwartz
    0

    Nope, you are correct.  I have the same exact issue.  There are several threads about this, and so far no answers that work for me.  I did a brand new nuget install in a blank asp,net mvc 4 website.  I am using Sql Server.  Works within VS 2013, not from IIS8

  • Carlos Mosqueda 239 posts 428 karma points
    Mar 14, 2015 @ 05:27
    Carlos Mosqueda
    100

    My issue actually pertained to permissions in the end. Network Service and local user rights need full rights. My local user account ended up not being included. Also make sure the App pool has network service as its identity (found in advanced settings for the app pool. )

  • Lennard Fonteijn 16 posts 72 karma points MVP 2x
    Mar 18, 2015 @ 13:56
    Lennard Fonteijn
    0

    For those affected by this issue, see my feedback on http://issues.umbraco.org/issue/U4-6396

    The place you first extract Umbraco to imposes security restrictions on the files. By extracting them at the right place immediately, or by moving your folder around in a particular order, the security restrictions get revoked and Umbraco starts working again.

  • Jeffrey Schwartz 3 posts 23 karma points
    Mar 18, 2015 @ 17:04
    Jeffrey Schwartz
    0

    I used nuget to install Umbraco.  There is no unpacking nor desktop in the mix.  Your original feedback was also to a person who used nuget.  I have added all the permissions for Network Service and IUSER. It really shouldn't be thos hard that so many people have the same problem.  Statistically, a very small percentage of people post their problems to a website, so the number of people who encounter this issue and simply give up must be quite large.

  • Lennard Fonteijn 16 posts 72 karma points MVP 2x
    Mar 18, 2015 @ 19:25
    Lennard Fonteijn
    0

    Yea, but where was your project originally located, upon NuGetting it?

    Just for the heck of it, try moving your project to some other drive. So if you main drive is C, move it to D, then try again by remapping IIS to that. Or an USB stick if you don't have other drives. The trick in my resolution was getting the whole project off your C-drive first.

    Also set your AppPool to LocalSystem for a moment, that saves you the trouble of having to set permissions as you move it around and you can exclude that as the problem.

  • Carlos Mosqueda 239 posts 428 karma points
    Mar 18, 2015 @ 20:26
    Carlos Mosqueda
    0

    @Jeffery et al,

    The issue is most always likely permissions.  Permissions are a good thing and are mostly relegated to IIS.  This is not necessarily and issue with Umbraco itself. 

    My issues 99% of the time have been issues with IIS itself and not Umbraco.  Sometimes Visual Studio and the way it handles threads and what not.

    My comment or original question actually related to IIS and not necessarily Umbraco. 

    Umbraco is an awesome and VERY flexible product, by design, to enable developers to develop very complex scenarios (if they want), by using a little .Net MVC and some HTML and JS.  

    In our instance, our companies network needs the App Pool set to Network Service.  In many cases it may not.

    But base permissions, just to be safe for IIS or on the folder, would be

    Network Service,
    IIS_IUSER,
    MachineName/LocalMachineUserName (mymachine/jsmith),
    NetworkName/NetworkUserName (if on a shared network).

    It might be frustrating at first, but that is the price you pay sometimes for a good secure website.  And it is nothing that someone can't learn.  

     

Please Sign in or register to post replies

Write your reply to:

Draft