Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Meni 164 posts 197 karma points
    Mar 25, 2015 @ 06:38
    Meni
    0

    Error when upgrading to the new version (7.2.x)

    Hey, It's the second time that it happened - when I upgraded to 7.2.2 and when upgraded again to 7.2.4 After the upgrade I got this error: " Compilation Error

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS0234: The type or namespace name 'Helpers' does not exist in the namespace 'Microsoft.Web' (are you missing an assembly reference?)

    Source Error:

    Line 29: using Umbraco.Core.Models; Line 30: using Umbraco.Web.Mvc; Line 31: using Microsoft.Web.Helpers; Line 32: using umbraco; Line 33: using Examine; "

    And it's annoying! Ok, somehow I've found here at the forums the solutions which is to find (somehow - I've find it in the previous versions bin folder) the Microsoft.Web.Helpers.dll file and copy it to the bin file - but yet, it's annoying! like, why at version 7! 7.2.4! this error repeat itself?? In wordpress it's not happened ! (and they just at their 4th version ...)

    And also - in the answer I saw in one of the forums here there's a link to the nuget to get the file, but the file is not available for download anymore, because somehow it's not available any more (there's a message that you have to install nuget or something).

    Umbraco team - please make sure to solve it at the next update.

    Thanks.

  • Chriztian Steinmeier 2732 posts 8346 karma points MVP 5x admin c-trib
    Mar 25, 2015 @ 09:17
    Chriztian Steinmeier
    0

    Hi Meni,

    I have the exact same error today - did throwing the DLL in there fix it for you?

    Sounds like the problem might be that I replaced the /bin folder while upgrading, where I should maybe have merged the folders...

    /Chriztian

  • Meni 164 posts 197 karma points
    Mar 25, 2015 @ 22:57
    Meni
    0

    Yes. Just throw this DLL at the Bin folder. Hopefully they'll fix it at the next update ...

  • Jason Prothero 421 posts 1242 karma points c-trib
    May 05, 2015 @ 19:27
    Jason Prothero
    2

    This was a tricky one.  There are web.config files in the MacroScripts and Views folder injected the Microsoft.Web.Helpers namespace in older versions.  This has now been removed in the 7.2.4 version.  Removing the assembly addition removes the need for that dll.

    I normally don't check those folders, but now it looks like I will need to in the future.

  • Steve 139 posts 320 karma points
    Feb 19, 2017 @ 20:35
    Steve
    0

    Jason,
    Thanks for the tip - this really helped us out!
    BR / Steve

Please Sign in or register to post replies

Write your reply to:

Draft