Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Raj 4 posts 54 karma points
    Apr 01, 2015 @ 22:07
    Raj
    0

    Async error installing Umbraco 7.2.4 using NuGet

    Hi,

    I've been evaluating Umbraco for the past couple of days! I've watched a lot of videos on Umbraco.tv and read a lot of articles.

    In terms on manually setting up the 7.2.4 manually on IIS and SQL Server - I thought it was a breeze. Very impressed from a user perspective in terms of how some of the guys in my team can utilise the CMS, it seems very flexible.

    My overall aim is to start to move some of of websites across to Umbraco. However, some of these sites may need some custom extension/developing in terms of third party integration. Hence a developer, I want to feel confident with the model of Umbraco in terms of extension to do some of these things.

    I've been maintaining a bespoke CMS system for nearly 7 years and I need to migrate to something more flexible... come in (hopefully) Umbraco.

    Anyhow - setting up manually from a zip - was a breeze. But going through the videos in terms of setting up Umbraco in VS2013 - I just haven't got it to work. After 4 hours - I am now a little fustrated, hence my first post for help!

    Running from VS I get this error:

    An asynchronous operation cannot be started at this time. Asynchronous operations may only be started within an asynchronous handler or module or during certain events in the Page lifecycle. If this exception occurred while executing a Page, ensure that the Page is marked <%@ Page Async="true" %>. This exception may also indicate an attempt to call an "async void" method, which is generally unsupported within ASP.NET request processing. Instead, the asynchronous method should return a Task, and the caller should await it.

     

    I also tried publishing the website and noticed the Umbraco assemblies were not also being copied to the target bin folder?

    I am getting a duplicate assembly reference with System.Net.Http (Might of been System.Web.Http)

    Should I been concerned that VS can't resolve this in the web.config:

    System.Web.Providers.DefaultSessionStateProvider

    And lastly do I need to setup/modify anything in the config folder?

    I was generally just hoping to have the same experience as the manual zip install - but apparently not!

    Sorry if I am just being stupid - I really hope so! (in a good way!)

    Originally I tried downloaing the source from GitHub > then publishing the web project from there - is that also wrong? (or does it depend on what I am doing?)

    A lot of questions I know!

    Any help would be great!

    Thanks.

     

  • Jan Skovgaard 11263 posts 23588 karma points MVP 8x admin c-trib
    Apr 01, 2015 @ 22:22
    Jan Skovgaard
    0

    Hi Raj and welcome to our :)

    Umbraco can be installed using either nuget in VS2013, which it sounds like you have been trying or you can do it manually. No matter the path you choose make sure to follow the official documentation about it, which you can find here https://our.umbraco.org/documentation/Installation/

    It's also a good idea to check the page about the system requirements to make sure that your machine is capable of running Umbraco at all.

    In regards to fetching the source from github...that's not recommended since that means you need to build the source code yourself and then make the installation after the building the package. That's only intended for when you want to contribute to fixing or enhancing core features.

    I hope this makes sense.

    /Jan

  • Raj 4 posts 54 karma points
    Apr 01, 2015 @ 23:06
    Raj
    0

    Thanks for the quick response! 

    I've followed that guide and checked my system requirements. 

    I guess now I'm wondering which is the best way to trouble shoot this.

    For example I am not sure the Async error is a red herring and the actual error is instalation or configuration? 

    If that makes sense? 

    Cheers. 

     

  • Raj 4 posts 54 karma points
    Apr 02, 2015 @ 09:28
    Raj
    0

    This morning I copied the web folder onto our dev server (rather than my local dev environment win8.1 iis8.5), which is win2.8 server with iis7.5

    But I got the same error... 

     

     

  • Raj 4 posts 54 karma points
    Apr 02, 2015 @ 09:32
    Raj
    100

    Fixed - Created a new empty VS MVC project.

    Deleted the unrequired items.

    Key bit - changed the framework from .Net 4 to .Net 4.5...

    Grabbed the latest nuget package for Umbraco...

    Built - ran locally...

    Bingo - it worked! 

    Now I can play!

     

  • rob 75 posts 170 karma points
    Jul 09, 2015 @ 09:42
    rob
    0

    Had a very weird issue with one server where our Umbraco solution was deployed and got the above error. All the dev machines and even live worked fine.

    Turned out it was the version of ImageProcessor.dll and ImageProcessor.Web.dll

    Fixed some legacy NuGet references in some satellite projects and now the build works on all servers. Very weird/annoying.

    Bad versions were in packages.config as

    <package id="ImageProcessor" version="1.9.5.0" targetFramework="net451" />
      <package id="ImageProcessor.Web" version="3.3.1.0" targetFramework="net451" />
    

    updated ones are

      <package id="ImageProcessor" version="2.2.3.0" targetFramework="net451" />
      <package id="ImageProcessor.Web" version="4.3.0.0" targetFramework="net451" />
    
Please Sign in or register to post replies

Write your reply to:

Draft