Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Costas Rigas 5 posts 25 karma points
    Jun 21, 2015 @ 19:35
    Costas Rigas
    0

    Umbraco 7 installation failure with locall IIS

    I tried many times to install umbraco (7.2.6). When I complete installation and try to login I get the message 'Session timed out. Log in below'. I cannot login.

    My OS is MS windows server 2008 R2. My local IIS version is 7.5. My database server SQLExpress 2012.

    I have tried manual installation, Web Platform Installer and WebMatrix. In all cases installation fails, giving above mentioned message, when selecting to use the local IIS.

    Nevertheless, installation completes successfully when selecting to use IIS Express!

    I tried everything I could find in the forum. No luck.

    Any suggestions?

  • Peter Gregory 407 posts 1612 karma points MVP 3x admin c-trib
    Jun 22, 2015 @ 01:36
    Peter Gregory
    1

    Have you looked in the logs to see if there are any errors? It could be many things from database connection issues to file permissions. The log file found in

    /app_data/logs/UmbracoTraceLog.txt

    may shed a little bit more light on the reasons.

  • Costas Rigas 5 posts 25 karma points
    Jun 22, 2015 @ 11:03
    Costas Rigas
    0

    This is part of UmbracoTraceLog.txt

    2015-06-22 13:53:51,950 [6] WARN Umbraco.Web.UmbracoModule - [T21/D11] Umbraco has no content 2015-06-22 13:53:57,956 [6] INFO Umbraco.Core.PluginManager - [T28/D11] Starting resolution types of Umbraco.Core.PropertyEditors.IParameterEditor 2015-06-22 13:53:57,956 [6] INFO Umbraco.Core.PluginManager - [T28/D11] Completed resolution of types of Umbraco.Core.PropertyEditors.IParameterEditor, found 44 (took 1ms) 2015-06-22 13:54:52,129 [6] INFO umbraco.BusinessLogic.Log - [T8/D11] Log scrubbed. Removed all items older than 2015-04-23 13:54:52 2015-06-22 13:54:52,706 [6] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [T36/D11] An error occurred with the scheduled publishing. The base url used in the request was: http://localhost:80/MyUmbracoSite/umbraco/, see http://our.umbraco.org/documentation/Using-Umbraco/Config-files/umbracoSettings/#ScheduledTasks documentation for details on setting a baseUrl if this is in error System.Net.WebException: The remote server returned an error: (404) Not Found. at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request) at System.Net.WebClient.UploadString(Uri address, String method, String data) at Umbraco.Web.Scheduling.ScheduledPublishing.PerformRun() 2015-06-22 13:54:59,960 [6] INFO Umbraco.Core.PluginManager - [T21/D11] Starting resolution types of Umbraco.Core.Persistence.Mappers.BaseMapper 2015-06-22 13:54:59,960 [6] INFO Umbraco.Core.PluginManager - [T21/D11] Completed resolution of types of Umbraco.Core.Persistence.Mappers.BaseMapper, found 23 (took 1ms) 2015-06-22 13:55:00,272 [6] INFO Umbraco.Core.Security.UmbracoMembershipProviderBase - [T21/D11] Login attempt succeeded for username [email protected] from IP address ::1 2015-06-22 13:55:00,460 [6] INFO Umbraco.Web.Security.WebSecurity - [T21/D11] User Id: 0 logged in

    I can see an error. Could that be causing failure? How is it resolved? I visited 'http://our.umbraco.org/documentation/Using-Umbraco/Config-files/umbracoSettings/#ScheduledTasks' but I cannot figure out what I am expected to do.

    Thanks

  • Carl Jackson 139 posts 478 karma points
    Jun 22, 2015 @ 11:53
    Carl Jackson
    0

    Hi,

    Just a suggestion but have you got the correct perissions set for the App pool user?

    There is a guide here if you are not sure

    https://our.umbraco.org/wiki/reference/files-and-folders/permissions

    Thanks

  • Costas Rigas 5 posts 25 karma points
    Jun 22, 2015 @ 12:36
    Costas Rigas
    0

    Group IIS_IUSRS has modify permisions to the root directory, where umbraco files and folders live.

  • Costas Rigas 5 posts 25 karma points
    Jun 24, 2015 @ 07:39
    Costas Rigas
    0

    I am struggling for quite a few days without success. Can someone help please?

  • Rik Helsen 670 posts 873 karma points
    Jun 24, 2015 @ 08:46
    Rik Helsen
    0

    The "ERROR Umbraco.Web.Scheduling.ScheduledPublishing" error should not prevent your site from loading.

    Log actually sais you succesfully logged in?

    "2015-06-22 13:55:00,460 [6] INFO Umbraco.Web.Security.WebSecurity - [T21/D11] User Id: 0 logged in"

    maybe clear all cookies, try in privacy modus or a different browser?

    • Maybe have a look with Fiddler to see if any requests are failing?
    • does your applicationpool user have write permissions on required .NET temp folders? (adding it to the IIS USERS group should suffice.)
    • have you tried forcing the inheritance of the permission on the files in the site? procedure:

    How about right-clicking each parent directory, going to Properties, then Security tab, then click Advanced, then click Change Permissions, then check that checkbox that says "Replace all child object permissions with inheritable permissions from this object"?

  • Rik Helsen 670 posts 873 karma points
    Jun 24, 2015 @ 08:50
    Rik Helsen
    0

    in this topic: https://our.umbraco.org/forum/getting-started/installing-umbraco/61849-Session-timedout-can-not-login-to-back-office-after-updating-to-Umbraco-722 one user fixed it by

    In your local IIS try setting up your umbraco site as a new website instead of a an application within a website.

  • MuirisOG 382 posts 1283 karma points
    Jun 24, 2015 @ 10:31
    MuirisOG
    0

    I had problems logging in because I hadn't configured SQL Server Express properly.

    You need to

    • make sure the blank database has been set up in SQL Server prior to your first login
    • make sure the SQL Server "umbraco" user is set up in Users, and in Roles (as dbo_owner) for that database
    • make sure when you select "Customise" in the initial umbraco setup, that you use [yourServerName]\SQLEXPRESS
    • check your web.config to see what the connection string is telling you
    • check your permissions! For a full list of things to do, check this page https://our.umbraco.org/wiki/install-and-setup/how-to-install-umbraco-on-windows-server-2008
  • Costas Rigas 5 posts 25 karma points
    Jun 25, 2015 @ 11:19
    Costas Rigas
    0

    Many thanks for all responses!

    The problem was solved following Rik Helsen's suggestion 'In your local IIS try setting up your umbraco site as a new website instead of a an application within a website'.

    Thanks again

Please Sign in or register to post replies

Write your reply to:

Draft