Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • clueless 5 posts 85 karma points
    Jul 17, 2015 @ 10:24

    Virtual Directory

    Hello! I’ve just started using Umbraco and I have used the following tutorial to get up and running

    At this point everything appears to have worked as expected. As part of the tutorial I have downloaded the latest version 7.2.8 at the time and I have created added the site into a virtual directory.

    From WebMatrix when I click the URL http://localhost:xxxxx the site opens and everything looks great. I’m not sure if this is relevant but the fonoe starter kit is installed but other than that this is a clean install. I can enter /umbraco/ after the URL and the admin section works perfectly.

    Now the problem. When I browse to the page displays but the css is not being applied and the images don’t display. Using firefox I can see the following error

    GET [HTTP/1.1 403 Forbidden]

    Initially I thought this was a security issue but then I noticed that the path above should be

    If I go back to the admin page and then go to the Master template under Settings -> Templates -> Master and change this line

    stylesheet" type="text/css" href="/css/fanoe.css to be stylesheet" type="text/css" href="~/css/fanoe.css (ie add a tilde in front /css) The css is now being applied but the images still won’t load.

    I’ve read the following article but umbracoUseDirectoryUrls in the web.config file was already set to true

    Also I have played around with change the image paths in the database as per

    If anyone is able to shed any light on what I am doing wrong it would be very much appreciated!! From my side it feels like I have missed a basic setting somewhere…….

  • Ste 14 posts 35 karma points
    Jul 17, 2015 @ 13:59


    I don't think I understand what the Virtual Directory is for, because you're not installing Umbaco in it, are you?

    Anyway it occurs to me you could look at the Culture and Hostnames option. Right-click the top level node in your Content side, and pick 'Culture and Hostnames'

    You should have in there already:


    Try adding your virtual directory like


    This may not be what you wanted to do! But check it out anyway.

    Also, be aware that you have spelt 'Directory' as 'Direcotry' everywhere I can see. Just check that your spelling matches everywhere! :)

    Hope this helps,

  • clueless 5 posts 85 karma points
    Jul 17, 2015 @ 17:30

    Hi Ste, Thanks for the response.

    This has definitely helped! I added into the Culture and Hostnames and now all the link are hanging together correctly so thank you but unfortunately the images are still not displaying.

    Regarding your question about the virtual directory, using the document as my reference point it says “start IIS Manager and right click on the Default Website and choose Add virtual directory.” This is where I have placed all the downloaded files.

    Somewhere I need to tell the application not to start at but start at as I have also noticed that when adding new media it is saved to /media not /virtualdirecotry/media

  • clueless 5 posts 85 karma points
    Jul 21, 2015 @ 15:10

    Although there are indication that you can install Umbraco into a virtual directory, I have completely dropped the idea.

  • Prashant 8 posts 78 karma points
    Aug 22, 2016 @ 15:53

    Hi Guys,

    Can someone please help me out for the resembling issue?

    I have configured an umbraco 7.3.1 website in IIS successfully and is working fine. Now, i have a requirement to add this Umbraco 7.3.1 Website to be inside a virtual directory converted to application in another parent website (Umbraco 7.3.1). But there is an issue while running that 7.3.1 site as subsite. When i tried to access this site as for example like, Umbraco7.3.1site/Umbraco7.3.1Subsite. We are getting the follwing error.

    enter image description here

    Please provide your solutions for it, i have wasted almost a week over it.

    My route for the 7.3.1 site is: "D:\delete me\UmbNewInstances\Parent" Route for the 7.3.1 subsite is: "D:\delete me\UmbNewInstances\Child"

    Let me know if someone wants any input from my side.

Please Sign in or register to post replies

Write your reply to: