Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • René Truelsen 4 posts 73 karma points
    Jul 22, 2015 @ 06:12
    René Truelsen
    1

    Web Application vs Website in Visual Studio

    Hey.

    I've installed Umbraco using Nuget in a Visual Studio Web Application (MVC) project, but I continously have to consider if new files have been included or not. Then I read an install guide, which recommended using a "Website project" instead of web application.

    So what are the caveats and advantages of using a website vs web application project?

    I've read a bit on different posts, which indicates that in the end it's a personal flavour, but I'm curious at the specific advantages and caveats at the two different approaches.

    RenĂ© Truelsen - [email protected]

    ;-)

  • Alex Skrypnyk 6054 posts 23213 karma points MVP 5x admin c-trib
    Jul 22, 2015 @ 13:05
    Alex Skrypnyk
    0

    Hi Rene,

    It's question of your preferences, what do you like more ?

    I prefer web application.

    Thanks

  • Mark Bowser 268 posts 855 karma points c-trib
    Jul 22, 2015 @ 17:14
    Mark Bowser
    1

    This page is really useful in understanding the differences: https://msdn.microsoft.com/en-us/library/dd547590(v=vs.110).aspx

    Here is a snippet I copied from that link:

    Scenarios in which web application projects are the preferred choice include the following:
        * You want to be able to use the Edit and Continue feature of the Visual Studio debugger.
        * You want to run unit tests on code that is in the class files that are associated with ASP.NET pages.
        * You want to refer to the classes that are associated with pages and user controls from standalone classes.
        * You want to establish project dependencies between multiple web projects.
        * You want the compiler to create a single assembly for the entire site.
        * You want control over the assembly name and version number that is generated for the site.
        * You want to use MSBuild or Team Build to compile the project. For example, you might want to add prebuild and postbuild steps.
        * You want to avoid putting source code on a production server.
    
    Scenarios in which Web site projects are the preferred choice include the following:
        * You want to include both C# and Visual Basic code in a single web project. (By default, a web application is compiled based on language settings in the project file. Exceptions can be made, but it is relatively difficult.)
        * You want to open the production site in Visual Studio and update it in real time by using FTP.
        * You do not want to have to explicitly compile the project in order to deploy it.
        * If you do precompile the site, you want the compiler to create multiple assemblies for the site, which can include one assembly per page or user control, or one or more assemblies per folder.
        * You want to be able to update individual files in production by just copying new versions to the production server, or by editing the files directly on the production server.
        * If you precompile the site, you want to be able to update individual ASP.NET web pages (.aspx files) without having to recompile the entire site.
        * You like to keep your source code on the production server because it can serve as an additional backup copy.
    

    Unfortunately, I have very little experience using the Website projects. I, too, am curious to hear more about the pros and cons.

  • Nicholas Westby 2043 posts 7020 karma points c-trib
    Dec 15, 2015 @ 00:07
    Nicholas Westby
    1

    I just tried to install Umbraco 7.3.4 using NuGet into a website (i.e., not a web application). I also note that the documentation says to install it with a web application rather than a website: https://our.umbraco.org/documentation/getting-started/setup/install/install-umbraco-with-nuget

    When I attempted to install into a website, I got a bunch of errors in the package manager console and files/folders were placed outside of the website folder. For example, I got an App_Data folder (containing the NuGetBackup folder) and a web.config in the website's parent folder (i.e., the same folder as the Visual Studio solution file).

    Have any of you been able to install Umbraco into a website with NuGet (i.e., rather than into a web application)?

    For anybody who is curious, here is what my package manager console said when I tried to install Umbraco:

    Each package is licensed to you by its owner. NuGet is not responsible for, nor does it grant any licenses to, third-party packages. Some packages may include dependencies which are governed by additional licenses. Follow the package source (feed) URL to determine any dependencies.
    
    Package Manager Console Host Version 3.3.0.167
    
    Type 'get-help NuGet' to see all available NuGet commands.
    
    PM> Install-Package UmbracoCms
    Attempting to gather dependencies information for package 'UmbracoCms.7.3.4' with respect to project 'MyClient.Website', targeting '.NETFramework,Version=v4.5.2'
    Attempting to resolve dependencies for package 'UmbracoCms.7.3.4' with DependencyBehavior 'Lowest'
    Resolving actions to install package 'UmbracoCms.7.3.4'
    Resolved actions to install package 'UmbracoCms.7.3.4'
    Adding package 'AutoMapper.3.0.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'AutoMapper.3.0.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'AutoMapper.3.0.0' to 'packages.config'
    Successfully installed 'AutoMapper 3.0.0' to MyClient.Website
    Adding package 'ClientDependency.1.8.4' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'ClientDependency.1.8.4' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'ClientDependency.1.8.4' to 'packages.config'
    Successfully installed 'ClientDependency 1.8.4' to MyClient.Website
    Adding package 'HtmlAgilityPack.1.4.9' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'HtmlAgilityPack.1.4.9' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'HtmlAgilityPack.1.4.9' to 'packages.config'
    Successfully installed 'HtmlAgilityPack 1.4.9' to MyClient.Website
    Adding package 'ImageProcessor.2.3.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'ImageProcessor.2.3.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'ImageProcessor.2.3.0' to 'packages.config'
    Successfully installed 'ImageProcessor 2.3.0' to MyClient.Website
    Adding package 'ImageProcessor.Web.4.4.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'ImageProcessor.Web.4.4.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'ImageProcessor.Web.4.4.0' to 'packages.config'
    Successfully installed 'ImageProcessor.Web 4.4.0' to MyClient.Website
    Adding package 'Microsoft.AspNet.Identity.Core.2.2.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.Identity.Core.2.2.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.Identity.Core.2.2.1' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.Identity.Core 2.2.1' to MyClient.Website
    Adding package 'Microsoft.AspNet.Razor.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.Razor.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.Razor.3.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.Razor 3.2.3' to MyClient.Website
    Adding package 'Microsoft.AspNet.WebPages.Data.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebPages.Data.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebPages.Data.3.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.WebPages.Data 3.2.3' to MyClient.Website
    Adding package 'Microsoft.AspNet.WebPages.WebData.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebPages.WebData.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebPages.WebData.3.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.WebPages.WebData 3.2.3' to MyClient.Website
    Adding package 'Microsoft.Bcl.Build.1.0.14' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Bcl.Build.1.0.14' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Bcl.Build.1.0.14' to 'packages.config'
    Executing script file 'C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1'
    You cannot call a method on a null-valued expression.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:18 char:5
    +     $import = $msbuild.Xml.AddImport($relativePath)
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    The property 'Condition' cannot be found on this object. Verify that the property exists and can be set.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:19 char:5
    +     $import.Condition = "Exists('$relativePath')"
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : PropertyNotFound
    
    You cannot call a method on a null-valued expression.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:22 char:5
    +     $target = $msbuild.Xml.AddTarget("EnsureBclBuildImported")
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    The property 'BeforeTargets' cannot be found on this object. Verify that the property exists and can be set.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:23 char:5
    +     $target.BeforeTargets = "BeforeBuild"
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : PropertyNotFound
    
    The property 'Condition' cannot be found on this object. Verify that the property exists and can be set.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:24 char:5
    +     $target.Condition = "'`$(BclBuildImported)' == ''"
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : PropertyNotFound
    
    You cannot call a method on a null-valued expression.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:27 char:5
    +     $errorTask = $target.AddTask("Error")
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    The property 'Condition' cannot be found on this object. Verify that the property exists and can be set.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:28 char:5
    +     $errorTask.Condition = "!Exists('$relativePath')"
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : PropertyNotFound
    
    You cannot call a method on a null-valued expression.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:29 char:5
    +     $errorTask.SetParameter("Text", "This project references NuGet package(s) th ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    You cannot call a method on a null-valued expression.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:30 char:2
    +     $errorTask.SetParameter("HelpKeyword", "BCLBUILD2001");
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    You cannot call a method on a null-valued expression.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:33 char:5
    +     $errorTask = $target.AddTask("Error")
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    The property 'Condition' cannot be found on this object. Verify that the property exists and can be set.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:34 char:5
    +     $errorTask.Condition = "Exists('$relativePath')"
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : PropertyNotFound
    
    You cannot call a method on a null-valued expression.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:35 char:5
    +     $errorTask.SetParameter("Text", "The build restored NuGet packages. Build th ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    You cannot call a method on a null-valued expression.
    At C:\r\MyClient\trunk\packages\Microsoft.Bcl.Build.1.0.14\tools\Install.ps1:36 char:2
    +     $errorTask.SetParameter("HelpKeyword", "BCLBUILD2002");
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull
    
    Successfully installed 'Microsoft.Bcl.Build 1.0.14' to MyClient.Website
    Adding package 'Microsoft.Bcl.1.1.10' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Bcl.1.1.10' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Bcl.1.1.10' to 'packages.config'
    Successfully installed 'Microsoft.Bcl 1.1.10' to MyClient.Website
    Adding package 'Microsoft.Net.Http.2.2.29' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Net.Http.2.2.29' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Net.Http.2.2.29' to 'packages.config'
    Successfully installed 'Microsoft.Net.Http 2.2.29' to MyClient.Website
    Adding package 'Microsoft.Web.Infrastructure.1.0.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Web.Infrastructure.1.0.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Web.Infrastructure.1.0.0' to 'packages.config'
    Successfully installed 'Microsoft.Web.Infrastructure 1.0.0' to MyClient.Website
    Adding package 'Microsoft.AspNet.WebPages.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebPages.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebPages.3.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.WebPages 3.2.3' to MyClient.Website
    Adding package 'Microsoft.AspNet.Mvc.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.Mvc.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.Mvc.5.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.Mvc 5.2.3' to MyClient.Website
    Adding package 'ClientDependency-Mvc5.1.8.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'ClientDependency-Mvc5.1.8.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'ClientDependency-Mvc5.1.8.0' to 'packages.config'
    Successfully installed 'ClientDependency-Mvc5 1.8.0' to MyClient.Website
    Adding package 'Microsoft.AspNet.WebHelpers.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebHelpers.3.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebHelpers.3.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.WebHelpers 3.2.3' to MyClient.Website
    Adding package 'MiniProfiler.2.1.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'MiniProfiler.2.1.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'MiniProfiler.2.1.0' to 'packages.config'
    Successfully installed 'MiniProfiler 2.1.0' to MyClient.Website
    Adding package 'MySql.Data.6.9.8' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'MySql.Data.6.9.8' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'MySql.Data.6.9.8' to 'packages.config'
    Successfully installed 'MySql.Data 6.9.8' to MyClient.Website
    Adding package 'Newtonsoft.Json.6.0.8' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Newtonsoft.Json.6.0.8' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Newtonsoft.Json.6.0.8' to 'packages.config'
    Executing script file 'C:\r\MyClient\trunk\packages\Newtonsoft.Json.6.0.8\tools\install.ps1'
    Successfully installed 'Newtonsoft.Json 6.0.8' to MyClient.Website
    Adding package 'Microsoft.AspNet.WebApi.Client.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebApi.Client.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebApi.Client.5.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.WebApi.Client 5.2.3' to MyClient.Website
    Adding package 'Microsoft.AspNet.WebApi.Core.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebApi.Core.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebApi.Core.5.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.WebApi.Core 5.2.3' to MyClient.Website
    Adding package 'Microsoft.AspNet.WebApi.WebHost.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebApi.WebHost.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebApi.WebHost.5.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.WebApi.WebHost 5.2.3' to MyClient.Website
    Adding package 'Microsoft.AspNet.WebApi.5.2.3', which only has dependencies, to project 'MyClient.Website'.
    Adding package 'Microsoft.AspNet.WebApi.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebApi.5.2.3' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.WebApi.5.2.3' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.WebApi 5.2.3' to MyClient.Website
    Adding package 'Owin.1.0.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Owin.1.0.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Owin.1.0.0' to 'packages.config'
    Successfully installed 'Owin 1.0.0' to MyClient.Website
    Adding package 'Microsoft.Owin.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.3.0.1' to 'packages.config'
    Successfully installed 'Microsoft.Owin 3.0.1' to MyClient.Website
    Adding package 'Microsoft.Owin.Host.SystemWeb.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.Host.SystemWeb.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.Host.SystemWeb.3.0.1' to 'packages.config'
    Successfully installed 'Microsoft.Owin.Host.SystemWeb 3.0.1' to MyClient.Website
    Adding package 'Microsoft.Owin.Security.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.Security.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.Security.3.0.1' to 'packages.config'
    Successfully installed 'Microsoft.Owin.Security 3.0.1' to MyClient.Website
    Adding package 'Microsoft.Owin.Security.Cookies.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.Security.Cookies.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.Security.Cookies.3.0.1' to 'packages.config'
    Successfully installed 'Microsoft.Owin.Security.Cookies 3.0.1' to MyClient.Website
    Adding package 'Microsoft.Owin.Security.OAuth.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.Security.OAuth.3.0.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.Owin.Security.OAuth.3.0.1' to 'packages.config'
    Successfully installed 'Microsoft.Owin.Security.OAuth 3.0.1' to MyClient.Website
    Adding package 'Microsoft.AspNet.Identity.Owin.2.2.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.Identity.Owin.2.2.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Microsoft.AspNet.Identity.Owin.2.2.1' to 'packages.config'
    Successfully installed 'Microsoft.AspNet.Identity.Owin 2.2.1' to MyClient.Website
    Adding package 'semver.1.1.2' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'semver.1.1.2' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'semver.1.1.2' to 'packages.config'
    Successfully installed 'semver 1.1.2' to MyClient.Website
    Adding package 'SharpZipLib.0.86.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'SharpZipLib.0.86.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'SharpZipLib.0.86.0' to 'packages.config'
    Successfully installed 'SharpZipLib 0.86.0' to MyClient.Website
    Adding package 'Lucene.Net.2.9.4.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Lucene.Net.2.9.4.1' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Lucene.Net.2.9.4.1' to 'packages.config'
    Successfully installed 'Lucene.Net 2.9.4.1' to MyClient.Website
    Adding package 'Examine.0.1.68' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Examine.0.1.68' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'Examine.0.1.68' to 'packages.config'
    Successfully installed 'Examine 0.1.68' to MyClient.Website
    Adding package 'xmlrpcnet.2.5.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'xmlrpcnet.2.5.0' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'xmlrpcnet.2.5.0' to 'packages.config'
    Successfully installed 'xmlrpcnet 2.5.0' to MyClient.Website
    Adding package 'UmbracoCms.Core.7.3.4' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'UmbracoCms.Core.7.3.4' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'UmbracoCms.Core.7.3.4' to 'packages.config'
    Executing script file 'C:\r\MyClient\trunk\packages\UmbracoCms.Core.7.3.4\tools\install.ps1'
    Successfully installed 'UmbracoCms.Core 7.3.4' to MyClient.Website
    Adding package 'UmbracoCms.7.3.4' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'UmbracoCms.7.3.4' to folder 'C:\r\MyClient\trunk\packages'
    Added package 'UmbracoCms.7.3.4' to 'packages.config'
    Executing script file 'C:\r\MyClient\trunk\packages\UmbracoCms.7.3.4\tools\install.ps1'
    Copy-Item : Cannot find path 'C:\r\MyClient\trunk\Web.config' because it does not exist.
    At C:\r\MyClient\trunk\packages\UmbracoCms.7.3.4\tools\install.ps1:15 char:2
    +     Copy-Item $webConfigSource $backupPath -Force
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (C:\r\MyClient\trunk\Web.config:String) [Copy-Item], ItemNotFoundException
        + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.CopyItemCommand
    
    Successfully installed 'UmbracoCms 7.3.4' to MyClient.Website
    PM> 
    

    The errors aren't obvious (the package manager console highlights them in red, but the text doesn't always indicate what is an error), but there are many.

Please Sign in or register to post replies

Write your reply to:

Draft