Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Ran Chen 40 posts 117 karma points
    Jul 27, 2015 @ 21:43
    Ran Chen
    0

    Umbraco 7 install on godaddy - stuck on initial page

    Trying to install version 7 on godaddy shared hosting: 1. created a virtual folder 2. uploaded all files to this folder 3. set web.config db connection string to a new clean ms sql server 4. added " " to web config 5. set folders permissions as advised on Umbraco documentation

    I do get the setup screen - but I do see only the splash screen, just image , no text - and no other content is loaded (also checked the db, it is still empty)

    Any idea ?

  • Casper Andersen 126 posts 508 karma points
    Jul 28, 2015 @ 07:55
    Casper Andersen
    0

    Your DB will remail empty until after you have typed the DB credentials or pressed install. What i would do first is to try and upload everything again, sometimes files can be skipped or completely missed

  • Steve Morgan 1022 posts 3186 karma points c-trib
    Jul 28, 2015 @ 07:58
    Steve Morgan
    0

    If you've unpacked the zip locally ensure you've unblocked the zip properly.

  • Ran Chen 40 posts 117 karma points
    Jul 29, 2015 @ 12:54
    Ran Chen
    0

    ok - I did manage to upload all the files and to run the umbraco setup.

    however, it is using the default db (sdf file) and I want to use an empty sql server instance I have .

    Before running the setup I've changed the web.config file with the new connection string, but then I've got an error: "Invalid object name 'cmsMember'" - and did not get the default umbraco setup screen.

    Can I change the default db during the setup ? since once Umbraco is installed I cannot modify the db (unless I'm doing a manual conversion from the sdf to an sql schema)

  • Casper Andersen 126 posts 508 karma points
    Jul 29, 2015 @ 13:26
    Casper Andersen
    0

    Yes you can, it's a bit hidden, but after you have told what your email, and password will be you have 2 options one is install, and the other one is configure or something along the lines of that. If you click configure you can tell Umbraco what database it should use and then give it the credentials needed.

    Hope this makes sense and answers your question. If i did then please mark whatever post was the solution so that other people in the future can easily find the solution.

  • Steve Morgan 1022 posts 3186 karma points c-trib
    Jul 29, 2015 @ 13:28
    Steve Morgan
    0

    Ran - the cmsMember error sounds like you didn't quite close the tag properly in your webconfig.

    I'd suggest you set this up locally (run SQL Server Express) and then copy your files up and restore a DB up if you're having problems.

  • jivan thapa 193 posts 658 karma points
    Jul 29, 2015 @ 13:34
    jivan thapa
    0

    Have you also remove the Umbraco version from the config file?

    Umbraco adds umbracoConfigurationStatus to the umbraco version that you have installed. Since you have an empty DB. You should remove the umbracoConfigurationStatus value as well.

    It should look like this one

    <appSettings>  <add key="umbracoConfigurationStatus" value="7.1.9" />
    

    Remove umbracoConfigurationStatus value to empty and Umbraco will reinstall.

    It should be like this one if DB is empty.

    <add key="umbracoConfigurationStatus" value="" />
    
  • Ran Chen 40 posts 117 karma points
    Jul 29, 2015 @ 14:46
    Ran Chen
    0

    Another one :

    Should I change the web.config somehow ?

    Attempt by security transparent method 'Umbraco.Core.UmbracoApplicationBase.StartApplication(System.Object, System.EventArgs)' to access security critical method 'System.AppDomain.add_UnhandledException(System.UnhandledExceptionEventHandler)' failed.
    
  • Steve Morgan 1022 posts 3186 karma points c-trib
    Jul 29, 2015 @ 15:08
    Steve Morgan
    0

    This sounds like you don't have Full Trust from host - you might need to raise a ticket and explain you're running Umbraco.

  • Ran Chen 40 posts 117 karma points
    Jul 29, 2015 @ 15:10
    Ran Chen
    0

    Seems like setting

    trust level="Full"

    under system.web prevents this error

  • John Palmer 63 posts 167 karma points
    Aug 10, 2015 @ 08:29
    John Palmer
    0

    I believe the issue is with permission. Please make sure you have given full permission or ask them to grant full permission for you. It should be work unless they dont support full trust.

  • Ran Chen 40 posts 117 karma points
    Aug 10, 2015 @ 08:30
    Ran Chen
    0

    It does.

    I can approve now that godaddy (shared Windows hosting) can support running an Umbraco instance.

  • Premkumar 5 posts 75 karma points
    Nov 24, 2015 @ 18:29
    Premkumar
    0
    <system.web>
    <securityPolicy>
        <trustLevel name="Full" policyFile="internal"/>
    </securityPolicy>
    ....
    ....
    </system.web>
    

    Is this what you tried Ran? It does not seem to be working in my case. Any pointers?

  • Ran Chen 40 posts 117 karma points
    Nov 24, 2015 @ 19:13
    Ran Chen
    1

    was checking my web. config, I have the following:

    <system.web>
        <trust level="Full" />
    

    in any case, I would like to state again that the site is running PERFECTLY on GoDaddy.

  • Simon Dingley 1393 posts 3245 karma points c-trib
    Sep 01, 2016 @ 10:55
    Simon Dingley
    0

    I have a customer who is insisting on using this cheap hosting service (false economy in my opinion) - thanks for sharing the solution! I wouldn't say "the site is running PERFECTLY on GoDaddy" but it is running. I don't believe in all honesty that it can run PERFECTLY on on those hosting packages.

  • ibrahim TUNC 39 posts 96 karma points
    Aug 31, 2015 @ 19:47
    ibrahim TUNC
    0

    I have same problem to. Godaddy support team said to me "Our system is normal your scripts may be wrong". I do not know how to solve this problem.

    Not: Database connection is normal. so no problem.

  • Carlos Casalicchio 104 posts 439 karma points
    Mar 15, 2016 @ 15:03
    Carlos Casalicchio
    0

    According to Godaddy you have to use the Trust Level Tag

    <trust level="Full" />
    

    https://www.godaddy.com/help/what-trust-level-can-i-use-when-running-aspnet-2531

    Just did that and it started working.

  • Jinesh Kaneriya 22 posts 155 karma points
    Sep 01, 2016 @ 11:51
    Jinesh Kaneriya
    0

    I also faced this problem. I found that godaddy basic hosting account not supported with .NET 4.5. Then I Upgrade my package and problem solved.

    Also make sure you have to set permission for app data folder.

  • Simon Dingley 1393 posts 3245 karma points c-trib
    Sep 01, 2016 @ 12:02
    Simon Dingley
    0

    That's a pain as well through their web interface. I really wouldn't recommend this sort of hosting for instances of applications like Umbraco.

  • Ran Chen 40 posts 117 karma points
    Sep 01, 2016 @ 18:50
    Ran Chen
    0

    Can you please elaborate on that ? I found the GoDaddy Plesk interface quite easy to use, but I will be more than happy to get more recommendation for Umbraco hosting services.

    Just stay away from HostForLIFE.eu (even it is recommended by Umbraco), they might be using other names such as asphostportal.com

  • Simon Dingley 1393 posts 3245 karma points c-trib
    Sep 02, 2016 @ 09:24
    Simon Dingley
    0

    For me it's like working with one hand tied behind my back, everything seems so much more difficult and time consuming or painfully slow, even FTP access which as I write has taken more than 30 seconds before it will upload a 3kb file! This is not something limited to just GoDaddy but I've found in general across other shared hosting platforms which get oversubscribed.

    Perhaps I have been spoilt by mostly working on projects that allow me complete access to the hosting environment to do what I need to do quickly and efficiently. A single command line sets all of the required file permissions instead of having to go in an out of every individual folder in the web UI to set permissions individually.

  • Carlos Casalicchio 104 posts 439 karma points
    Sep 02, 2016 @ 13:29
    Carlos Casalicchio
    0

    I actually use Godaddy free hosting with domain, just to test things before moving the site to a full blown hosting server (VPS).

    and just did a fresh install of 7.5.2 and after adding the full trust it worked just fine! (and made sure all folders had read/write permissions)

    <trust level="Full" />

    <configuration>
        <system.web>
            <trust level="Full" />
        </system.web>
    </configuration>
    

    This was for the classic hosting

    For Plesk, their instructions are as follows:

    1. Log in to your GoDaddy account.
    2. Click Web Hosting.
    3. Next to the hosting account you want to use, click Manage.
    4. At the bottom of the section of the domain hosting you want to use, click Show More.
    5. Click ASP.NET Settings.
    6. From the CAS trust level menu, select the settings you want, and then click OK.

    What trust level can I use when running ASP.NET?

Please Sign in or register to post replies

Write your reply to:

Draft