Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Rick 92 posts 278 karma points
    Sep 23, 2015 @ 16:04

    Problem installing Umbraco 7.2.8


    I'm wondering if someone can help ...

    I've tried to install Umbraco in a few different ways and I am seeing the same error each time the application boots up:

    • Web Matrix
    • Nuget
    • Manual install

    The message I see when the application loads is:

    Method not found: 'System.String Umbraco.Core.ApplicationContext.get_OriginalRequestUrl()'.
    [MissingMethodException: Method not found: 'System.String Umbraco.Core.ApplicationContext.get_OriginalRequestUrl()'.]

    Having used Umbraco for a fair number of years now I haven't come across this issue before and I'm not doing anything crazy with the install - but I'm starting to tear my hair out now!

    I'm on Windows 10, using .net 4.5.1.

    Can anyone help please?

    Thanks, Rick

  • Rick 92 posts 278 karma points
    Sep 23, 2015 @ 20:17

    To add to this...

    I've noticed that by running the nuget install - I'm missing some folders such as: - install - media - scripts

    ... to name but a few - despite nuget saying that it has successfully installed.

    If I manually copy the missing files to the directory - I still have the above error.

    I've also got Resharper disabled throughout all of this as well.



  • Rick 92 posts 278 karma points
    Oct 02, 2015 @ 11:46

    I thought I'd follow this up for anyone else that was experiencing this strange issue ...

    I took the rather drastic measure of rolling back from Windows 10 to Windows 8.1 (I was getting desperate) and the issue went away.

    Once I installed VS and installed Umbraco via Nuget, the site spun up and I was getting the nice and familiar Umbraco install screen.

    Hope this helps someone!


Please Sign in or register to post replies

Write your reply to: